Jump to content

Windows Firewall problem with nLite ?


Methanoid
 Share

Recommended Posts

Whatever I do I seem to be losing the Windows Firewall. Now that isnt a particular problem in that I have a Firewall in my router but it seems that removal of the service prevents some other things working so I have re-done my install CD so many times trying to get to the cause of this and also a strange bug I have where clicking on the Start button can sometimes cause the machine to partially hang until Explorer.exe is restarted.

Any ideas?

My Last Session.ini is below

[Main]

Env = 1.4.9.1 - 2.0.50727.3603.Microsoft Windows NT 5.1.2600 Service Pack 3

Target = Windows XP Professional SP3 - 5.1.2600.5512 - English (United States)

[Tasks]

Remove Components

Unattended Setup

Integrate Drivers

Hotfixes and Update Packs

Tweaks

Create a Bootable ISO

Options

[Components]

;# Applications #

Briefcase

ClipBook Viewer

Defragmenter

Games

Internet Games

Pinball

Screensavers

WordPad

;# Drivers #

Asynchronous Transfer Mode (ATM)

Cameras and Camcorders

Display Adapters

Display Adapters (old)

Ethernet (LAN)

IBM PS/2 TrackPoint

IBM ThinkPad

ISDN

Logitech WingMan

Microsoft SideWinder

Modems

Multifunctional

Portable Audio

Printers

Scanners

SCSI/RAID

Serial Pen Tablet

Sony Jog Dial

Sound Controllers

Tape drives

Toshiba DVD decoder card

Wireless Ethernet (WLAN)

;# Hardware Support #

Brother Devices

Gravis Digital GamePort

Iomega Zip drive

Multi-port serial adapters

Ramdisk

Smart Cards

;# Keyboards #

Albanian keyboard

(AND ALL EXCEPT UK English!!)

Zulu

;# Multimedia #

Music Samples

Tablet PC

;# Network #

MSN Explorer

;# Operating System Options #

Manual Install and Upgrade

Tour

;# Directories #

DOCS

ETH0

SUPPORT

VALUEADD

;# Compatibility #

Compat01

Compat02

Compat03

Compat04

Compat06

Compat07

Compat08

Compat09

Compat11

Compat13

Compat14

Compat16

[KeepFiles]

msconfig.exe

[RemoveFiles]

clock.avi

yahoo.bmp

swtchbrd.bmp

[Options]

CABMerge

ClassicSetup

BlackSetupBack

ProfilesDir = "%SystemDrive%\Documents and Settings"

TargetPath = "WINDOWS"

temp_dir = %USERPROFILE%\Local Settings\Temp

AdvTweaks

[Patches]

[services2]

[Tweaks]

Boot and Shutdown-Logon Page-Classic

Boot and Shutdown-Numlock-On

Desktop-Internet Explorer icon-Show

Desktop-My Computer icon-Show

Desktop-My Documents icon-Show

Desktop-My Network Places icon-Show

Desktop-Recycle Bin icon-Show

Explorer-Add 'Command Prompt' to folder context menu

Explorer-Associate additional file types with Notepad

Explorer-Change Windows Explorer folder view-Details

Explorer-Classic Control Panel

Explorer-Disable Prefix: Shortcut to

Explorer-Preset Places Bar to-C:, D:, E:, Desktop, My Network Places

Explorer-Remove Send To on context menu

Explorer-Show Drive Letters in front of Drive Names

Explorer-Show extensions of known file-types

Explorer-Show Map Network Drives buttons in Explorer bar

Explorer-Show Statusbar in all windows

Internet Explorer-Disable Download Complete notification

Internet Explorer-Disable Internet Explorer link creation

Internet Explorer-Disable Market Place bookmark

Internet Explorer-Disable Media Player 6.4 created bookmarks

Internet Explorer-Disable Outlook Express link creation

Internet Explorer-Enable Google URL-Search

Internet Explorer-Keep IE URL-History for-10 Days

Internet Explorer-Set Homepage-www.google.com

Internet Explorer-Set IE-Cache limit to-20 MB

Internet Explorer-Set Internet Explorer to accept 10 connects at a time

Internet Explorer-Set popup-blocker to high

My Computer-Remove Manage from Context Menu

My Computer-Remove Search from Context Menu

My Computer-Remove Shared Documents

Performance-Disable Last accessed Timestamp on files

Performance-Disable Optimize harddisk when idle

Performance-Disable paging of kernel and core-os

Performance-Disable Tracking of Broken Shortcut Links

Performance-Speed-up Access to AVI Media Files

Performance-Use Windows classic folders / No Tasks Sidepanel

Privacy-Remove Alexa

Start Menu-Disable and remove Documents list from the Start Menu

Start Menu-Disable Highlight newly installed programs

Start Menu-Do not use Personalized Menus

Start Menu-Hide Search button in Start Panel

Start Menu-My Computer-Display as a link

Start Menu-My Documents-Display as a link

Start Menu-My Music-Display as a link

Start Menu-My Network Places-Display as a link

Start Menu-My Pictures-Display as a link

Start Menu-Remove Help and Support

Start Menu-Remove Logoff User

Start Menu-Remove Pinned Apps List from Start Panel

Start Menu-Remove Search For People from Search

Start Menu-Remove Search the Internet from Search

Start Menu-Remove Set Program Access and Defaults

Start Menu-Remove User name

Start Menu-Remove Windows Catalog shortcut

Start Menu-Remove Windows Update shortcut

Taskbar-Disable Balloon Tips

Taskbar-Disable Group similar Taskbar buttons

Taskbar-Disable Hide inactive icons

Taskbar-Disable Language-Bar

Taskbar-Lock the Taskbar-No

Windows Media Player-Accept Privacy Statement

Windows Media Player-Disable auto-add music to library

Windows Media Player-Disable starting with Media Guide

Windows Media Player-Optimize fullscreen mode behavior

[unattended]

UnattendMode = 1

ComputerType = Automatic

AutoLogon = Administrator

OOBEOff

CustomLocales

Resolution = 1280x1024

BitsPerPel = 32 bit (True Color)

Vrefresh = 60 Hz

DisableSRestore

MaximumDataStorePercentOfDisk = 12

RestorePointLife = 30

DefaultThemesOff

DefaultStartPanelOff

DesktopTheme = Windows Classic|Windows Classic style|Normal

IISInstall = 2

AutoUpdates = 3

AutoUDay = 5

AutoUHour = 15

AUMinor

ProgFilesPath = "\Program Files"

[DesktopThemes]

C:\WINDOWS\Resources\Themes\Luna.theme

C:\WINDOWS\Resources\Themes\Windows Classic.theme

[NetAdapter1]

connname = ""

macaddress = ""

ipaddress = "192.168.0.1"

subnetmask = "255.255.255.0"

defaultgateway = ""

dnsserver1 = ""

dnsserver2 = ""

winsserver = ""

netbiossetting = "0"

ipxnetworknumber = "00000000"

ipxnetworkframetype = "0xFF"

[GuiRunOnce]

[Drivers]

D:\My_Utils\Win Sources\_My_Drivers\USB Apple Mobile Device\USBAAPL.inf,0

D:\My_Utils\Win Sources\_My_Drivers\VGA Radeon (Oct 09)\CX_83739.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Asus ACPI\atk2000.inf,0

D:\My_Utils\Win Sources\_My_Drivers\TV BGT3540_(Pinnacle 3010ix)\BGT3540_6.0.0.49_32bit\BGTCap.inf,0

D:\My_Utils\Win Sources\_My_Drivers\SND SB128_Driver\ctpci2K.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Printer Epson R220\E_DF1AIA.INF,0

D:\My_Utils\Win Sources\_My_Drivers\Intel Chipsets\2008s4el.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Wind VGA\igxp32.inf,0

D:\My_Utils\Win Sources\_My_Drivers\LAN Marvell_Yukon\yk51x86.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Nvidia 9300\SMU\smuc.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Nvidia 9300\SMBUS\nf4sys.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Nvidia 9300\Ethernet\nvenetfd.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Nvidia 9300\Awy\nvawy.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Nvidia 9300\AHCI-SATA\nvgts.inf,BUSDRV

D:\My_Utils\Win Sources\_My_Drivers\HDMI Audio (Nvidia) Asrock\nvhda.inf,0

D:\My_Utils\Win Sources\_My_Drivers\TV Pinnacle PCTV 2000i\RoyalTS.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Realtek Card Reader\RtsUStor.inf,0

D:\My_Utils\Win Sources\_My_Drivers\HDMI Audio (ATI)\HDAATI.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Wind WiFi Driver\net8187Se.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Realtek HD Audio\HDA.inf,0

D:\My_Utils\Win Sources\_My_Drivers\Realtek PCIE LAN\Netrtle.inf,0

[Hotfixes]

D:\My_Utils\Win Sources\_Addons\01_OnePiece_Windows_XP_Post-SP3_UpdatePack_v2.9.0_ENU.7z

D:\My_Utils\Win Sources\_Addons\02_ProgramAddons_dtoolsawx.cab

D:\My_Utils\Win Sources\_Addons\03_xable_Full-Unlocker-v1.8.7_addon.cab

D:\My_Utils\Win Sources\_Addons\04_ELiTE_AddOn_AcroReadLite92030.7z

All drivers are latest available from manufacturers. Likewise the Addons above. I use OnePiece pack for adding WMP11 and .NET 1.1 (although it doesnt seem to install .NET 1.1 at all according to the Javascript response I get when querying in IE8). Apart from the addons above, all other customisation is done by installing via RunOnceEx.cmd (as I was removing addons in case of conflicts).

Any ideas?

Link to comment
Share on other sites


I can fix the missing Firewall by this script but I should not need to really....

net stop winmgmt

rd /s /q %systemroot%\system32\wbem\Repository

rundll32.exe setupapi,InstallHinfSection WBEM 132 %windir%\inf\wbemoc.inf

net start winmgmt

for /r %%i in (%systemroot%\system32\wbem\*.dll) do regsvr32 /s "%%i"

for /r %%i in (%systemroot%\system32\wbem\*.exe) do "%%i" /regserver

winmgmt /clearadap

winmgmt /kill

winmgmt /unregserver

winmgmt /regserver

winmgmt /resyncperf

Link to comment
Share on other sites

;# Directories #

DOCS

ETH0 <--- And what's this folder? Not the Eth0 XP pirated versions?

SUPPORT

VALUEADD

Yes, your point is? I choose to use that rather than use my SP2 original as it came with SP3 pre-integrated. Just saved time. No problem.

Now, do you have something constructive to add to solving the problem?

Link to comment
Share on other sites

Yes, I do; however your method does not comply with home rules. Has it ever occurred to you that this may be the exact reason for failing in certain things that you do?

First things first: look at this post #4 about how to get your own CD in less than half an hour.

Then check if you have done anything to remove or wrongly set the services in the attached image.

Link to comment
Share on other sites

Thanks, I was beginning to think I'd have better gone back to my SP2 original.

Coincidentally I noticed a WMI issue in the Event Log even when I had re-added the WF/ICS service back.

So, back to SP2, then SP3 integrate and OnePiece pack. Can I do that in one session or separate only?

Link to comment
Share on other sites

1. Copy your XPSP2 CD in a folder, e.g. C:\XPCD\;

2. Put SP3 in folder C:\SP3\ and extract it (you can use 7-Zip, it's free); you should get a i386 folder

3. Open Command Prompt and enter this command

C:\SP3\i386\update\update.exe /Integrate:C:\XPCD\

Now you have an XPSP3 CD. Make an .ISO (open nLite, point it to your new XPSP3 folder and only choose the option to create the .ISO file) and after that use it every time you want to work with nLite. You add the OnePiece pack later with nLite.

Edited by Sp0iLedBrAt
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...