Jump to content

Win7 bootloader to boot linux from array on other hdd 2nd part


ColdFlo
 Share

Recommended Posts

I have windows 7 installed to array with all other drives not connected. Im using windows 7 on raptor raid 0 array with the mbr on this array. On a second 250gb hdd that i partitioned into 3 80gb +/- os drives and small swap for linux. I have snow leopard on the first partiton which boots fine when setup with easybcd. The next partition is gentoo with grub installed to that partition and the bootrecord on that partition. The third is a windows xp-64. The osx and xp partitions boot fine with easybcd but the gentoo partition wont boot. All I see is grub in upper left of screen. I am using all the settings I used previously which worked but now I cant get to the gentoo partition. I believe I need some kind of custom copy of the bootrecord from the gentoo partition. Ive tried the method from the port25 website and the easybcd method which i believe copies or creates a bootrecord itself that it copies then boots from root partition sending it to the corresponding partiton. Ive tried both methods so i believe I must make a custom bootrecord, but can't find any software or tools to do so. Any help would be appreciated.

Link to comment
Share on other sites


Link to comment
Share on other sites

I'd rather just use grub. Not interested in learning a new syntax(and rebooting a million times more) or can i just use grub.conf from the linux partition? You can use a grub bootrecord on an ntfs parition if initiated by bcd ive done it before. I dont think grub4dos will be any different than grub. The way grub works is there are stages stage one is the bootrecord which initiates stage 2 which i believe is what you see on the screen to select os when then initiates the kernel upon selection. The grub4dos second stage couldnt install to the linux partition. The problem is in the bootrecord aka stage 1 because its not getting to the linux partition. Have you done this personally?

Link to comment
Share on other sites

I dont think grub4dos will be any different than grub.

Good :). Stay with GRUB then. :hello:

The grub4dos second stage couldnt install to the linux partition.

grub4dos second stage cannot install ANYWHERE :w00t:, for the simple reason that a grub4dos second stage DOES NOT exist (grub4dos is monolithic).

Have you done this personally?

Of course NO :blink: , my hobby is using my free time posting on boards to actually purposedly deceive other members by pointing them in the wrong directions, suggesting them to do things I never tried myself and that have no chance to ever work. :whistle:

However, and just for the record, grub4dos is GRUB, with a number of added features (commands/syntax are the same as GRUB, of course with added commands for the added features) that make possible a good interaction with Microsoft Operating Systems while keeping the "GRUB principles" untouched, but if you are happy thinking that it won't work, it's allright, I can go and mislead someone else, no problem. ;)

jaclaz

Edited by jaclaz
Link to comment
Share on other sites

Situation

- Gentoo is in second harddisk (0x81) in second partition (0x81,1).

- You have grub stage2 inside (0x81,1) with stage 1 in the boot record of (0x81,1).

- You have made a copy of boot sector of (0x81,1) into a file in C: partition.

- You have created a BCD entry to load boot sector file.

- When you select this BCD entry, GRUB stage1 runs and shows "GRUB" on screen but it seems stage2 does not run.

Analysis

- stage2 is on (0x81)

- stage1 think stage2 is in (0x80). It load some sectors from (0x80) instead of real stage2.

Suggestion

1. Use your existing GRUB.

- Read http://mirror.href.com/thestarman/asm/mbr/GRUB.htm

- Open your boot sector file in a hex editor. Look at offset 0x0040. Its old value is probably FF or 80. Change it to 81. Save file.

2. Use GRUB4DOS. This is also easy.

- Copy grldr and grldr.mbr to C:\

- Create BCD entry to load grldr.mbr as a boot sector

- When you select this BCD entry, GRUB4DOS should be able to find your (hd1,1)/boot/grub/menu.lst automatically.

Or you can specify its device and path in C:\menu.lst

default 0
timeout 1
title Gentoo boot menu
root (hd1,1)
configfile /boot/grub/menu.lst

Edited by karyonix
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...