Jump to content

karyonix

Member
  • Posts

    6
  • Joined

  • Last visited

  • Donations

    $0.00 

About karyonix

  • Birthday 08/16/1982

karyonix's Achievements

0

Reputation

  1. It is VirtualBox BIOS bug. 1. Normally, BIOS writes number of hard disk drives to memory at address 0x475. In VirtualBox this byte is always 1, no matter how many disk is installed. This is bug. 2. When you select non-first hard disk in BIOS boot selection menu, in most (all?) PCs I have tried, the selected drive gets drive number 0x80 and other drives get 0x81,0x82 ... . In VirtualBox, the selected drive have the same drive number as when it is not selected. If you select second hard disk, it gets drive number 0x81. This can be considered non-bug, just different behavior. 1+2 together : You cannot boot GRUB4DOS from second drive. Workaround : Don't use F12 and 2. Change drives order in Settings storage page.
  2. If you tell ISO file name to WinVBlock in step 2, it should keep ISO file opened without having to use cmd trick. Or you may try FiraDisk 0.0.1.30 with ISO file name in its parameter in small mem drive.
  3. Without additional software : I don't know. With a disk filter driver made for this purpose : Yes. See bootland thread "Page file in USB hard disk" for more information.
  4. - press F8, disable driver signature enforcement, boot into Windows - bcdedit /set {current} testsigning on - make sure your .sys is signed
  5. Situation - Gentoo is in second harddisk (0x81) in second partition (0x81,1). - You have grub stage2 inside (0x81,1) with stage 1 in the boot record of (0x81,1). - You have made a copy of boot sector of (0x81,1) into a file in C: partition. - You have created a BCD entry to load boot sector file. - When you select this BCD entry, GRUB stage1 runs and shows "GRUB" on screen but it seems stage2 does not run. Analysis - stage2 is on (0x81) - stage1 think stage2 is in (0x80). It load some sectors from (0x80) instead of real stage2. Suggestion 1. Use your existing GRUB. - Read http://mirror.href.com/thestarman/asm/mbr/GRUB.htm - Open your boot sector file in a hex editor. Look at offset 0x0040. Its old value is probably FF or 80. Change it to 81. Save file. 2. Use GRUB4DOS. This is also easy. - Copy grldr and grldr.mbr to C:\ - Create BCD entry to load grldr.mbr as a boot sector - When you select this BCD entry, GRUB4DOS should be able to find your (hd1,1)/boot/grub/menu.lst automatically. Or you can specify its device and path in C:\menu.lst default 0 timeout 1 title Gentoo boot menu root (hd1,1) configfile /boot/grub/menu.lst


×
×
  • Create New...