Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


problem with ATI graphic... (Solved)

Recommended Posts


this stupid thing never happened to me before.

i'm win98SE user

Mobo: P4B533

VGA: Hightech Excalibur (ATI) 9250

i can't start windows normaly, it just hangs with black-sreen & unresponsive keyboard after the "Starting windows 98...", i have to hit the reset button :blink:

i do however can access the safe mode, and i found out if i uninstall the ATI display driver, windows will start normaly.

if i tried to install the ATI display driver again (any offical version for win9x/ME), it will hangs again at restart.


Problem solved by copying vflatd.vxd into windows\system directory.

see also: http://www.msfn.org/board/98-fix-t12005.html

Edited by Joseph_sw

Share this post

Link to post
Share on other sites

first of all check if your mobo drivers are working. try to reinstall them. also try to install newer driver. when all fails try to return system registry to day when the system was working.

Share this post

Link to post
Share on other sites

I had a similar problem once with a much older card. I fixed it by removing all traces of the old ATI driver before installing the new one. I can't guarantee this will work in your case -- or even if it is safe to do -- but here's what I did:

Boot to safe mode and uninstall the ATI driver. Once normally back in Windows in glorious VGA, hit F3 to bring up file search, and search C: drive using filename [ati*.*] without the brackets. If anything comes up, right click on each to check its properties and make sure it's an ATI file. If it is, delete it. If an .inf file shows up, run notepad and open up the .inf. If it is an ATI .inf, delete it also.

So now any ATI dregs are gone from the hard drive. Next, backup the registry. Then run Regedit and go to HKEY_CURRENT_USER\SOFTWARE and delete any ATI software key. On mine it was "ATI Technologies". Do the same in HKEY_LOCAL_MACHINE\SOFTWARE. Then go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Display and examine the subkey(s). If there is more than one they will be numbered from 0000, 0001 etc. If any of these mention ATI, delete the entire subkey (e.g., if 0000 is for ATI, delete 0000.) Finally go to HKEY_LOCAL_MACHINE\Enum\PCI and go through the keys. If any mention the ATI card, delete the key.

All done. Reboot, and when Windows detects the ATI card, don't let it search for a driver -- hit the browse button and point it to the driver INF you want to install. Or, if the driver is in an installation exe, just cancel the new hardware wizard and run the exe instead. Once the ATI driver has been installed, hopefully it's cheers all around. But if the problem persists you'll at least know that it's not due to corrupted ATI files, version mismatches or inherited ATI registry settings.

EDIT: Forgot to include this: in Regedit go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion and check the Run keys (Run, RunOnce, RunServices, etc) for any ATI entries and delete them.

Edited by chromatic47

Share this post

Link to post
Share on other sites

thank you for the suggestions.

i tried it all, reinstalling mobo driver, removing all traces of ATI drivers, reinstalling ATI display driver, even restoring user.dat/system.dat/system.ini/win.ini from various rb####.cab that created while everything was ok.

the problem still persisted...

is this problem was in the hardware? but Dos Application, that use other modes better than 640x480x4bit was works normaly, such as SEA graphics viewers (tried both on real DosMode & full-screen command prompt), dos games, even VBETest from scitech display doctor...

i need to run bussiness application, but that application won't run on 4bit video modes.

for time being is the alternative drivers for ATI Radeon 9250?

it doesn't need to have full hardware support, but enough to have other video modes to works normaly.

Share this post

Link to post
Share on other sites

puting hardware acceleration down may do some thing and if u can get to it look what it says in device mananger

would have said go to dxdaig but ur in safe mode so never mind

may be conflick with some other hard ware

and try Turning all start up items off

plus mabye scaning for spyware or some thing wouold be good becasue some like this dont happen for no reson

Share this post

Link to post
Share on other sites

i'm have already try the hardware acceleration slider before starting to make this thread.

however, you may be right, something probably happened to other system files.

anyway i found a bit more info:

it seems if i reinstall ATI Radeon 9250 driver,

then i open regedit, and remove the string value minivdd, minivdd2, on registry key mentioned by chromatic47




only delete those whose used by primary display.

i can start windows using ATI Display Driver BUT in standard vga mode (640x480x4bit),

at start windows will give choice to change the video mode resolution,

but it won't works, as its require restart (not a forced restart, thankfully) and,

per restart it will revert back into the std vga mode.

value of minivdd was "ATI2VXAG.VXD"

the secondary also use it, but i don't delete it from registry.

Share this post

Link to post
Share on other sites

Your new info brings up another possibility -- unless there is onboard video on the motherboard, or unless there is another video card plugged in, there should only be the single 0000 display key. No other is necessary.

If that's the case (only the ATI adapter is available) then redundant keys can be deleted:

1) In regedit go to HKEY_LOCAL_MACHINE\Enum\PCI. Locate the VEN_ key for the video card and look at the string value for Driver (right-side panel under the BUS subkey). If it doesn't say "DISPLAY\0000" then change it to 0000. (Again, the only reason it would need to say 0001 is if the motherboard has onboard video or if there is a second video card occupying a slot.)

2) Go to HKLM\...Services\Class\Display and delete all keys but one complete key referencing the ATI card. It should be a complete key that contains the original minivdd entries. If the "untouched original values" key is number 0001, rename it to 0000. So after this action there is only one Display key, 0000, with all original values.

Now Enum\PCI points to the driver in Display\0000, and Display\0000 points to the ATI driver with no redundant keys mixup possible. This should make all resolutions available again. If Windows tries to re-install the ATI driver on reboot -- let it -- but then repeat the above procedure, but this time keep only the highest numbered Display key (the one most recently installed), rename it to 0000 and rename the Enum driver entry to DISPLAY\0000 as before. Reboot again and all should be well with no install prompt.

Hope this helps. If it doesn't, there may be a hardware failure because we have just told Windows how to get from card detection to proper driver in a straight line.

EDIT: Nope not hardware failure, I just saw your results using higher VESA modes in DOS. If 800x600x8bit is working in DOS it should work in Windows too. :blink:

Edited by chromatic47

Share this post

Link to post
Share on other sites

thank you for all, the problem finaly solved

thanks to starcraftmaster for pointing that may be something wrong with system files, you're right it was.

thanks to chromatic47 for pointing the registry key, indeed the problem was related to it, without your advice i'm probably still looking in the dark.

the problem was related to vdd.


i notice that it was something minivdd.

so i thought, if it was 'mini' what about the non-'mini' ?

i looked for vdd in that key, found something stuff like this:


iirc, i saw something like that in drwatson report backthen.

i checked file that have similar name both in windows directories and installer .CAB files.

it seems vflatd.vxd existed in windows installer cab, but not in windows system directory...

i decided to extract that file, copy it into windows\system directory,

reinstall driver, restart, and ... it works.

it works? to make it sure, turn-off computer, turn-it on again, restart once again.

confirmed: problem solved! joy.

the problem is now solved, but there thing that make me wonder:

  • vflatd.vxd wasn't bundled in downloaded driver packages,
    it seems driver maker assume that file was already there in each computer?
    well, i go to check friend computer who also using ATI graphics card (also using win9x), i don't found the vflatd.vxd in his computer, but nothing wrong with his display driver.
    i also have bootlog.txt that was created when there was the problem, the enty on bootlog.txt: (when there was no vlfatd.vxd file)
[000FBEEA] Loading Vxd = vflatd
[000FBEEA] LoadSuccess = vflatd
[000FBF53] DEVICEINIT = Display1
[000FBF53] DEVICEINIT = Display2
[000FBFA1] INITCOMPLETE = Display1
[000FBFA1] INITCOMPLETE = Display2

yes, i even re-run setup.exe from win98SE installer disc before i come up with this solution, re-running setup doesn't solve it.
(thankfully, i doesn't go to complete OS re-install, yet)
what was exactly going on with my system?

anyway thanks to you all, this problem was solved :yes:

Share this post

Link to post
Share on other sites

Excellent. :w00t:

And, what you found about vflatd.vxd jogged my memory about certain drivers being bundled into vmm32.vxd instead of loading separately. There is a way to tell in Device Manager which are bundled, and if they are then placed separately into windows\system and-or windows\system\vmm32 it can cure problems with various devices, and also boost system efficiency and free up some resources and memory. Some say it helps, some say it doesn't .. but it obviously worked for you.

Check this old thread from MSFN:


(Especially the posts by Shotgun.)

Now thanks to your solution I can make some possible improvements too. B)

Edited by chromatic47

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.