Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


The Life and Times of Unclesocks

Recommended Posts

I am making this thread to use as a reference for anyone helping me troubleshoot any networking or server related issues I end up having, or with things I am trying out just for fun or whatever.

Dev Network

DECOMMISSIONED: UNCLESOCKS.shark.attacksyou (Server 2003 Standard SP1)

Purpose - DNS Server and Infrastruture FSMO

Mainboard - Intel D945GNT

DECOMMISSIONED: 7Server.shark.attacksyou (Server 2008 Standard x64)

Config - Intel SE7520DB2SATA2

UPDATE: Reused temporarily as WDS (Server 2008 Standard R2 x64), name: IMAGEX.SABRES.COM

Production Network

Computer Name: Imagex.WDS.Local (Server 2008 Standard x64)

This server was a rebuild from my eval 2008, which I made with non-certified hardware. This one is all certified. Server relocated to MA and rebuilt in a new chassis.


- Intel S5000PSL

- 2x Intel Xeon 2.4GHz Quad-Core CPUs

- 16GB Fully-Buffered RAM

- 80GB SATA RAID1 (onboard)

- 1.76TB RAID10 (storage)

- 3Ware 9550SXU-8LP 64bit SATA RAID

- 2x Intel Gigabit NICs (onboard) TEAMed

- 2x Intel Gigabit NICs (PCI) TEAMed but not used (performance issues)

- apps: Active Directory, Domain Controller, Microsoft OPK for Vista SP1, DHCP, DNS, WDS, PXE, TFTP

DECOMMISSIONED: LIONCASH.iherdulike.mudkipz (Server 2008 R2 Standard x64)

Purpose - PXE Boot Passmark BurnInTest Pro

Mainboard - Intel S3210SHLC


Computer Name: AARON RULES

Multi-testing system


- Intel DQ35JO



- T-7 Storm Series Military Grade Hard Drive enclosure

- 1.5GB RAM

- XFX nVidia GeForce NX8600GT 256MB PCI-E x16

Computer Name: Wind (Windows 7 Professional)


- MSI 9S7-N01162-044 (Unbranded Wind)

- Intel Atom 1.6GHz


- 80GB Toshiba Mobile HDD

Corporate Network

Computer Name: DAI-ATLAS (Windows 7 Professional x86)

This is my regular workstation


- Intel DQ45FC

- Intel Core 2 2.40GHz

- 4GB DDR2


- 2x WD 160GB SATA HDD


- ATI FireMV

- 3x 17" AOC LCD Monitors

- apps: AutoIT v3.3.0.0, Macromedia Fireworks MX 2004, MS Office 2010 Professional Plus, MS Visual Studio Team System 2008


Config - MSI MS-1722 Barebone Notebook

DECOMMISSIONED: LOCKERCHECK (Server 2003 Standard x86)

Purpose - secondary Dev Webserver

Mainboard - Intel S875WP1-E

Edited by Tripredacus

Share this post

Link to post
Share on other sites

GHOSTSERVER decided to take a crap yesterday at 14:10. I noticed my VM box wasn't getting an IP (and I needed to test an IP app I wrote) so I checked the server. I hit the button for the KVM but the screen is black. The server is still running (can hear its loudness from under the desk) so maybe it is asleep?

Well I press the Ctrl+Alt+Del to see what happens, but it actually started to boot up? The usual DEGRADED welcome screen on the 3Ware came up, and it booted into Windows. The event viewer says that the computer experienced an unexpected shutdown at 14:10 on 10/01/08, but the computer clearly wasn't off when I "rebooted" it today.

Anyone know what may have happened?

PS: the mouse stopped working on it too... annoying using Event Viewer with the keyboard. :angry:

Share this post

Link to post
Share on other sites

Ghostserver was checked out by our Server Lord on Friday and he "fixed it" only to fail about 30 minutes later. So he checked it again and recommended that we replace one of the drives to rebuild the array. Today I got a new Western Digital 250GB SATA II RAID Edition drive, which is now waiting for the Server Lord to come into work tomorrow.

I got to come in early this morning to pull a migration. We moved the production Ghost/File Server (Vistaserver) across the room. Rewire the room. Remove 4 NetGear routers. Renamed the WDS to Imagex. Added Vistaserver to the domain. Wrote up a new SoP for the Imagex Server regarding file usage and naming conventions, access privledges, etc.

We are still suffering from the .83% Upload limit for whatever reason, which is delaying me updating all the Vista images. I get to contact a dude at Microsoft about that, since I get better results on an upload to Uncle Socks than to Imagex. Makes no sense to me really.

Deployment times are averaging around 2 minutes for a 3GB+ image... not too bad eh?

An additional difference is that after joining Vistaserver to the domain, and logging into the domain, it stopped allowing remote connections without a password. Previously it was set up to automatically accept all incoming connections with the Guest account. I'm not sure if it really matters enough for me to change that back.

Currently, Sixshot is swapped out and is being used to recreate standard Vista images, to be used until I craft up some autounattend goodness to launch from the distribution share.

Share this post

Link to post
Share on other sites

Forgot to update yesterday. We pulled out the Ghostserver, opened it up just to find out that it had a hot-swap SAS enclosure... :realmad:

So anyways the 3Ware firmware was saying that SATA 0 was a problem, so we pulled it. Take a look to see and it says Western Digital 400GB RAID Edition... Right well back into stock goes that 250GB and to hunt for the 400GB. It seems that the 400 isn't as popular as the 250 for some reason and we don't actively stock them anymore. I went into the back and found the LAST REMAINING ONE IN THE BUILDING! Well actually I did find a few more later but they were not usuable as they were up for sale on The Ebay.

So we swapped out the holder and put the new drive in. Then we boot up the server and go into the 3Ware and...

It doesn't see ANY drives...

So right now the server is SOL until we can figure out how to make the 3Ware see at least one of the drives.

The most challenging part was getting the server out from where it was sitting. I didn't really figure I'd ever have to move it EVER so I kinda wired up the KVM system around it... woops. And so it took 3 people to move the thing out of there, 2 to pick up the server and 1 to hold the KVM switch up...


Share this post

Link to post
Share on other sites


- The Old Ghostserver got its new RAID built, with no hot spare. 3 drives RAID1. Server 2008 Standard 64bit got installed but haven't gotten around to doing anything with it.

- Our Server Lord has been complaining that his RDP session to VISTASERVER gets disconnected. I've been struggling with trying to figure out why.


- Found out that Ghost won't put images into a certain folder anymore, complaining that the drive is out of space. That is totally wrong. I did a test and can put a WIM in that folder with imagex, so its limited to a Ghost issue. Unfortunately, we do not have a support contract with Symantec anymore, so we are going to just have to work around the issue.


Imagex.WDS is experiencing all sorts of minor issues, all found while checking for audit events after turning on the account logon failure audit rules to troubleshoot the RDP issue.

- Microsoft Windows Security, Event ID 4769

A Kerberos service ticket was requested.


Account Domain: WDS.Local

Service Name: krbtgt

Service ID: NULL SID

Ticket Options: 0x60810010

Failure Code: 0xe

Unfortunately, this seems to be more of a generic message that gets recorded, although to be able to turn off the option would be great. A possible solution was to use auditpol to change the logging, but I haven't figured out how to use that program yet.

- An IPsec Main Mode negotiation failed. Cause: no policy defined.... :wacko:

- The Windows Filtering Platform has blocked a bind to a local port. LSASS and SVCHOST connecting to ports in the 50,000 range, using protocol 17 (UDP). Windows Firewall is not enabled. I ran a port scanner, but it did something to the server, which it took the other virtual NIC in the team and gave it the same IP as the Team itself. End result was an IP conflict occurred, and the Team IP became the standard Automatic Configuration 169.258.x.x IP Address, which dropped DHCP to the domain. Since the team has a static IP, you can't release or renew the IP. I rebooted the server and it came back. I also tried another program but it was not recording the data properly. Still stuck on this one. Its annoying because there are about 3 events logged every second about this.

- Kerberos Key Distribution Center ID 29. Smart Card requirement for authentication is enabled automatically. We don't use it and there is no Personal Certificate installed, thus I can't request a new one.


- The network upload issue is sitting in limbo. We got permission to open a support ticket with Microsoft using the OEM Connect Channel, but something happened with our account and we can't log into the site... :blink:

It seems the further I go into Server 2008, the more stuff I gotta fix...

Share this post

Link to post
Share on other sites

GhostServer: Drive 2 fell off the array. We are thinking there is a bad slot. The RAID will get rebuilt on Monday and we can hopefully use it. New direction: This server will act as a backup server for VISTASERVER, since it seems to be having storage issues ATM.

IMAGEX.WDS: Still trying to fix some of the previous errors. WDS is flaking out about not having a WinPE for x64 even though we use it every day. Disabled LDAP signing requirement, but its still complaining about not having a certificate... Disabled Windows Firewall, but the Filtering Service is still blocking ports. Code Integrity is saying that tcpip.sys doesn't match the hash. Power Management is saying that it couldn't apply powr settings to any of the 8 cores, and we should do a firmware update. Maybe we can do that today. Intel posted a new one for the S5000PSL just yesterday. Online Help says it can't update to the internet. No wonder there. DHCP service says it can't update DNS records...

Not sure if we want it to update DNS records. There are only a handful of computers that should have a DNS record, all the rest are only on the network for maybe 2-3 days tops. It would be pointless for those to get recorded.

Share this post

Link to post
Share on other sites

I spent all day fixing up the old Ghostserver. We came to the conclusion that we needed a different drive enclosure. The one that was in there, for some reason, the rails weren't designed properly so the drives would move around in there. I took the whole thing apart, and found a 3 drive enclosure to use. I also had to replace the backplane on the single drive bay, which I used one from the old enclosure. That thing is hella dusty and my fingers were black by the time I was done. The motherboard, I found, is an Intel SE7501CW2 and it does NOT have any onboard SATA. So now I am using just 4 hard drives connected to the RAID card. The prospective outlook is: 80GB JBOD and 3x 400GB RAID5. Server 2008 is being installed on it now and hopefully there won't be any problems with it. It will be used to backup the Vistaserver because of its recent Ghost issues.

Share this post

Link to post
Share on other sites

Unclesocks has been transformed from Server 2003 to XP Embedded. It is still 2003 tho. Changed the larger images and start menu item. Also replaced the logon.scr so that the screen saver says Embedded instead of Server. This was difficult because DEP kept reverting to the original version. It took a bit of trickery but I got it to be replaced. It still says Server 2003 during boot and in Computer Properties, but I do not know how to change those. I uploaded some screenshots to show how it looks now.


I edited this one to take out a word. :sneaky: I had forgotten that I had previously changed some of the string tables when I was bored a few months back.


Next up, installing OPK for Windows 7. Last ISO burn failed to install, now waiting on another one. Also need to check out the new HTA version, haven't gotten a chance for that yet.

Share this post

Link to post
Share on other sites

Trying to install Server 2008 x64 Standard onto PHOBOS. Which means it will probably get renamed again. Anyways, the install DVD throws an error claiming the CPU might not support 64bit instructions... This is so bad. Here's the specs via CPU-Z, but I gotta find out if I can install x64 on this. It has x86 on it right now, but it was never activated, as it was the DSP copy. It boots up and says it isn't genuine. The x64 version is VLK.


Number of processors 2

Number of cores 1 per processor

Number of threads 2 per processor

Name Intel Xeon

Code Name Prestonia

Specification Intel® Xeon CPU 2.40GHz

Package Socket 604 mPGA

Family/Model/Stepping F.2.5

Extended Family/Model F.2

Brand ID 11

Core Stepping M0

Technology 0.13 um

Core Speed 2392.3 MHz

Multiplier x Bus speed 18.0 x 132.9 MHz

Rated Bus speed 531.6 MHz

Stock frequency 2400 MHz

Instruction sets MMX, SSE, SSE2

L1 Data cache (per processor) 8 KBytes, 4-way set associative, 64-byte line size

Trace cache (per processor) 12 Kuops, 8-way set associative

L2 cache (per processor) 512 KBytes, 8-way set associative, 64-byte line size

Chipset & Memory

Northbridge Intel E7501 rev. A1

Southbridge Intel 82801CA (ICH3-S) rev. 02

Memory Type DDR

Memory Size 3072 MBytes

Memory Frequency 132.9 MHz (1:1)

CAS# Latency (tCL) 2.5 clocks

RAS# to CAS# (tRCD) 3 clocks

RAS# Precharge (tRP) 3 clocks

Cycle Time (tRAS) 6 clocks


System Manufacturer Intel Corporation

System Name SE7501CW2

System S/N 0123456789

Mainboard Vendor Intel Corporation

Mainboard Model SE7501CW2 Board

BIOS Vendor Phoenix Technologies LTD

BIOS Version E7501CW20.86B.0026.P08.0312181024

BIOS Date 12/18/2003

Memory SPD

Module 1 DDR, PC2300 (142 MHz), 1024 MBytes, unknown brand

Module 2 DDR, PC2100 (133 MHz), 512 MBytes, unknown brand

Module 3 DDR, PC2300 (142 MHz), 1024 MBytes, unknown brand

Module 4 DDR, PC2100 (133 MHz), 512 MBytes, unknown brand


Windows Version Microsoft Windows Vista (6.0) Service Pack 1 (Build 6001)

DirectX Version 10.0

Hmm, two different speeds of memory isn't a good idea. I guess this is what happens when you rescue a server from the garbage, you never have any idea what is in it!

The CPU appears to be this one:


This might turn out bad. Also here is from the TPS:

The Intel® E7501 chipset provides a 36-bit address, 64-bit data processor host bus interface,

operating at 533MHz in the AGTL+ signaling environment. The MCH component of the chipset

provides an integrated memory controller, an 8-bit hub interface, and three 16-bit hub interfaces.

The hub interface provides the interface to two 64-bit, 133- / 100- / 66- / 33-MHz, Rev 2.2

compliant PCI-X bus via the P64H2. The Intel® Server Board SE7501CW2 directly supports up to

8GB of ECC memory, using four DDR200 or DDR266 compliant ECC DIMMs. DDR200 DIMMs

will run at 400MHz. The ECC implementation in the MCH can detect and correct single-bit errors,

and it can detect multiple-bit errors, and supports Intel® x4 Single Device Data Correction with

DIMMs that use x4 technology.

I might have to do an upgrade or trade one of my extra machines for another server? We shall see...

Share this post

Link to post
Share on other sites

Our Network admin is also trying to set up a new Oracle backup server. It is to run the same OS as mine. He had problems getting RAID to work with his board and upgraded to an S5000VSA. So he gave me his backup board, which included memory, CPUs, heatsinks and IO Plate. I went through and pulled out the old board and installed the new one.

I updated the config in the first post for PHOBOS. That name will likely change. The new board is an Intel SE7520BD2SATA2. 2x Xeons and 4GB RAM. We are going to try installing Server 2008 on it later today or sometime soon hopefully. I checked the specs on this board and it was tested to work with 64bit Server 2003. I do not require it to be fully funtioning or to be officially supported by Microsoft like the Oracle backup server does. So this is why I am fine with using uncertified hardware with it. If we have problems using the SATA driver for onboard, I know that we can always use the Beta RAID driver for the 3Ware card.

I am now wondering what is to become of the old parts that I took out. I doubt they could be resold, maybe I can buy them on the cheap!

Share this post

Link to post
Share on other sites



Promoted to be a Domain Controller for SHARK

Migrated Schema Master, Domain Naming Master, Relative ID Master and PDC FSMO Roles.

Currently Unclesocks retains PXE, DHCP, DNS, WDS and the Infrastructure FSMO Role

Share this post

Link to post
Share on other sites

Added new server (lioncash) in the first post. Just finished setting it up today! Also, SMART failure on 7Server. Replaced the drive and is now rebuilding.


Share this post

Link to post
Share on other sites

I just totally jacked up my Wind netbook! As noted above, its using Windows 7 Starter. Yesterday I installed Sun VirtuaBox on it.

At first all the tech dudes at work were telling me... um I don't think that's going to work out/it doesn't support virt, etc. Well I showed them all! I created a 20GB VDI and installed... wait for it... VISTA BUSINESS SP1 x86! HAHAHA

Of course it did take about 2 hours to install. And also the Experience Index rating hit a 1.0. Is that the lowest it can be? Anyways, I'm going to be taking a Vista cert for work (don't ask) and didn't have a Vista PC to refer to at home.

Unfortunately, Vista isn't activated, so it will time-bomb in 30 days, fortunately, the test is in 3 weeks!

So I wonder what the heck is up with Starter... I didn't think I'd be able to run a VM inside it, let alone Vista... What are the limitations of Starter besides changing the wallpaper?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.