Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Mr Snrub

Patron
  • Content Count

    765
  • Donations

    $0.00 
  • Joined

  • Last visited

Everything posted by Mr Snrub

  1. Testing a virtual machine environment is a good idea, but neither Virtual PC or VMWare support 64-bit guest machines yet so you can't do this.
  2. I have a large number of laptops which I want to have an unattended XP install for, and all will connect to disjointed networks through the onboard WLAN and LAN adapters. WLAN adapter is first in the adpater list and I would like the LAN adapter to be first - as far as I can tell the only way to alter the order is through the GUI: - Control Panel / Network connections - Advanced / Advanced Settings menu option - Up & Down buttons to set desired order, then OK netsh doesn't appear to have any ability to do this, and there are stacks of binary registry keys updated when you alter the order. Is there any cunning way I can set the adapter order during or post installation?
  3. I did it slightly differently, using an "avgsetup.ini" file which contains the licence number: HIDE: DONT_START_APPS: NO_WELCOME: NO_AVGW_STARTUP: QUIT_IF_INSTALLED: LOG: "C:\AVG7INST.LOG" TARGET_DIR: "C:\Program Files\AVG7" NAME: "my name here" COMPANY: "my company here" LICNO: "my-free-licence-code-here" This is how it is called from postinst.cmd: start /w %systemdrive%\Install\AVG\avgsetup.exe /script_file %systemdrive%\Install\AVG\avgsetup.ini And this is the clever bit, to update it immediately after installation, assuming you have Internet connectivity: start /w %systemdrive%\Install\AVG\avginetl.exe /UPDATE_AVG "avginetl.exe" is extracted from the "AVG Admin" tool from Grisoft's website - http://www.grisoft.com/us/us_dwnl7.php?ver=8 - a command line tool to perform an update, as I couldn't figure out a way to initiate one without a pop-up prompt with the standard EXEs. As far as I know this only works for v7.0 (beta), I think the switches are a little different for v6.x. I don't know if this means you can use the entries in the script file as switches on the command line (e.g. avgsetup.exe /HIDE /DONT_START_APP /LICNO "licence-code"), but I find it a little tidier to keep these things out of the batch file anyway.
  4. I have now finished my XP Pro SP2 DVD and I'm happy with it, but I'd like to make an unattended Windows 2003 Enterprise Edition CD now - I can install the pre-SP1 hotfixes, run & kill gdidettool, install MSDE no problem. But I can't figure out a way to get IIS, COM+, ASP.NET and Terminal Services added during installation too - is it possible? This is for a rebuild of my web server which is currently Windows 2000 Server, and I want to get it 100% smooth using Virtual PC 2004 SP1 before I touch the server itself. The Deployment Tool doesn't seem to have any options for components, and I've seen no WINNT.SIF files with anything likely-looking, so is it even possible?
  5. Here is the code I use for setting up my Shuttle SS51G, which successfully names and configures my 2 NICs: [Networking] InstallDefaultComponents=No [NetAdapters] Adapter1=params.Adapter1 Adapter2=params.Adapter2 [params.Adapter1] ConnectionName="nVidia 100Mbps" INFID=PCI\VEN_10EC&DEV_8139&SUBSYS_813910EC [params.Adapter2] ConnectionName="CNet 1Gbps" INFID=PCI\VEN_100B&DEV_0022&SUBSYS_00000000 [NetClients] MS_MSClient=params.MS_MSClient [NetServices] MS_SERVER=params.MS_SERVER [NetProtocols] MS_TCPIP=params.MS_TCPIP [NetBindings] Enable="MS_Server, MS_NetBT, MS_TCPIP, Adapter1" Enable="MS_Server, MS_NetBT, MS_TCPIP, Adapter2" [params.MS_TCPIP] DNS=No UseDomainNameDevolution=No EnableLMHosts=Yes AdapterSections=params.MS_TCPIP.Adapter1,params.MS_TCPIP.Adapter2 [params.MS_TCPIP.Adapter1] SpecificTo=Adapter1 DHCP=No IPAddress=10.0.0.2 SubnetMask=255.255.255.0 NetBIOSOptions=0 [params.MS_TCPIP.Adapter2] SpecificTo=Adapter2 DHCP=No IPAddress=192.168.1.2 SubnetMask=255.255.255.0 DefaultGateway=192.168.1.254 DNSServerSearchOrder=192.168.1.254 WINS=Yes WinsServerList=192.168.1.80 NetBIOSOptions=1
  6. You are using an encrypted password and it still manages to auto logon, and just once? Whenever I have an encrypted password set in WINNT.SIF, it does not log in after installation and has to be done manually. Also, I find that "AutoAdminLogon" seems to be permanently set as it logs in after every reboot when I install. What am I doing wrong?
  7. Still having problems - Cleartype is not selected, though font smoothing is checked and "standard" is selected. Menu animations are still enabled, set to "fade effect". Complete HKCU.reg: Windows Registry Editor Version 5.00 ;================================= ; HKEY_CURRENT_USER ;================================= ;Disable sticky keys [HKEY_CURRENT_USER\Control Panel\Accessibility\StickyKeys] "Flags"="506" ;Enable Cleartype [HKEY_CURRENT_USER\Control Panel\Desktop] "FontSmoothing"="2" "FontSmoothingType=dword:00000002 ;Prevents Internet Explorer windows from being reused [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main] "AllowWindowReuse"=dword:00000000 ;Disable "Links" folder in Favourites [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar] "LinksFolderName"="" ;Stop MSN Messenger loading automatically, disable tabs, etc. [HKEY_CURRENT_USER\Software\Microsoft\MSNMessenger] "PassportBalloon"=hex:29,00,00,00 "FirstTimeUser"=dword:00000000 "AppSettings"=hex:30,8c,00,00 "SharePassportCredentials"=hex:00,00,00,00 "DisableTabs"=hex:01,00,00,00 ;Disable "Hide inactive icons" [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer] "EnableAutoTray"=dword:00000000 ;Disable hiding of file extensions [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer] "HideFileExt"=dword:00000000 ;Show compressed files in alternate colour [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer] "ShowCompColor"=dword:00000001 ;Disable "Most Frequently Used" shortcuts from Start Menu [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer] "NoStartMenuMFUprogramsList"=dword:00000001 ;Enable "Classic" Windows [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] "ClassicViewState"=dword:00000001 "ForceClassicControlPanel"=dword:00000001 ;Configure settings for explorer and Start Menu views [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced] "Hidden"=dword:00000001 "ShowCompColor"=dword:00000001 "HideFileExt"=dword:00000000 "DontPrettyPath"=dword:00000000 "ShowInfoTip"=dword:00000000 "HideIcons"=dword:00000000 "MapNetDrvBtn"=dword:00000000 "WebView"=dword:00000000 "Filter"=dword:00000000 "SuperHidden"=dword:00000001 "SeparateProcess"=dword:00000001 "ListviewAlphaSelect"=dword:00000001 "ListviewShadow"=dword:00000001 "ListviewWatermark"=dword:00000001 "TaskbarAnimations"=dword:00000001 "StartMenuInit"=dword:00000002 "StartButtonBalloonTip"=dword:00000002 "StartMenuAdminTools"=dword:00000001 "StartMenuFavorites"=dword:00000000 "StartMenuRun"=dword:00000001 "StartMenuChange"=dword:00000001 "CascadeControlPanel"="NO" "CascadeMyDocuments"="NO" "CascadeMyPictures"="NO" "CascadeNetworkConnections"="NO" "CascadePrinters"="NO" "StartMenuScrollPrograms"="NO" "IntelliMenus"=dword:00000000 "TaskbarSizeMove"=dword:00000000 "TaskbarGlomming"=dword:00000000 "NoNetCrawling"=dword:00000000 "FolderContentsInfoTip"=dword:00000000 "FriendlyTree"=dword:00000000 "WebViewBarricade"=dword:00000001 "DisableThumbnailCache"=dword:00000000 "ShowSuperHidden"=dword:00000001 "ClassicViewState"=dword:00000001 "PersistBrowsers"=dword:00000001 "Start_ShowNetPlaces_ShouldShow"=dword:00000041 "Start_LargeMFUIcons"=dword:00000000 "Start_MinMFU"=dword:00000000 "Start_ShowNetPlaces"=dword:00000001 "Start_ShowNetConn"=dword:00000001 "Start_ShowControlPanel"=dword:00000001 "Start_EnableDragDrop"=dword:00000001 "Start_ShowHelp"=dword:00000000 "Start_ShowMyComputer"=dword:00000001 "Start_ShowMyDocs"=dword:00000000 "Start_ShowMyMusic"=dword:00000000 "Start_ShowMyPics"=dword:00000000 "Start_ShowPrinters"=dword:00000000 "Start_ShowRun"=dword:00000001 "Start_ScrollPrograms"=dword:00000000 "Start_ShowSearch"=dword:00000001 "Start_ShowRecentDocs"=dword:00000000 "Start_AutoCascade"=dword:00000001 "Start_NotifyNewApps"=dword:00000000 "Start_AdminToolsRoot"=dword:00000000 "ServerAdminUI"=dword:00000000 "Start_ShowSetProgramAccessAndDefaults"=dword:00000000 ;Disable the Desktop Cleanup Wizard [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Desktop\CleanupWiz] "NoRun"=dword:00000001 ;Automatically sort Start Menu icons in alphabetical order [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\Start Menu] ;Disable menu animations [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\VisualEffects\MenuAnimation] "DefaultValue"=dword:00000000 "DefaultApplied"=dword:00000000 ;Max your Internet Explorer's simultaneous downloads to 10 (default was 2) [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings] "MaxConnectionsPer1_0Server"=dword:0000000a "MaxConnectionsPerServer"=dword:0000000a ;Removes Sign up with Passport Wizard when trying to sign in MSN Messenger [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Passport] "RegistrationCompleted"=dword:00000001 ;NoRecentDocsmenu removes the recent documents from the start menu. [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] "NoRecentDocsMenu"=dword:00000001 Are there any conflicts in here? I've verified it isn't the theme I'm applying during install by switching to classic Windows and back, it doesn't affect the "effects" settings at all.
  8. I just call it using "start" (no /w) - then it spawns a new process window, runs to completion and closes it so you don't get the output in the main window. i.e. start pskill.exe killmenow.exe
  9. SP1? Yeah, original release version bluescreened or froze my main machine when trying to install an XP SP2 guest, and took about 4 hours on my secondary PC. SP1 has really improved stability and performance for XP SP2 guests - now the entire process is ~1 hour to install and put my apps on. Last I read, it should be available to the public in a couple of weeks.
  10. Thanks guys Aaron - I thought at first I had tried that key, but it was one under HKCU and the key was called "WebView" but didn't work on my last install attempt, thanks! Tsunami - thanks for the correction and additions! Ryan - yeah I was using RegMon to pull out the keys modified in realtime but it seems there may be more than one way to control certain features, and only some work when applied with during-install tweaks. Good job Virtual PC 2004 SP1 makes this a lot quicker than messing about with real CDs! *toddles off to make another ISO*
  11. First up, this is a great resource for all things Microsofty - a few days ago I thought making a bootable slipstreamed CD for XP or 2K was "advanced" I now have my unattended XP SP2 CD almost perfect, just a couple of things I would like to iron out: During installation, cmdlines.txt is tweaking my HKCU options (hkcu.reg). After installation the PC logs in to run postinst.cmd, which does further registry tweaks (tweaks.reg), silently installs my apps, deletes the installation files copied over, then auto reboots after a 5 minute delay. Start Menu issues: Want to remove the "Help and Support" icon Want to add the "Network Connections" icon I have successfully tweaked the other options such as disabling taskbar glomming, hiding inactive icons, highlight new programs, etc., but the above elude me. ClearType not enabling: tweaks.reg has this in, but it doesn't seem to work: [HKEY_USERS\.DEFAULT\Control Panel\Desktop] "FontSmoothing"="2" "FontSmoothingType=dword:00000002 Disable menu effects: Don't want any fading or sliding of menus, how can I turn this off for all users? Explorer "Use Windows classic folders" option under Tools / Folder Options - how can I set this during install? Any advice much appreciated
×
×
  • Create New...