Jump to content

sysprep reseal & wmp11.inf error


Recommended Posts

Hello, and thanks Tomcat76, TommyP, and all the other contributors to HFSLIP for an awesome package.

I first tried it out a week or two ago, and it saves me LOTS of time.

Here's the issue:

I have slipstreamed all critical updates, IE7, and WMP11 with version 1.2.1.

The install from CD works flawless.

I built a disk image based on this install, running sysprep -mini -reseal.

The first time a user logs on (after an image has been applied, and sysprep has

run the mini-setup), there is an error from Advanced INF Install about

the lack of wmp11.inf in C:\Windows\inf. I looked myself, and wmp11.inf isn't present.

HFSLP156.inf references it multiple times... even in [Copy.INF.WMP] (it's pointed at 17,

which I believe is %windir%\inf, but I'm not sure).

The error is little more than an annoyance, as it apparently just keeps shortcuts from

being created. I can manually launch media player and everything works OK.

It just makes a fully unattended image procedure kind of attended.

Thanks for your time, and let me know what info you need to troubleshoot this

issue... I'll gladly provide it.

Link to comment
Share on other sites

hi ob1kenob! welcome to HFSLIP! :) maybe you need to attach the following files (as i always do, most specifically if you use addons): HFSLIP.LOG, DOSNET.INF, HFSLIPWU.INF, SVCPACK.INF, SYSOC.IN_, TXTSETUP.SIF for TC & TP might require it too ... ;)

Link to comment
Share on other sites

I'm also encountering this error.

Which is also present in the newest test release of HFSLIP.

The error seems to only occur after I've added personal reg tweak files and or batch tweaks..

I'm in the process of narrowing down what tweak maybe causing the issue, I don't believe this is an HFSLIP problem.

Edited by antonio_king
Link to comment
Share on other sites

If I remember well, someone once had a similar issue with wmp10.inf.

It doesn't make sense to me though. This is what should be happening:


2) HFSLIPWU.INF calls the [DefaultInstall] section from HFSLP156.INF

At no point there are requests for wmp*.inf so I don't understand why SysPrep (or a similar tool) causes Windows setup to look for it. Do you still get an error if you remove all instances of wmp11.inf from HFSLP156.INF?

Link to comment
Share on other sites

OK, taking Kiki's advice ;)

Attached are the requested files (and also hfslp156.inf) in a zip.

Can I help anyone as far as getting the info Kiki just told me onto the

website and/or hfslip.log?

@Tomcat76: I hadn't thought of that approach (edit HFSLP156.inf) but I did grab

wmp11.inf from the installer... and was going to dump it in %windir%\inf and see

what happens.

Will let you know.


Link to comment
Share on other sites

Unfortunately I haven't had the opportunity to try out your suggestion, TC. The image I had created wouldn't load on my spare PC (HAL incompatibility). I also haven't had the chance to test the image with the wmp11.inf file added.

It may take me another day or so, but I won't forget.

After some thought on antonio_king's comments, Office Pro 2003 and Symantec Client Security (Corporate AV/Firewall) were added before the creation of the problem image. I need to sysprep a baseline install with no software and see if I can reproduce the issue.

Edited by ob1kenob
Link to comment
Share on other sites

Hi all !

It was me, the WMP10 error.

The workaround i used for WMP10 and sysprep is here : http://www.msfn.org/board/index.php?s=&amp...st&p=485671

I use the same workaround for WMP11 and XP Pro / Corp.

With XP Home it's also working but i'm facing another issue explained here :


Link to comment
Share on other sites

OK, I still haven't had the chance to do a clean install test... :( or the solution Tomcat suggested (remove references to wmp11.inf) but I can verify that putting wmp11.inf in the %windir%\inf directory manually fixes the problem. Since I'm building hard drive images from the install created by the CD, this is really minor problem for myself, as I just push an image back to a drive, alter the contents, and create an updated image.

Another thing I forgot to mention in the earlier posts, I'm building with XP Pro Corporate.

I also noticed that wmp11.inf is included in the WMP11 installer, so what would be the problem with hfslip just copying it into %windir%\inf? Would that be more difficult than changing the creation/content of hfslp156.inf? I know it involves dosnet.inf and txtsetup.sif... it's been since the NT4 days since I've modified them, though!

Expanding on EmRod's solution, closely related to my idea above, could there be yet another inf that copies wmp11.inf into the proper place? It could be created conditionally based on the inclusion of wmp10/wmp11.

Don't hesitate to tell me which ideas should be flushed, but I would actually like to know why any given idea would be bad... and I'm sure there are dozens of lurkers that do too.

Link to comment
Share on other sites

Well... I'd prefer to have one file instead of two. Additionally, wmp11.inf would be a dead file since you can't uninstall WMP11 if it has been slipstreamed.

That's why I suggested to remove all instances of wmp11.inf from HFSLP156.INF.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...