Jump to content

[error] XP not recognizing 2nd IDE channel


Recommended Posts

This is frustrating me and I haven't been able to figure it out myself.

After a fresh install of XP Pro SP2 the secondary IDE channel isn't recognized. Whatever I connect to it does show up during the POST, and is available in DOS. With a different primary HDD with Win98 installed it works fine as well.

In Device Manager I get the black exclamation point on a yellow background.

Device Status: This device cannot find enough free resources that it can use (Code 12).

If you want to use this device you will need to disable one of the other devices on this system.

Not enough free resources? Christ, I barely have anything connected as it is! One HDD, and I've disabled LAN, audio, and serial/parallel ports in the BIOS.... what else does it want, my first born?

I click on the Resources tab and the IRQ 15 icon has the red circle with a line through it, with the message "Interrupt Request 15 is not available." The "use automatic settings" option is checked, but it's grayed out so I can't change it. I've tried:

1. Changing the BIOS settings for PnP devices to manual, but I still couldn't access it in Device Manager.

2. Uninstalling IDE #2 in Device Manager and letting XP recognize it during the next boot.

I have this problem with a fresh install of XP, and after installing all the motherboard drivers. There's plenty of Google info regarding this Code 12, but two hours of looking through it hasn't helped me. One final thing I'll mention is that this PC isn't currently connected to the internet so I haven't gotten any updates.

Suggestions welcome, giftwrapping unneccessary.

Edited by E-66
Link to comment
Share on other sites

could be a couple of things.....

jumper settings on the HDD? Possibly RAID settings in BIOS? Have you tried vanilla XP without SP2?

I had a perfectly good new HDD in my PC not long ago and it (eventually) worked a treat then i put SP2 on and it stopped working. If i used SP2 slipstreamed it didn't work either. Took me ages to get it working but this sounds slightly different

Can i ask what kind of motherboard is it? What HDD is it? And if you are getting into windows OK, what are you plugging into IDE 2? CD/DVD drive? another HDD?

I'm thinking F6 during setup and having the correct motherboard RAID drivers (mine eventually started working when i slipstreamed RAID drivers into my install CD SP2 included)

Also, if you use the secondary IDE port for your XP HDD, does the primary IDE then show the same error in windows?


Link to comment
Share on other sites

Sorry for not getting back to this, been busy.

The board is a DFI NF3 250-AL. The 2nd IDE channel not being recognized happened regardless of whether I had anything connected to the channel or not.

At the moment the problem is fixed, but I tried so many different things that I was surprised when it finally worked and now I have to sit back and think of what I did to get it to work. I *think* it was related to a BIOS setting, either because power management wasn't set to ACPI, or this other setting I'd never seen before 'APIC mode,' and its two choices, 1.1 or 1.4.

Regarding the RAID drivers... the board came with them but I didn't F6 during setup b/c I'm not using RAID and have it disabled in the BIOS. Is it still recommended that I install them?

I do have XP SP1a as well as a slipstreamed SP2. I used SP2 for the install.

Edited by E-66
Link to comment
Share on other sites

I got it all working now. Apparently the problem was that ACPI wasn't enabled in the BIOS when I first installed XP, and enabling it afterwards had no effect. I had to reinstall XP with ACPI enabled first. I've since installed it 3-4 times with different combinations of having almost all ports/peripherals disabled in the BIOS, and with all of them enabled, and each time I've had no problems when looking at everything in Device Manager afterwards.

I never did install the RAID driver though. The board also has SATA, but the floppy that came with it says nVidia RAID Driver v1.0 and doesn't mention SATA so I didn't think I needed to install it. I'm not currently using SATA but will be when I get some new HDDs. I guess I'll find out at that time if I need the floppy driver.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...