Jump to content

WinPE 2.0 NTFS Not Working with 2000 - Please Help


campbrs
 Share

Recommended Posts

I am using WinPE 2.0 (Build 5744) to install Windows 2000 and the Windows 2000 install fails after the intial reboot.

I have formated the systemdrive using either Diskpart or Format with NTFS using default settings under WinPE 2.0.

If I format using FAT32 it works fine, but I am putting together a build CD for servers (FAT32 is not secure enough). Is convert to NTFS an option here? Does this work well?

Any ideas on what's going on here and why NTFS in Vista appears to be different?

Did anything change with NTFS in this release/build of WinPE 2.0 (Vista)? Could some advanced features of NTFS be on by default (such as Encryption)?

I have also tried format.com from Windows XP and 2003 and niether work (they will not execute correctly in Vista).

Any suggestions on what to try next?

One thing I did notice is that under the "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem" key in the registry the "NtfsDisableEncryption" and "NtfsDisableCompression" are both set to 0 in this build of WinPE. I set these to 1 and re formated the partition but this did not work either (in a few articles I found that referenced these values they said a reboot is required for these values to take).

I was able to modify the Hive and set these to 1. But this still did not fix my issue.

Any more ideas?

Thanks,

RC

Edited by campbrs
Link to comment
Share on other sites


Your problem is caused by the fact that WinPE 2.0 formats the drive and writes a Vista bootsector (using BCD instead of ntldr) on your disc.

Add bootsect to your WinPE image, and run it after you have partitioned the disk.

I use BOOTSECT /NT51 C: /FORCE

That did it for me.

Link to comment
Share on other sites

  • 2 weeks later...

I am also trying to install Windows 200 with WinPE 2.0. When I try to run winnt32.exe /syspart:C

it gives me a message saying

"Windows 2000 Setup cannot detect the version of Windows you are currently running. Setup cannot continue."

Can anyone tell me how I can get past this. SOunds like from the discussion above that this should work. I am using SP4

in my W2K image.

Tom

Link to comment
Share on other sites

  • 3 weeks later...
I am also trying to install Windows 200 with WinPE 2.0. When I try to run winnt32.exe /syspart:C

it gives me a message saying

"Windows 2000 Setup cannot detect the version of Windows you are currently running. Setup cannot continue."

Can anyone tell me how I can get past this. SOunds like from the discussion above that this should work. I am using SP4

in my W2K image.

Tom

Did you ever figure this out?

Link to comment
Share on other sites

I found the regkey that needs to be added to run the win2k setup from WinPE2:

Run this command to mount the reghive:

reg load HKLM\PE-SFT %MOUNTROOTDIR%\Mount\Windows\system32\config\software

Then load regedit and make these changes, you will have to add them because they aren't there.

[HKEY_LOCAL_MACHINE\PE-SFT\Microsoft\Windows NT\CurrentVersion]
"ProductID"="50293-000-1234567-12345"

Then unmount the reghive with:

reg unload HKLM\PE-SFT

Link to comment
Share on other sites

  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...