Jump to content

[solved] connection reset?


rendrag
 Share

Recommended Posts

Hey fellas,

I'm having a disagreement with the support tech for our IBM as/400. On our Windows boxes, we run a terminal emulation program provided by IBM. As of Friday of last week (9/29), I've been experiencing semi-frequent disconnects from the system. It only seemed to drop me when I wasn't actively using the software. I couldn't get a bead on how long I needed to be idle, however. I called support, and it was initially thought that the session timeout was too short, which was why I was getting disconnected.

Today, the tune changed. They are now saying it is a problem with my workstation (they didn't provide it, so they won't support it naturally). It's dropping the connection.

I've tried uninstalling the software, and also the hardware from device manager, swapping cat5 cable, swapping ports on the switch, and I've had 0 luck. I have a spare 10/100 card I am about to install (waiting for a confirmation from the support company that I won't have any issues because of a new MAC address).

Now that you have the background and the troubleshooting I've done, here's the question:

is there any software out there (preferably free) that will monitor an adapter and tell me if the connection gets reset, dropped, or what have you?

I was thinking something like a bandwidth monitor, but if my connection is idle, and it gets reset, it probably won't notice.

Thanks for the help!

Edited by rendrag
Link to comment
Share on other sites


update:

I swapped NICs, and the problem is still occuring. I'm out of ideas. Anyone out there have any suggestions? I'm about ready to kick this whole system to the curb. :realmad::realmad::realmad:

update #2

I have 2 network switches in this loop. I have a 16 port next to the server (switch A), and a 5 port on my desk that connects 3 PCs (switch B). When I disconnect the uplink cable from B going to A while actively running the software on another desktop (not the one that I'm having problems with), and I would expect it would dump my connection because the link was broken. Suprisingly, it did not.

That leads me to believe the issue is more software related. Since I've already uninstalled/reinstalled the software once, I guess it's back to the drawing board.

I'm still interested in finding some connection diagnostic software, or whatever it's called, so if anyone has some links, I'd appreciate it.

Thanks

Edited by rendrag
Link to comment
Share on other sites

What if you used DHCP for a while? The lease information could get changed/updated if the connection is dropped+restored. If you run the DHCP server yourself then you may be able to verify the data on both ends.

Of course, this wouldn't tell you if the client only lost access past the gateway for some reason.

Link to comment
Share on other sites

thanks for the reply. I'm using DHCP from a watchguard soho box, and it ties the IP leased to the MAC address of the NIC, so that won't work.

Something I was testing this morning really messed me up though. I tried pinging this machine from another, and it continuously times out. The only thing I've added to my machine was a cisco vpn client that I run once a week to do administrative tasks on a remote system.

I started searching around in there and noticed that "Stateful firewall (always on)" was checked for some reason. I unchecked it, and wa-la! It's working again. It didn't make sense because the program is manually started by me, it doesn't start w/ windows. I look in the services list, and the VPN service is constantly running.

anyway, thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...