Jump to content

need help about Switches


 Share

Recommended Posts


If you create a shortcut of any of the Windows Hotfixes and put /? on the end of the command line it will tell you what switches are available to that hotfix.

You will find that the switches differ based on release date, but most of the latest ones over the past year or so support /q /n /z

More info can be found at:

http://www.msfn.org/board/index.php?showtopic=31886 and

http://support.microsoft.com/kb/262841

Link to comment
Share on other sites

thank for those information

can help me about this one

i put a KB884883.exe into install folder

and my command line was %wpipath%install\\KB884883.exe /quiet

but when i click begin y i got the X with red colour ?

izzit got problem with the line?

i need more help on this

can someone correct the line for me

Edited by cckit08
Link to comment
Share on other sites

it return like this

WPI Installation Log File

Install process started at: Tuesday, June 27, 2006 9:19:17 PM

List of programs to be installed:

sdgsdfgsdgsdgsdfg

-----

Tuesday, June 27, 2006 9:19:17 PM

Program: sdgsdfgsdgsdgsdfg

UID: SDGSDFGSDGSDGSDFG

Order: 900003

Category: --None--

Tuesday, June 27, 2006 9:19:17 PM

cmd1 *** Fail *** (returned code undefined): "C:\Documents and Settings\ChunKit\Desktop\Backup\WPI\install\\KB884883.exe /q"

Tuesday, June 27, 2006 9:19:17 PM

Finished installation

-----

Install process finished at: Tuesday, June 27, 2006 9:19:18 PM

Edited by cckit08
Link to comment
Share on other sites

and this is the log that without switches

WPI Installation Log File

Install process started at: Tuesday, June 27, 2006 9:40:04 PM

List of programs to be installed:

sdgsdfgsdgsdgsdfg

-----

Tuesday, June 27, 2006 9:40:05 PM

Program: sdgsdfgsdgsdgsdfg

UID: SDGSDFGSDGSDGSDFG

Order: 900003

Category: --None--

Tuesday, June 27, 2006 9:40:20 PM

cmd1 Success (returned code 0): ""C:\Documents and Settings\ChunKit\Desktop\Backup\WPI\install\\KB884883.exe""

Tuesday, June 27, 2006 9:40:20 PM

Finished installation

-----

Install process finished at: Tuesday, June 27, 2006 9:40:20 PM

Link to comment
Share on other sites

Can you try moving your WPI to the root of C: Drive so it is in C:\WPI

Try changing your command line so it is %WPIPATH%Install\KB884883.exe /Quiet (No speech marks).

Are you using WPI 5.0.1?

If you still have problems, please post your wpi_log file and config.js

Link to comment
Share on other sites

Can you try moving your WPI to the root of C: Drive so it is in C:\WPI

Try changing your command line so it is %WPIPATH%Install\KB884883.exe /Quiet (No speech marks).

Are you using WPI 5.0.1?

If you still have problems, please post your wpi_log file and config.js

thanks everyone

i find out wat the problem already

the correct comman line is "%wpipath%Install\April Update\Q901190.exe" /Q

i need to add " " then it only work

and yes i was using 5.0

and this is the success log

WPI Installation Log File

Install process started at: Wednesday, June 28, 2006 12:38:13 AM

List of programs to be installed:

Q901190

-----

Wednesday, June 28, 2006 12:38:14 AM

Program: Q901190

UID: Q901190

Order: 900001

Category: April Update Patch

Wednesday, June 28, 2006 12:38:31 AM

cmd1 Success (returned code 0): ""C:\Documents and Settings\ChunKit\Desktop\test\Install\April Update\Q901190.exe" /Q"

Wednesday, June 28, 2006 12:38:31 AM

Finished installation

-----

Install process finished at: Wednesday, June 28, 2006 12:38:31 AM

but i dun understand y i need to add the " " then only can add switches

but example config there no need but it work for silent install

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...