Jump to content

How to create a Winpe 2.0(vista) with Explorer Enabled.


Recommended Posts


Ok..I`ve been getting alot of request on how i`ve been able to get Explorer working on the New Winpe 2.0 images.

Well i`m going to list the steps i took in order to get it working.

First the test lab.


Beyond Compare

Registrar Registry Manager

Registry Crawler



Waik 5308

1. copy both boot.wim and install.wim from the beta CD to your local hard drive, ie d:\vistape\wim\

2. make two directories to contain the WIM images. ie d:\vistape\install\ and d:\vistape\test\

3. Apply the install.wim to one directory using the ximage, ie ximage /apply d:\vistape\wim\install.wim 1 d:\vistape\install

4 . Apply the boot.wim to the other directory using ximage, ie ximage /apply d:\vistape\wim\boot.wim 1 d:\vistape\test

5. Now the fun. Copy all *.exe, *.cpl, and *.msc files from d:\vistape\install\windows\system32 to d:\vistape\test\windows\system32. overwrite any files on test.

6. Copy all *.dll files except any that Start with NLS*.dll, from d:\vistape\install\windows\system32 to d:\vistape\test\windows\system32

7. Copy d:\vistape\install\program files\internet explorer to d:\vistape\test\program files\

8. Copy the following Directories from d:\vistape\install\windows\system32 to d:\vistape\test\windows\system32. 0409, catroot, catroot2, en, en-us. Overwrite any files that already exist.

9. Copy d:\vistape\install\windows\explorer.exe d:\vistape\test\windows\

10. Copy d:\vistape\install\windows\system32\config\SOFTWARE to d:\vistape\test\windows\system32\config

11. Using Regedit, Load hive, select d:\vistape\test\windows\system32\config\SYSTEM, pick a name for the Hive. ie soft

12. Open up Registrar Registry Manager, Select the hive you just imported, ie soft. Click search, enter in d:\. Click Search. After the search is done, select all the results, Click Replace enter x:\, click ok. This will replace most of the incorrect entries.

13. now open up Registry Crawler, Again search for d:\ in the local_machine key. Sort by Registry Key, Select all Keys that are part of the Hive, ie start with soft. Click Replace type in x:\ Click ok.

14. Now the Registry hacks to allow Explorer to Run.

15. Open up Regedit. goto the hive loaded earlier. ie soft, Hkey_LOCAL_MACHINE\soft\Microsoft\Windows\CurrentVersion\Control Panel\Don`t load\ remove all entries

Hkey_LOCAL_MACHINE\soft\Microsoft\Windows\CurrentVersion\explorer\HideDesktopIcons remove all


16. unload the Hive.

17. Close Regedit.

18. Now make the CD. you need to run ximage than oscdimg.

ximage /capture /compress max /boot d:\vistape\test d:\vistape\winpe\sources\boot.wim "test"

OSCDIMG.EXE -n -bd:\vistape\winpe\boot\etfsboot.com d:\vistape\winpe d:\vistape.iso

19. Now load the ISO with VirtualPC.

20 After the Winpeshl has finished, type explorer.exe

This process has been tested with both 5308 and 5365 betas. This is still a work in process..Most things are working, except the Stupid Start Menu...:(

UPDATE: Seems in my haste, i listed the wrong Hive file in step 10, should be Software HIVE. Sorry all..

Also i`ve included a file list of all files i have on the cd and the locations. Hope this helps.

Edited by unknwon
Link to comment
Share on other sites


Thanks for putting down the steps to get the WinPE with the Explorers (Windows and Internet) enabled.

I followed the steps and came up with the ISO size of 275 MB and not 360 as you have mentioned. Then when I booted the image that created - I get an error - mpio.sys file is missing.

Right now I am going to add this file, I have tried a similar exercise before and got to a position where after adding crcdisk.sys - the WinPE image would just start rebooting. Do we have to cppy some drivers also from the install\windows\system32\drivers folder to the \test\windows\system32 folder including the inf files?

Also, in the step for the registry - you mention copying the SYSTEM hive under install\windows\system32\config and not the SOFTWARE hive - however in the editing steps you mention editing \HKLM\Soft\Microsoft\Windows\CurrentVersion\Control Panel key which resides in SOFTWARE hive.



Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...
  • 2 weeks later...

You can get the Start Menu working... in Classic mode.

Just load system32\config\DEFAULT as hive in regedit, i.e. named as DEFAULT_PE. Then go under

HKEY_LOCAL_MACHINE\DEFAULT_PE\Software\Microsoft\Windows\CurrentVersion\Explorer sand find

or create a binary value named "ShellState". Change it to something like this:


I think the only important value is the first pair in the last row, it may be 02 if existing and must be 00.

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\DEFAULT_PE\Software\Microsoft\Windows\CurrentVersion\Explorer]"ShellState"=hex:24,00,00,00,33,A8,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\  01,00,00,00,0D,00,00,00,00,00,00,00,00,00,00,00
Link to comment
Share on other sites


Followed your steps and was able to get the Windows explorer and Internet explorer to work with the observation that only the IE icon on the desktop was able to launch, the other icons do not complete with desired results.


I did the recommended change but have not been able to get the "Start" button visible in the taskbar of Windows PE



Link to comment
Share on other sites

I forgot something... you also have to copy folder d:\vistape\install\windows\branding to d:\vistape\test\windows\branding.

Edited by scp
Link to comment
Share on other sites

is there a way to add a user to the WinPE image such that the %USERPROFILE% is not set to systemprofile?


Even after copying the branding folder - still does not work.

Do you have a snap shot of the WinPE image with the start button?



Link to comment
Share on other sites


Only the Internet Explorer icon on the desktop seems to be working. None of the other icons seem to complete the operation when trying to open.

Since you have quite a few of the control panel plugins working - Any clues?



Link to comment
Share on other sites

I tried all this and got a

Windows Boot Manager

"System Error - 0x0000017"

Unknown error

or something.

Have you come across this yet?

Just learned an important lesson. MS changes things in each build, so using the winpe.wim from the WAIK will not be all that compatible with say July CTP build 5472.

I know, derrr, I'm stupid but i guess it did teach me a fair bit.

- Also, if anyone is having trouble copying over the .dll's because of write protection/system errors,

- try MOVING all the .dll's from the boot.wim to another dir (called backups).


- Next copy the required .dll's from the install.wim to the boot.wim.


- Then MOVE the .dll's from the backups dir and DO NOT OVERWRITE (this is the reverse workaround).


- Hold shift and click "No" for effectively a "No to All" type action.


- This should only have added 10-15 files to you boot.wim

Continue as per instructions above.

Edited by mickregan
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...