Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


unknwon

Member
  • Content Count

    10
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About unknwon

  1. unknwon

    VistaPE

    your download link doesn`t work.
  2. Thanks..that worked. by the way, you can change this offline, just mount system hive for the winpe with Regedit. i was able to us your setting and change the ramdisk from 32 to 64 offline.. Thanks.
  3. does anyone know how to edit boot.sdi for winpe2.0. I belive this is where the Ramdisk size is being set and i would love to change it to 64megs from the default 32megs.. Thanks.
  4. Sorry for not posting much on this site, been busy working on a different project that has been eating all my time. Currently reworking my instructions for enabling Explorer with Winpe 2.0..Seems that Microsoft changed some of the Registry keys on the RC2 build to prevent Explorer from running correctly. Currently it only it loads the desktop and icons ok, but you can`t than launch another explorer to browse the drives. As soon a i correct these problems i`ll be releasing a new tool to build the pe image. UpDATE: ok, doubled checked my instructions against a RC1 release, everything worked correctly. Use the same script against a RC2 release and i can `t get explorer to load correctly. Also tried using hte registry settings from RC1 with the files from RC2, still have the same problem, so it would seem that microsoft changed some code in the files to prevent us from running explorer with WINPE, seems i`ll have to start some file compares..
  5. i`m hoping that now that i`ve posted a working how to, that more people will start working on the new Winpe.
  6. iso size is 360Megs. there`s alot of extra stuff that can be removed..
  7. Ok..I`ve been getting alot of request on how i`ve been able to get Explorer working on the New Winpe 2.0 images. Well i`m going to list the steps i took in order to get it working. First the test lab. VirtualPC Beyond Compare Registrar Registry Manager Registry Crawler Ximage OSCDIMG Waik 5308 1. copy both boot.wim and install.wim from the beta CD to your local hard drive, ie d:\vistape\wim\ 2. make two directories to contain the WIM images. ie d:\vistape\install\ and d:\vistape\test\ 3. Apply the install.wim to one directory using the ximage, ie ximage /apply d:\vistape\wim\install.wim 1 d:\vistape\install 4 . Apply the boot.wim to the other directory using ximage, ie ximage /apply d:\vistape\wim\boot.wim 1 d:\vistape\test 5. Now the fun. Copy all *.exe, *.cpl, and *.msc files from d:\vistape\install\windows\system32 to d:\vistape\test\windows\system32. overwrite any files on test. 6. Copy all *.dll files except any that Start with NLS*.dll, from d:\vistape\install\windows\system32 to d:\vistape\test\windows\system32 7. Copy d:\vistape\install\program files\internet explorer to d:\vistape\test\program files\ 8. Copy the following Directories from d:\vistape\install\windows\system32 to d:\vistape\test\windows\system32. 0409, catroot, catroot2, en, en-us. Overwrite any files that already exist. 9. Copy d:\vistape\install\windows\explorer.exe d:\vistape\test\windows\ 10. Copy d:\vistape\install\windows\system32\config\SOFTWARE to d:\vistape\test\windows\system32\config 11. Using Regedit, Load hive, select d:\vistape\test\windows\system32\config\SYSTEM, pick a name for the Hive. ie soft 12. Open up Registrar Registry Manager, Select the hive you just imported, ie soft. Click search, enter in d:\. Click Search. After the search is done, select all the results, Click Replace enter x:\, click ok. This will replace most of the incorrect entries. 13. now open up Registry Crawler, Again search for d:\ in the local_machine key. Sort by Registry Key, Select all Keys that are part of the Hive, ie start with soft. Click Replace type in x:\ Click ok. 14. Now the Registry hacks to allow Explorer to Run. 15. Open up Regedit. goto the hive loaded earlier. ie soft, Hkey_LOCAL_MACHINE\soft\Microsoft\Windows\CurrentVersion\Control Panel\Don`t load\ remove all entries Hkey_LOCAL_MACHINE\soft\Microsoft\Windows\CurrentVersion\explorer\HideDesktopIcons remove all entries 16. unload the Hive. 17. Close Regedit. 18. Now make the CD. you need to run ximage than oscdimg. ximage /capture /compress max /boot d:\vistape\test d:\vistape\winpe\sources\boot.wim "test" OSCDIMG.EXE -n -bd:\vistape\winpe\boot\etfsboot.com d:\vistape\winpe d:\vistape.iso 19. Now load the ISO with VirtualPC. 20 After the Winpeshl has finished, type explorer.exe This process has been tested with both 5308 and 5365 betas. This is still a work in process..Most things are working, except the Stupid Start Menu... UPDATE: Seems in my haste, i listed the wrong Hive file in step 10, should be Software HIVE. Sorry all.. Also i`ve included a file list of all files i have on the cd and the locations. Hope this helps.
  8. i have explorer and Iexplore working, as well as over half the control panel snap-ins.. He`s what i did, copy the software(registry) file from the install.wim to your mounted/applied location. overwrite the current registry file. now open up the software Hive with regeditor or similair problem, change all "c:\program files" to "X:\program files" and "d:\windows" to "x:\Windows" than unload the hive, run the ximage command to capture the wim image. than create the iso/cd. The whole Winpe 2.0 is controlled thought the Registry.
  9. i have explorer and Iexplore working, as well as over half the control panel snap-ins.. He`s what i did, copy the software(registry) file from the install.wim to your mounted/applied location. overwrite the current registry file. now open up the software Hive with regeditor or similair problem, change all "c:\program files" to "X:\program files" and "d:\windows" to "x:\Windows" than unload the hive, run the ximage command to capture the wim image. than create the iso/cd. The whole Winpe 2.0 is controlled thought the Registry. P.s i`m using 5308
  10. has anyone been able to get any addons to work..IE get explorer.exe to run on the New Winpe 2.0 (vista) ?? i`ve added the two files, shdocvw.dll and shlwapi.dll as needed by explorer.exe, but explorer still doesn`t launch... Trying to move my bartpe applications to Winpe 2.0. Thanks Unknwon
×
×
  • Create New...