Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Drivers Instalation in Post-Install stage (New Method)

Recommended Posts

Once again i have reuploaded 0.5.4 version. Now it should FIX the issue with registry path not being added correctly. Please test it. And those who downloaded earlier 0.5.4 version pls redownload it.

Share this post

Link to post
Share on other sites

Just tried it again on another machine and it works fine this time!

I suspect when I downloaded and overwrote the old version it didn't do it correctly.

Will let you know on Tuesday whether this clean download solves it.

Thanks for all the assistance and fixes!

Share this post

Link to post
Share on other sites

I checked and the 01 code changes are working now.

also, if I choose Begin or End... it still finds the existing INF first, and asks for the missing files. However, if I choose None, it will search the CD and will overlook the existing INF's like it is supposed to.

I was also wondering, after the devices are re-detected, I have to walk windows through the new hardware wizard. Can this be made automated? or is that already planned for a future release?

Here is my INI file if needed:


Edited by discountpc

Share this post

Link to post
Share on other sites

I was looking in the registry when the 'None' option is used... and the "DevicePath" key changes to blank when the program runs. Shouldn't this be set to the Driver source path? cause I assumed that the 'None' switch was just used to not look in the current systemroot\inf folder, but still use the new variable path...

Share this post

Link to post
Share on other sites

discountpc: correct behaviour when 'none' is used is clean devicepath on start of the function but it is supposed to add 'more' paths as it finds .inf's later on. If it doesn't add anything and you are sure path's are correct and inf's are there then there might be error in code :( Have you DOWNLOADED newest version that i uploaded? Maybe it was cached or so? As Netman66 gave me debug output that helped to solve the problem of paths not getting added to registry on English (probably other versions too, except Polish) windows. Maybe it was same cause for you too?

As for the Windows Wizard it's complicated issue. Are you sure you have correct 'paths' added in registry (as i said earlier there might have been problem with earlier version 0.5.4 and all before that)? I'll release 0.5.5 shortly to fix the confusion ;p

Share this post

Link to post
Share on other sites

I was also wondering about the Add New Hardware Wizard. I was under the impression that after the Registry was pointing to the correct location that the hardware should just install without asking for any manual input as long as all the correct drivers were there. Is this not the case?

If that's how it works, then we need to figure out how to automate that as it defeats the purpose of unattended installation.

So far so good though. It seems to be doing what it's supposed to other than the wizards.

Share this post

Link to post
Share on other sites

Well the Add Hardware Wizard shouldn't be there at all. As i expect Plug & Play to work in background and just install stuff and do nothing. Maybe baloon tip.. all done. And that's it. I experienced that Add hardware wizard myself few times, but i can count it on one hand. Other then that all drivers successfully installed without the wizard showing.

I would expect all the ppl that were experiencing problem with Add hardware wizard to be connected with the bug that wasn't adding paths to registry and when PLUG & PLAY found some device, and no drivers (as no path in registry = no drivers) then the wizard was showing. But if the wizard always shows up and the registry path is CORRECT then it's plain wrong.

If the wizards are really showing up for everyone and for every device maybe it's problem for WINDOWS to distinguish between multiple modem's, mulitple vga cards etc. Anyone tried it with using just one driver for modem, one vga card etc? I just don't get why the wizards would appear.

I realy have no idea WHY the Wizards show up, maybe there's a way to force window to not use WIZARDS at all (for the time the program runs or so). Anyone with info about that?

The last bastion can be of course use of AutoIt functionality to control widnows and to just make the program do the wizards for user. Only problem is it won't loook "as good" and i will have to learn functions that control mouse, windows etc :) But i guess it's doable.

Anyway if you guys can help me out on the topic about Wizards we can realy make it work and be very usefull for a lot of ppl.

Share this post

Link to post
Share on other sites

I have no problem helping you out with this - I see it as very useful if it works the way it's supposed to.

I will test this extensively on Tuesday when I'm back in front of the images I'm working on.

I have 9 different machines at my bench (6 different desktops and 3 different laptops) so I should be able to stress test this to the max.

Can you Upload 0.5.5 with all minor correction so I can use the latest cleaned build?

Incidently, what is the maximum path length for this registry key? I think it's 4096 characters - can you confirm?

Also, if you can write some logic into your code to display the length of the path (in the window) it will add to the registry it would be very helpful as a visual indicator of how close we are to the limit.



Share this post

Link to post
Share on other sites

Nevermind the request for 0.5.5 - you've posted it already, sorry.

I have noticed one interesting thing which *may* prompt the Wizard to show up even if the drivers are located in the DevicePath path.

In the following key:


...there is a value: Installation Sources

...which seem to hold paths to the drivers that were installed last.

If these values conflict, it may prompt the Wizard to appear.

I wonder if capturing, deleting then repopulating that value might work??

Share this post

Link to post
Share on other sites

Nice idea with counting devicepath lenght. I'll add it soon. And yes it's 4096 chars.

I used to have nice testing desk since i worked for company with over 2000 ppl and they didn't had same hw... so testing was included daily then. But now i changed work and i don't do that anymore so the program i'm writting just to fullfill needs as i knew it's pain in the a**.

Little off topic:

My company also used other project of mine. Installer of software. Worked preety nice, but also stopped developing due to diffrent company :) Here's a screen of it (excuse my polish):



The use is simple. you just choose either profile or by hand programs you want to install and it does it automatically. Worked preety nice. Program was using network share with access to /ADVANCED dir (office2003 etc) only if someone was in Domain Admins or MsOffice2003 grp in Active Directory so only some ppl could use it. Program also supported multiple localizations. So if you have like lets say Washington, NewYork and server in each city that is replicated thru domain... program would detect where you are and use the closest location to you, or would tell you to "f... off" if you don't have server near by. I also had a bunch of little programs so i was just sending litle exe in mail, adding user to right grp in AD and they were able to install office with 2-3 clicks ;) Was fun :) Maybe someone will buy my programs some day *Evil GRiN*.

Anyways ;P

I did some googling on this key you gave me and seems it's no GO :) See for yourself. But maybe you want to try it out by yourself.

If Windows setup can't find your install files:

Start/Run/Regedit. Go to HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Setup. Change the path.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Sourcepath


those are for Windows CD and should be pointing to <driveletter>:\i386 and <driveletter>:

Changing the default Win2000 install path: Top

If you want to change where Windows 2000 expects to find the installtion source files, edit:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Setup

and substitute your hard disk path for the existing CD-ROM path.

If a value isn't there, click Edit, New, String Value. For the name enter

SourcePath and press enter. Then double click SourcePath and enter the

path to your installation files, e.g. C:\I386. (it must have a I386 structure)

Next, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows

NT\CurrentVersion. In RegEdit's right pane, double-click SourcePath and

enter the new path, e.g. C:\I386.

You should also check:


Installation Sources




for a path to the CD-ROM drive. If the CD-ROM path appears in these keys, then change them to the hard disk path also.

I'll read some, maybe i'll find something about the wizard :/

Share this post

Link to post
Share on other sites
Have you DOWNLOADED newest version that i uploaded?

Well your release was ~11am from your post... I downloaded the 'latest' copy ~2hrs before my last post... so ~10hrs after your 5.4 re-release, is when i downloaded it...

I will re-test with the latest v5.5

Share this post

Link to post
Share on other sites

Check out my debug report file attached...

here is what I gathered from it

[23:10:26] - DEBUG in REGISTRYDEVICEPATH FUNCTION 0: Total Files Listed:
[23:10:26] - DEBUG in REGISTRYDEVICEPATH FUNCTION 0: 0 File(s) 0 bytes
[23:10:26] - DEBUG in REGISTRYDEVICEPATH FUNCTION 0: 158 Dir(s) 8,992,768 bytes free

I gather that it hasn't detected ANY of the inf's that I have in the All_Drivers folder... shouldn't it have found the files in each of the folders and reported a size???

also, still with the new 5.5 version, when the program starts it changes the "devicepath" key from "%systemroot%\inf;" to blank... then back to the systemroot after closing... with all 3 registry options (Begin, End & None).

the full debug is attached to this post if u need a further look.


Edited by discountpc

Share this post

Link to post
Share on other sites


Check your PM's....

(Edit) ... now a 2nd PM, and a further in-depth incite...

If you want you can either post or pm a reply... doesn't matter to me, but let me know either way.


Edited by discountpc

Share this post

Link to post
Share on other sites

Changelog for 0.5.6

- seems like i missed one thing in program that was related to bug in 0.5.5. Users that were using CDROM or REMOVABLE for drivers_drive wouldn't get DevicePath into registry. (tnx discountpc AGAiN)

- added into program counting for DevicePath lenght. It's added to output and to logfile. Later on maybe i'll redo the look a bit and add it in some better place but for now the log box is nice ;p (requested by netman66)

Should fix the issue now discountpc :) Tnx again :)

Edited by MadBoy

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...