Jump to content

Intel 915GM chipset + Nvidia 6600 board problem


Recommended Posts

As I already reported here, PCI Express graphics boards works very well in motherboard with Intel 955X chipset. I have tested Nvidia 6200, 6200 TurboCache, 6600 and ATI X300SE. All that is necessary to select the right driver manually.

Now I tried this with a bit older motherboard with Intel 915GM chipset and there are troubles. ATI X300 board work well, but Nvidia boards not - the device manager reports "The device cannot find any free Input/Output Range (I/O) resources to use. (Code 12).


This is really strange because there are no conflicting ports that these boards use.

If I try to assign resources manually, the following list of resources appears:


so the only problem seems to be with memory ranges:

00000000 - 0FFFFFFF (256 MB)

00000000 - 03FFFFFF (64 MB)

00000000 - 00FFFFFF (16 MB)

00000000 - 0001FFFF (128 KB)

The graphics board ic conncted correctly to the PCI Express Root Port:


the memory range assigned is: B0000000 - CFFFFFFF:


Windows XP on the same computer shows the same range for the PCI Express Root Port but also assigns correctly the four memory ranges for the graphics board:

B0000000 - BFFFFFFF (256 MB)

C0000000 - C3FFFFFF (64 MB)

C4000000 - C4FFFFFF (16 MB)

The fourth range (for 128 KB of RAM) is not present in Windows XP, but the same situation is for ATI X300SE so probably it is OK.

I tried to disable all integrated peripherals and left just the harddisk and the video card, and the conflict has not disappeared.

The on-board Intel graphics is always disabled.

I also tried both Windows 98 SE and Windows Me with the same result.

Of course, I can use ATI board and forget this problem but I like to see things working :)

Does anybody have any idea how to assign the right resoures or find any possible conflict? Is there any debug mode in which it would be possible to find the root cause?


Link to comment
Share on other sites

Now I found the same problem with Radeon X550 - again the same error "The device cannot find any free Input/Output Range (I/O) resources to use. (Code 12).

X300 worked fine, so where is the difference?

X300 has allocated the following resources:


IRQ 11 (Win XP IRQ 16)

Memory 000A0000 - 000AFFFF

Memory 000B0000 - 000BFFFF

Memory 000C0000 - 000CCFFF (ROM BIOS) *

Memory D0000000 - D7FFFFFF (128 MB)

Memory D8000000 - D801FFFF (128 KB) *

Memory D8030000 - D803FFFF (64 KB)

I/O ports 03B0 - 03BB

I/O ports 03C0 - 03DF

I/O ports B000 - B0FF


Memory D8020000 - D802FFFF (64 KB) (Windows XP D80F0000 - D80FFFFF)

* = In Windows 98 SE allocated, in Windows XP not.

X550 has allocated in Windows XP:

IRQ 16

Memory 000A0000 - 000BFFFF

Memory C0000000 - CFFFFFFF (256 MB)

Memory D8030000 - D803FFFF (64 KB)

I/O ports 03B0 - 03BB

I/O ports 03C0 - 03DF

I/O ports B000 - B0FF


Memory D80F0000 - D80FFFFF (64 KB)

So the only difference is the need of 256MB memory allocated. Windows 98/ME correctly allocates the resources to the PCI Express root port, but later the assignment of these resources to VGA adapter will fail.

The strangest thing is that this does not work on system with 915GM chipset, but on system with newer 955X chipset everything works fine - i.e. Windows 98 IS able to assign 256MB of video memory.

Strange things.


Link to comment
Share on other sites

This might be related: I have an older Celeron machine with an FX5200 (AGP) in it, and it also had the same conflicts with the memory ranges (also said it was used by "System Board Extension for ACPI BIOS"). I managed to get the card working correctly by booting into safemode, *removing* the "System Board Extension for ACPI BIOS" device from the devmgr, then booting normally. It redetects the SBEfACB, and everything else including the video card works fine; the only irregularity I get is that the SBEfAB shows up with the yellow icon and claims to not be working properly. All I see is that instead of the problem being with the video card and the system complaining that it's not working, it's moved to the SBEfAB and Windows doesn't complain when it starts up.

Link to comment
Share on other sites

I don't know what was wrong but X550 works now with no problems, so 256 MB is not the cause.

I've got an idea what might be the problem but I really don't understand to the physical <-> virtual memory mapping so maybe this could not be realated, hard to say for me.

In the Windows 98 Resource Kit http://www.microsoft.com/technet/archive/w...rt6/wrkc28.mspx Figure 28.14 illustrates where Windows 98 system components and applications reside in virtual memory:

00000000 - 0009FFFF: Real mode device drivers and TSR

000A0000 - 003FFFFF: ? too?

00400000 - 7FFFFFFF: Win32-based applications

80000000 - BFFFFFFF: The Windows 98 core components and shared DLLs

C0000000 - FFFFFFFF: All Ring 0 components

In all cases when everything works fine, i.e. all PCI-E video cards in 955X motherboard and Radeon PCI-E cards in 915GM motherboard all the adresses assigned to the video board are in the range C0000000 - FFFFFFFF.

In all cases with resources conflict the addresses assigned to Nvidia card by 915GM BIOS are in the range B0000000 - CFFFFFFF.

Could be this the problem?

Is there any way how to tell to BIOS to assign different addresses? It is not possible to change them in the Windows 98 device manager.


Link to comment
Share on other sites

The addresses assigned to the video card itself are physical addresses, and generally can't be changed very easily except through PnP configuration. Quite possibly there is PnP Configuration option in the BIOS which might have what you need.

The addresses you mentioned from the W98RK are virtual addresses, and have nothing to do with the hardware itself.

Edited by LLXX
Link to comment
Share on other sites

  • 2 years later...

Same hiere for an old Pentium-III board with BX440 chipset, and Nvidia GeForce 6600 graphics board ( advertised as AGP8x, but with 2 keys in the slot interface so that I was able to install it ),

conflict is on W2k



This device cannot finde enough free resources that it can use ( Code 12)


Memory Range: D0000000-DFFFFFFF "is not available"


D80000000 - E7FFFFFF

is used by the "Intel 82443BX Pentium® II Processor to AGP Controller" of the motherboard.

Same here


motherboard with BX440 chipset


128mb radeon 8500le


It did not help me to reduce my memory from 512 MB to 256 MB ( it was just a try ).

A GeForce 4M-X440 card with 64 MB works properly :-).

There are a lot of more memory conflicts with Win98SE, but on different (lower) memory addresses !



Edited by hemmerling
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...