Jump to content

Reading an NTFS drive in USB external enclosure


sqzdog
 Share

Recommended Posts

Pardon me if I have posted in the wrong forum. I am new here. I have a computer that's board is fried and I removed the hard drive. The fried computer was running XP. I placed the HD in a USB 2.0 enclosure, but my working computer won't detect it. Is it because the drive is NTFS? How do I get the data off of this drive?

Thanks in advance.

Link to comment
Share on other sites


Is it listed in the Disk Management section of "Computer Management"? If it's listed there, you may just have to initialize the drive (or you won't see it). If it's not there, then some further troubleshooting needs to be done.

Edited by cluberti
Link to comment
Share on other sites

Well first and formost we would need to know a little about the drive and how you are plugging it into the new system. As well as what do you mean when you say "I have a computer that's board is fried" Are you talking about the Hard Drive controler on the Mobo, the Hard Drive Controler on the Drive itsself, or the mobo in the old system? Also what type of drive is it? IDE/SATA/SCSI/MFM/RLL/USB ect..... Also what type of format/file system is on the drive in question? It would help if you could be a little more helpful on some details,

MrChris

Link to comment
Share on other sites

The CPU in the computer that this drive came out of fried. The drive I am trying to read has WIndows XP on it. It is a West. Dig. WD400 40gig.

I put it in a USB 2.0 external hard drive enclosure and am trying to access it through USB from an XP machine.

Edited by sqzdog
Link to comment
Share on other sites

Before the drive is detected the enclosure must be detected. I have come across a number of situations where USB 1.1 & USB 2.0 compatibility issues arise & you have to disable the Enhanced USB Host adapter in Device Manager.

Is the new machine you are connecting the USB drive to fast enough? USB will only allow 10% resources for any thing you might want to do on USB connections. It may a while before the drive is accessed, detected, configured & made available. In fact on an XP machine it may just keep playing hide n seek. USB is an extremely poor cousin to firewire.

I had to resort to USB enclosure to access a drive which was not fully supported by the mobo bios. I was miserable with it. Finally I attached it to a machine which supported the size fully. Configured it the way I wanted it. Transferred it back to the original machine. Set the bios for the drive to none. Now I have no problems with it. The individual OSes (Win 2k, XP, Linux) can access the drive properly. Only thing I can't do is access it at intial boot manger/ bios level. I can even access it from WinME + Acronis Mount All utility.

Link to comment
Share on other sites

Ok, if I want to add this drive to an existing machine that already has a hard drive with win XP on its primary hard drive, how would I do it? I tried it some time ago and it screwed up the boot file. My preference is to be able to place is as a slave in an existing machine instead of using it in the external enclosure.

Link to comment
Share on other sites

What jumper settings are you using with the USB. I do this freq. Remove the jumpers. It's not a master or a slave. That might help unless the drive controller is fried. I use a Windows 2000 machine for data recovery though. It's always worked better for me.

Edited by KAndle
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...