Jump to content

XPize 4 final causing WMP10 and PowerDVD to crash.


Recommended Posts

Hmm this is weird. Installing without msxml3.dll or uninstalling msxml3.dll manually (add/remove apps) makes WMP10 work fine, but does not fix the PowerDVD 6 crashes. If I uninstal all .dll's Both PowerDVD and WMP10 work fine.

Then I will have to investigate on what DLLs are causing this. Will take long :}

Link to comment
Share on other sites

Did'nt take THAT long I think ;)

quartz.dll and msxml3.dll are causing my problems.

msxml3.dll causes WMP10 to crash

quartz.dll causes Power DVD 6 to crash

(System + apps = Norwegian language)

Thanks, my suspicions were right ;)

I will update the site soon with this new info.

Edited by XPero
Link to comment
Share on other sites

Nepali: Thanks for the help on this one.

I'm starting to think there is no way to restore the dll's quartz.dll and msxml3.dll at the same boot as XPize was installed with those 2 dll's.

Ive tried now with this in a cmd file:

rem Gjenoppretter ukompatible dll filer installert med XPize.
sfc /purgecache
regsvr32 /u /s %WinDir%\system32\msxml3.dll
regsvr32 /u /s %WinDir%\system32\quartz.dll
del /q %WinDir%\system32\msxml3.dll
del /q %WinDir%\system32\quartz.dll
copy /y "%~dp0msxml3.dll" "%WinDir%\System32"
copy /y "%~dp0quartz.dll" "%WinDir%\System32"
regsvr32 /s %WinDir%\system32\msxml3.dll
regsvr32 /s %WinDir%\system32\quartz.dll

and running this right after XPize installation with ALL dlls (as there are no way to exlude specific dll's) does not seem to work. PowerDVD and WMP still crashes (at next reboot). BUT HOWEVER if I run the command from above after the next reboot AFTER wpi has installed, and yet again reboot then it works!

Nepali or anyone else, any idea on how to make this work at the same boot as XPize installs?

Edited by BoardBabe
Link to comment
Share on other sites

Those having problems with msxml3.dll and quartz.dll in your uA CDs, PM me your email addresses. In some days I will have prepared something for you. Im not at home right now.

Edited by XPero
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...