Jump to content

network adapter problem in xp


Recommended Posts

i gave realtek

rtl8139/810x family fast ethernet nic

ip of

not the card gave me problem so took out the card and hook a new card

it shows the address

rtl8139/810x family fast ethernet nic #1

now i can't give the same ip in this card

"u cannot assign ...... coz hidden device is assigned the same ip " message popup

after when i hook again another adapter

rtl8139/810x family fast ethernet nic #2

rtl8139/810x family fast ethernet nic #3

rtl8139/810x family fast ethernet nic #4

rtl8139/810x family fast ethernet nic #5

rtl8139/810x family fast ethernet nic #6

whats the matter

how can we get rid of this problem

Link to comment
Share on other sites

to resolve your problem, you need to go to below location


in this class registry key which control all shown devices in Device Manager, go through each of them until you see "network adapter"and following registry keys such as 000, 001,002, and so on.

Important: DO NOT delete the class itself. If you do, windows won't be able to install the driver for your device.

Next you should delete these above registry number keys and restart computer. windows will detect and re-install device without any number next to your device.

Next, you want to take care of "local area connection #" too. I don't remember where in this registry it stores. When i go home, i will have this information right away.

Yes, the procedure can be lengthy and it works. NO, it is not that difficult if you know what you are doing.

do you know why you have these numbers.?


rtl8139/810x family fast ethernet nic #2

rtl8139/810x family fast ethernet nic #3

rtl8139/810x family fast ethernet nic #4

rtl8139/810x family fast ethernet nic #5

rtl8139/810x family fast ethernet nic #6


The answer is because of 000, 001, 002 registry keys under "network adapter" class.

In fact, I experienced this kind of problem before and i'm tired of going through the whole processes again,i wrote my own scripts which deals this kind of problem. I found a way to fix this problem and wrote my script to take care that. How cool.? :)

i will post my script tomorrow morning so that you can take care of this problem in 2 seconds. :)

Yes, it is SAFE and FAST and it works. Of course, you or anybody can KEEP it for future reference as long as you don't tell anybody you wrote it or sell it to make money. Other than that, you are FREE to modify and learn my codes :).

Edited by msfn11
Link to comment
Share on other sites

If you have the following problems, this script will help you fix them.

1-Under "network adapter" in Device Manager, if you see something like this

Linksys *******

Linksys ******* #2

linksys ******* #3


In control panel, "network connections"

local area connection

local area connection 2

local area connection 3

Import note: All i ask you NOT to do is Please DO NOT remove my name from my script . Other than that, you are FREE to modify, use, and share it with your friends.

Pleae do not do any harm to other people's computers. Thank you

A small contribution to msfn.org community from MSFN11. Of course, it is FREE :)

if it works for you, please let me know.

Link to comment
Share on other sites

Hello everybody,

Here is another updated version of my script. I strongly advise you to use this version instead of a previous version because it is better than the first.

Instruction how to use

1-Download it in your computer. Open a "notepad" to rename it from fixnetwork.txt to fixnetwork.vbs, click it to run. Please only click it 1 time

2-After your computer restarts, windows will detect and automatically install driver for your network card.

3-Open "Device Manager", if you see any yellow mark next to "WAN Miniport" devices, right click on each of these and choose "Update Driver". Click "Next" and "Finish". Select No if computer asks you to restart.

After doing that to all yellow mark devices, you will see some or all "WAN Miniport" devices disappears. Good News!

4-If one of these "wan miniport" devices still shows up there , open registry editor and locate this registry key


In this registry key, you will see other registry keys from 0000 to 0009 or more, go through each of these registry keys and look for "driverdesc" (driver description) to know which registry key number.

For example, After you go through step 3, the only thing that has yellow mark is "WAN MINIPORT (IP), go to step 4, look into registry keys from 0000 to 0009 if you see "driverdesc" which says WAN MINIPORT (IP)".

In my computer, this key is in 0009 registry key, all i do is highlight on 0009 and delete it.

go back to "device manager" and use step 3 again. At this point, everything should be OK now

5-If you want to know where all "WAN Miniport" devices go. Click on "View" and choose "show hidden devices" in device manager.

6- Don't forget to test your internet connection or any program which uses your network adapter such as VMWARE.

Hope it help. If you have any question or problem, please post it here.

don't forget to let me know if it works in your computer. It runs fine in windows xp.

thank you for using. Don't forget to backup everything FIRST.


Edited by msfn11
Link to comment
Share on other sites

WAN Miniport didn't get updated after reboot and update method...

all other worked fine :)

you mean WAN Miniport (IP).?

open your registry editor to go to "HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}"

look inside from 0000 to 000X (X is the number such as 9 or 10) registry keys. and look for "driver description or drivdesc or something like that". You will see WAN Miniport (IP) . In my computer, it locates in 0009 registry key, i delete 0009 and go back to device mananger and right click on troubled WAN miniport and choose driver update.

Everything should be FINE now.

About this problem, I will post another version of my script sometimes this week to correct this problem and to make everything goes smoothly.

Keep checking back this thread for further update.

thank you for letting me how everything works.

Edited by msfn11
Link to comment
Share on other sites

From what i understand your still believes your old nic is still installed with that IP on it ....maybe an alternative to the batch in the future would be reboot in safe mode and open up device manager go to network adapters and try removing it from there. If im right the old adapter should show up in there....not sure but its worth a try.

Link to comment
Share on other sites


thank you for letting me know my script worked. :thumbup It's a good news. You give me an inspiration to make my script better.

i'll post another improved version sometimes this week. Of course, you can test it for me when it comes out. Will you.?


thanks again.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...