Jump to content

drivers from cd

Recommended Posts

I was trying to integrate drivers with the drivers from cd method.

You know the way with the modified setup.ex_, setuporg.exe and presetup.cmd.

I can't seem to get it working...setup keeps restarting and I think it's because something is going wrong with the setuporg.exe.

I expand setup.ex_ to setuporg.exe however the difference with 32 bit is that setuporg.exe doesn't get a installer icon...

maybe something is going wrong with the expand command?

Someone got drivers from cd working with x64?

Link to comment
Share on other sites

This can be done by sending setuporg.exe and presetup.cmd to the 32 bit system32 folder instead of the 64 bit system32 folder. Works fine, I tested it myself last night.

The reason for this is even at this early stage, x64 runs the replaced setup.exe in 32 bit mode.

I haven't managed to get setdevicepath.exe to work in 64 bit yet, but I'm working on it.

I'm not at home at the moment, so I can't give you the exact edits I made to txtsetup.sif at the moment, but I will post those when I get home tonight.

Link to comment
Share on other sites

This is what I put in my txtsetup.sif....

setup.exe    = 1,,,,,,,82,0,0
setuporg.exe = 1,,,,,,,82,0,0
presetup.cmd = 1,,,,,,,82,0,0

The 82 means that it puts the file in SysWOW64, which is the 32bit system32 folder. I had to put setup.exe in here as well as leaving the normal entry to get past the check that the version of Pyron's hacked setup does.

Hope this helps.... :)

Link to comment
Share on other sites

Sorry, no. You have to put

setup.ex_ (modified)

setupORG.exe (uncompressed and renamed original)


in the AMD64 folder, plus make the changes to the txtsetup.sif, and everything will work.

I managed to make some tests with setdevicepath.exe last night too. If everything works out, I will post what I did with that as well tonight or tomorrow.

Link to comment
Share on other sites

OK, my testing with setdevicepath.exe worked fine. The problem with setdevicepath.exe on 64 bit is that it is a 32 bit application. What this means is that the registry setting it makes gets written to the 32 bit HKLM\Software\etc path instead of the 64 bit one. This could be solved by writing a 64 bit setdevicepath.exe, but this is not something I know how to do.

To get around this, I'm still using setdevicepath.exe, but I'm then copying the 32 bit reg key to the 64 bit reg key.

Attached is a link to copypath64.exe. This is a self extracting 7z file, which contains 4 files.


commands.bat is simply

start /wait /min cmd.exe /c commands64.bat

and is started by startx.exe in the 7z sfx module like so

RunProgram="StartX.exe /WAIT /B \"commands.bat\"">>config.txt

There are references to creating 7z sfx modules elsewhere in the forums.

What this does, is start commands64.bat, using cmd.exe to start it. cmd.exe is a copy of the 64 bit version, which forces the commands64.bat file to run in 64 bit mode, even though it's being run from 32 bit mode from the hacked setup.exe! :thumbup

commands64.bat contains:

reg copy HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion HKLM\SOFTWARE\TempRegkeys /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "CommonFilesDir" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "CommonFilesDir (x86)" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "MediaPathUnexpanded" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "PF_AccessoriesName" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "ProductId" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "ProgramFilesDir" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "ProgramFilesDir (x86)" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "ProgramFilesPath" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "SM_AccessoriesName" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "SM_ConfigureProgramsName" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "SM_GamesName" /f
reg delete HKLM\SOFTWARE\TempRegkeys /v "WallPaperDir" /f
reg copy HKLM\SOFTWARE\TempRegkeys HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion /f
reg delete HKLM\SOFTWARE\TempRegKeys /f

which is simply making a copy of the 32 bit location of the key into TempRegkeys, removing what we don't want to copy (which is everything but DevicePath), but had no choice in copying with the "reg copy" command, and then copying the remaining DevicePath value into the 64 bit location. There's bound to be a better way to do this, but I couldn't figure it out with a for loop or anything because of the spaces in some of the names.

I'm using "reg copy" here because it will copy DevicePath no matter how long it is. If I try to copy the value out to DOS with "reg query" DOS will truncate the value if it's too long. Can't remember the length limitation off the top of my head.

So basically, all you would have to do is run setdevicepath.exe as you normally would from presetup.cmd, and then run copypath64.exe straight after this, and the 64 bit DevicePath in the registry now contains a copy of the 32 bit one and you're set to go.

I've tested this with my nVidia and network drivers just now, and it all worked fine for me.

Anyway, I hope all this makes some sense, and that it's useful to someone! :)


Link to comment
Share on other sites

I got an lsass.exe error box explaining me there is not enough system resources or something.

This results in the setup rebooting and restarting the setup over and over again.

Do you work with extracting the drivers from 7z in your presetup.cmd?

I think there is maybe something going wrong with my extraction process.

Maybe I have to use the 7za.exe X64 build?

Also my expanded setuporg.exe is different from the 32bit one...it has no icon


Edited by devilrunner
Link to comment
Share on other sites

The setuporg.exe file will not have an icon under 32 bit windows because it is a 64 bit only application. If you look at it under 64 bit, it will have an icon again.

Yes, I use a 7z to extract my drivers in presetup.cmd, but it shouldn't matter.

I have no idea what would be causing lsass.exe problem. I assure you that this has been working for me no problems. :(

Are you able to get the first part working without worrying about the drivers? So just running presetup.cmd and getting setuporg.exe to start running, but don't actually do anything in presetup.cmd?

Has anyone else tried this method and been able to get it to work?

Edited by Viking
Link to comment
Share on other sites

No worries. I just hope it works for you.

Hopefully someone more knowledgable than me will pick it up at some point and make it as easy as the 32 bit stuff.

**** it's painful testing this stuff. Having to actually install every time is a pain. Come on virtual machines with x64 guest support!! :)

Link to comment
Share on other sites

yes...this thread helped me allot...thx

Yes I have been waiting for 64bit emu's to...any idea which will be first?vmware would be nice to offer x64 support.

Still would like to see someone emu 64bit on a 32bit machine...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...