Jump to content

Help - Can't get any hotfix method to work!

Recommended Posts

Lo all,

Thanks to everyone here I've been happily using a Windows XP SP2 unattended CD for a while now. However, today I decided it was time to slipstream all the hotfixes into the installation CD.

I tried nLite, the Integrate switch and finally the SVCPACK.inf methods but none of them seem to be working ie. Hfnetchk is still reporting all of the hotfixes missing.

Any help would be greatly appreciated.




Link to comment
Share on other sites

Well this is how I did it

I placed all my updates here XPCD\$OEM$\$1 in a folder called Updates.

and I load hotfixes.cmd at my last entry in Wpi so it can be done in Runonce or whatever you need. Edit the .cmd file to fit your needs. It's extremely difficult to slipstream updates into a XPCD best to install after windows instillation.

The updates can be found here if needed



Edited by TheeBeets
Link to comment
Share on other sites

Well, there's always my way ;):P

But seriously, if /integrate isn't working, my intuition says that you've got something else going wrong with your CD. Of course, hfnetchk isn't the most reliable way of checking these days. What does MBSA report?

Link to comment
Share on other sites

Could you please check if this ...


... is in your dosnet.inf?


I believe Nlite does this automatic, and I think the /intergrade switch does this aswell, but it is just to be on the safe site

Edited by erik_demon
Link to comment
Share on other sites

I think there may have been a corruption of my DOSNET.inf file. I didn't notice it until I tried to attach it to my last msg and it was too large to attach.

I've now copied and pasted the contents into a new txt file and will give it another go.

Will keep you updated.

Link to comment
Share on other sites

I got some "issues" with teh hotfixes too.

Nothing big, really, just that im waiting if Ryans site is coming up with the latest goodies (june-updates) anytime soon...


I mean, that Ryans full hotfix pack is just too awsome to be ignored.


Been using nLite and adding Ryans pack with that, seems to work fine for me.

Alltho I have been messing in VMware only...

Link to comment
Share on other sites

Well, created a brand new unattended installation and the svcpack.inf method and it still didn't work.  I'm going to give TheeBeets way a try.

Like I said slipstreaming hotfixes into a windows instillation is extremely difficult better off just installing after windows instillation. Im sure this will work well for you!!

Link to comment
Share on other sites

Guess what? TheeBeets method didn't work either. So I started to doubt MBSA!

I ran the hotfix manually and it seemed to run OK but when I checked the file version on the file it was supposed to update, it was still the old version. This now has me stumped!

If anyone has any ideas why the hotfixes aren't working I really appreciate the help.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...