Jump to content

Active Directory problem after nLite install


Recommended Posts

I'm using nLite 1.0b2 to create a customized XP Pro installation CD. After installing the system, i use Sysprep to join an Active Directory. However, during the join process i get this error:

The file 'c_20127.nls' on Windows XP Professional CD-ROM is needed.

If i cancel the message everything works fine, but i'd like to automate the Sysprep step, which means i need to get rid of the error. Is anyone else seeing this? If so, is there some component you kept that perhaps i did not (i'll include my Last Session.ini file)? In the Compatibility screen i did check "Windows Activation and Sysprep" before selecting any components for removal.

The curious thing is that the compressed version of the file ("c_20127.nl_") shows up on the XP CD in the I386 directory. And after installing Windows, c_20127.nls is in C:\Windows\System32, right where i'd expect it. So i don't know why Windows isn't finding it when running Sysprep. I don't have this problem on an install that is done from an unmodified XP disc, just the nLite disc. I'd be happy to hear any suggestions people have. Thanks!


Link to comment
Share on other sites

Yeah you don't have to be worried, it's just cosmetic but still a bug.

This was reported before but when I asked how can I replicate that no one replied.

So I ask...how can I replicate that problem...run sysprep...reseal it, what ?

Link to comment
Share on other sites

I to am haveing the same problem. Sysprep is run from Symantec Ghost Console (deployed and run when it pulls an image from a target machine to the server) so I am not sure what switches are run. This is from the Ghost manual:

Using Sysprep switches

If you are using other Sysprep switches, consult Sysprep documentation and

ensure that they do not conflict with the Ghost operation. The following Sysprep

switches are generated automatically by Symantec Ghost or are set in the







The only part of sysprep.inf I can see that would use this file is this:



I have even tried putting 'c_20127.nls' in the sysprep\i386 folder so it is copied to the machine when Sisprep is run.

And I still get:

The file 'c_20127.nls' on Windows XP Professional CD-ROM is needed.

I would DEARLY love to use NLite here at work so ask if you need any further info :)

P.S. nLite 1.0 beta 2 fixed all my other sysprep problems :thumbup

Edited by Gibbo
Link to comment
Share on other sites

Sorry i didn't get back to this thread until today. I'm attaching my sysprep.inf file, after cleansing it of passwords and such. When sysprep is run, it is called like so:

C:\sysprep\sysprep.exe -activated -mini -quiet -reboot -reseal

Hope this helps, and thanks nuhi for all your work on nLite. It is an awesome tool.


Link to comment
Share on other sites

Just for another data point, i installed nLite 1.0b4 today and built another CD using the Last Session i posted previously in this thread. The problem with sysprep still exists; the process is interrupted by the c_20127.nls error. Any chance of getting this fixed in the next beta? I'm ready to roll my nLite'd XP installation out to the roughly 100 machines that i administer, but can't do it until the c_20127 problem is gone.

Link to comment
Share on other sites

Same here.

The only thing holding me rolling out nLite to 200 odd machines is that darn language file :)

Many of the computers are rather slow running XP, but with nLite have become quite zippy.


Keep up the amazing work.

Link to comment
Share on other sites


have finally solved this issue run sysprep as you normally would but copy the entire i386 directory to C:\Sysprep\I386 and point the install files path in your sysprep.inf to this location then just run a command to delete the susprep folder at the end to free up all that hd space. It ain't pretty but it works!

Link to comment
Share on other sites

*Wonders where that less than usefull outburst came from

:huh: We indeed have "some kind of corporate, multi-user licence"

It's not as if I can fit 200+ computers in my house. :rolleyes:

(that is the EULA of windows.... correct me if I need some sort of EULA for nLite)

Edited by Gibbo
Link to comment
Share on other sites

  • 3 months later...

Problem is that nlite edits few infs and breakes signatures, then while sysprep installs it asks for files already there...just point it to your installed windows folder, files are there for sure. Or...don't use nlite until in changelog says sysprep fixed.

Link to comment
Share on other sites

That does not work perfectly. You can specify the souce in the sysprep.inf file. but not all the files it asks for are there... (I guess some are in a subdirectory)

Other sollution could be: specify the source as a networklocation \\server\I386

But I'm not sure that will work.

Meantime I keep an eye on the changelog :-)

Link to comment
Share on other sites

  • 10 months later...

Hey everyone,

I'm not a nLite user, and apologies for bouncing an old thread, but I just hit this issue myself. Your thread was one of the first that came up in google and wanted to post my findings somewhere they would help others.

I think the missing c_20127.nls error message is due to windows re-installing some settings after sysprep. The error is simply because windows can't find the file.

In my case the source files were on a network share, and windows is having issues with the network drivers (They're not installing until after I first log on). Because of this, the usual network location for these files isn't available during mini-setup and this message comes up. Cancelling the message means the install works fine, attempting to enter an alternative location just leads to more and more errors.

As others here suggested, copying the entire i386 folder to the local machine and setting the source paths accordingly is a good work around. I'm also trying to get our network drivers working so I can use the network location for these files, but that's not really relevant to this forum.

Well, that's my 2c. Hope that helps some of you understand the problem. I'm not sure it's an N-lite problem, I think it's more of a generic "path / network driver / source" file access problem with sysprep.


Link to comment
Share on other sites

All you have to do is copy the file your missing into the sysprep/i386 folder not the whole i386 folder. I havent done it for awhile mainly because I don't like sysprep and started using newsid, but I used to have 8 or 9 files missing, even files like desktop cleanup wizard which I removed gave me an error. Just copying that into the i386 folder should fix it. Also why do you need to use sysprep. In active directory the sid gets pulled down from the server. See if this works for you.

Link to comment
Share on other sites

  • 6 months later...
Seems like I have the same problem... And no one found a sollution yet :s

NLite causes this. But what part of it... Copy the entire I386 folter would make the image too big I guess :-)

Me three... Has any headway been made on this or is it still prefered to copy the entire i386 directory over to the sysprep folder?!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...