Jump to content

A phantom disk drive!


Ginpit

Recommended Posts

I have a 120 gb hard drive installed as a secondary slave. It appears in Device Manager and is said to be working ok - it is obvoiusly also present in the BIOS. But when I look for it in Windows Explorer or using Control Panel it is invisible. I have tried disconnecting it in BIOS and restarting, then closing and reinstating it in BIOS to no effect.

The programs which refer to this drive also cannot find it.

Has anyone any ideas?

Link to comment
Share on other sites


Hi,

Do you have assigned a drive letter to the disk?

You can check this by going to administrative tools in the Control Panel ---> computer management ----> storage ----> Disk management

Can you see the drive there, if so see if there’s a letter assigned to the drive. If not, right click and change drive letter. Select one that is not in use.

Link to comment
Share on other sites

Windows XP - When you install a secondary drive it doesnt show up as a Drive Letter straight away you need to set it up.

Goto Control Panel -> Administrative Tools -> Computer Management -> Disk Management

Do you see it as a drive in there? If you do, right click and then hit Format.

Link to comment
Share on other sites

Hi,

If it’s a new drive or one with no files you need, then indeed format it and give it a drive letter afterwards. However if it’s a drive with important files on it, don’t format it because you will loose all files.

Link to comment
Share on other sites

I am not trying to insult anyones intelligence here but the first thing I would check is the view in My Computer. If it is set to large icons then it is very possible that it is just off the screen. Set the view to list or detail.

The reason I say this is because a friend of mine asked me the same question and by setting the view to list he could then see the slave drive.

Link to comment
Share on other sites

I am not trying to insult anyones intelligence here but the first thing I would check is the view in My Computer.  If it is set to large icons then it is very possible that it is just off the screen.  Set the view to list or detail.

The reason I say this is because a friend of mine asked me the same question and by setting the view to list he could then see the slave drive.

A very good point.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...