Jump to content

error in wpi.hta


Recommended Posts

Hiya,

have some small tweaking wih WPI to look and feel a bit more personal, whoever i've chaned something to cause a javascript error when it runs, but can't figure what change is causing it.

The error is attached, (not sure how to add image) along wpi.hta, but as you can see the line 76 exist, but char28 doesn't or i'm think, which is likely.

If I click yes or no it runs, but show none of the applications available, an dnone of the links for Options, Config etc work

If you need more, shout and will oblige, and any assistance appreciated.

Apologies for the big post.

an Oldman getting annoyed

edit: removed wpi.hta code as rather too big

post-17928-1116448355_thumb.jpg

Edited by oioldman
Link to comment
Share on other sites


WPI.hta is just the compiler your error is most likely in the wpiscripts that are compiled during start up. What changes have you made? Please post your config.js (Serials removed) and useroption.js. Also did you customize the theme at all?

Link to comment
Share on other sites

@kelsenellenelvian - Thanks for your prompt and helpful reply as always.

Ive done something simple and seems to have solved it!! copied from one dir to another, ran wpi.hta - all worked, so copied back again, replacing all files in process and all works.

Shall burn to cd, and build to see what heppens.

Will let you know out come.

I did change the theme, by adding a different background and removing all reference to the tables and directing to the background image from within the wpi.htm body section with background= That fails in test as expected as runnig from different location.

if of help, can still post my config.js and others if neeeded.

Oldman

Link to comment
Share on other sites

Thought a copy and re-copy would solve it, but when happened again, thought something else has to be an issue, though which file i'm not as only updated the config.js to add a cmd line to do a start /wait when installing a program as doesn't always work correctly, though if do standalone with same switch works fine!!

If seeing the config.js helps shout and i'll post up as requested.

Oldman

Link to comment
Share on other sites

Update:

having run and checked all settings, it appeared as though a line break had managed to make it's way into the config.js file. Added the command <br /> to create one, saved, tested and all ok.

Thanks for pointing in right direction kelsenellenelvian

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...