Jump to content

@ is an unknown command


Recommended Posts

Hello All,

1st - great program - next is to customise it a bit more.

Issue; It worked fine, so i added some comments to my programs, it failed on line 109Char59 (line exists, char doesn't), but resolved as comments were too large so shrunk some.

Result now is though that the cmdow.exe line fails with the error that

@ is an uknown system command

This can be resolve dby REM the line out, but then the dos box stays on the screen.

Why would the addition or removal of comments affect this? Bugged for about 2hrs and then gave up.

Thought about replacing the wpi.cmd file with clean one, but would rather find issue and fix.

Oldman

Link to comment
Share on other sites


@kelsenellenelvian

As requested, One wpi.cmd

@ECHO OFF

REM Example, how to look for CDROM-drive. Must have a file to identify in its root (like WIN51 or WPI.ico).
for %%i in (D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\wpi.ico set CDROM=%%i:
echo Found CD-Rom as drive %CDROM%

REM Determine the WPI startup path.
REM if wpi should run off the cd the replace %~dp0 with %cdrom%.
REM set wpipath=%~dp0
set wpipath=%cdrom%\$OEM$\$1\Install\WPI

REM Force resolution to needed size for wpi interface.
start /wait %wpipath%\common\VideoChanger.exe 1024x768x32@75 -q

REM Hide this command window.
start /wait "%wpipath%\common\cmdow.exe" @ /hid

REM Font installation - the smooth and customizable way.
start /wait %wpipath%\common\fonts\fontinstaller.exe

REM Special registry tweak needed.
regedit /s "%wpipath%\common\wpi.reg"

REM Make WPI directory the current directory.
for /f "delims=: tokens=1" %%i in ("%wpipath%") do %%i:
cd "%wpipath%"

REM Start WPI and wait for its end
start /wait WPI.hta

REM Cleaning up the desktop.
REM del /s/q "%userprofile%\desktop\*.lnk"

REM Rebooting the sytem to finalize the installation process.
REM --shutdown.exe -r -f -t 10 -c "Reboot in 10 sec..."

exit

:end

The copy i downloaded had the line

--start "%wpipath%\common\cmdow.exe" @ /hid

which constantly gave errors, so i looked and thought that's wrong, corrected to the one above and it worked.

You'll find that --shutdown should also fail

I have REM'd out the lines i don't need.

I have also modified to use the cdrom to laod from - this works fine.

I will try a new cmdow.exe tonight when home as doing from work at present.

Oldma

Link to comment
Share on other sites

Thanks,

Also just played a bit more and the quotes aren't needed either, but still worked with the start /wait.

will remove the start /wait and let you know result.

Cheers again

Link to comment
Share on other sites

@kelsenellenelvian,

Your right removed start /wait and worked fine.

Will re-burn and test CD tonight.

Oldman

Edit: Also have no quotes as I think they're only needed if command has a space with in it?

Edited by oioldman
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...