Jump to content

Internal Setup Data Structures Are Corrupted


 Share

Recommended Posts

Hi Everyone!

When I make an ISO file from my UA installation and then try it, the first part where the setup deals with the partitions and copies installation files is ok. The other part, where the setup starts installing WinXP stops almost immediately giving me this message (chech attached image).

I've tried creating a new Installation a couple of times as I thought that something was wrong with the files, obviously. That didn't help a thing. The only thing I have in my installation right now is the installation itself along with the winnt.sif file. Anyone?

EDIT: If I press Ok, the setup log shows me the same message.

Thanks in advance!

Marthax

post-18743-1112270731_thumb.jpg

Link to comment
Share on other sites


Managed to fix it on my own. :) The problem was the winnt.sif file. I don't exactly know which part of winnt.sif that caused the error but I created a new winnt.sif and it worked.

Thx anyway.

Cheers,

Marthax

Link to comment
Share on other sites

  • 1 year later...
  • 1 month later...

Hey Marthax, I have the same problem, I'll try to remove the winnt.sif file just to see if the installations runs better. I'll report soon.

EDIT: Here are the error pictures, so people can actually see what we are talking about:

23r0eut.jpg

23r0fae.jpg

Could you post your winnt.sif file please, so we can compare with ours?

Here's what's in my winnt.sif:

[GuiUnattended]DetachedProgram="%SystemRoot%\System32\cmd.exe /c @ECHO something>%SystemDrive%\XPPRO.TAG"
Edited by andregcasal
Link to comment
Share on other sites

  • 5 months later...
  • 6 months later...

This just happened to me.

The answer is - WINNT.SIF has to have at least the [Data] section.

I wanted setup to automatically put in my product key, but I did not

want the setup to be unattended - putting the product key in alone

does not work, you need the [Data] section too like so:

[Data]
AutoPartition=0
UnattendedInstall="No"
MsDosInitiated=No

[UserData]
ProductKey=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

This way you can set everything up during install but you won't be asked

for a product key.

Whats useful about a non-unattended install is you still have the repair option.

The [unattended] section stops you having the repair option.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...