Jump to content

Wpi.hta Unresponsive


Recommended Posts


I'm having a problem just starting WPI. I downloaded the ZIP, and I've tried 2 ways of opening the .hta. I'd double clicked the .cmd and I've double clicked the .hta. The same thing happens. I get a window the 'Windows cannot open this file; choose a program" and I choose IE 6, then I get a warning window with options pertaining to a HTML Application, I've tried both "Save" and "Run", both just do nothing.

I've looked at all 7 pages of this forum, and over 50 posts. The closest thing I could find was a problem, but the solution was that it was a dual screen setup, and I'm not running that.

Anyway, if anyone could help me out, I'd really appreciate it. Also, if I'm asking a FAQ or something, please don't refer me to a single website [i've been to them all], refer me to a specific article/document/post.


Link to comment
Share on other sites

No. Maybe I've got it wrong as to what WPI is. It is a stand-alone program that you customize then put into the respective folders, and add the necessary codes, right? Or do I have to put it into the $OEM$ folders, then install and customize? Sorry, but I've confused myself soooooo bad.

Link to comment
Share on other sites

Here's what I did. I downloaded WPI, unzipped [the default unzipped folder], than I ran the .cmd, when I got to the "Which program" I chose mshta.exe. I then got the aforementioned errors

Is there something I'm doing wrong? Do I have to run it from precreated $OEM$ folders? Do I go through creating all the unattended application junk [Putting .exe(s) in "Install" folders, etc...] and then run WPI?

So it is like nLite, where I use the program first, and I create the necessary paths. THEN, I implement it?

Boy, I'm confused, I just wanted to unattend install programs with the sweet custom interface!

Link to comment
Share on other sites

Okay, I'll just wait. I did try to run just the wpi.hta, same results. Hopefully, I'll get it to run sometime or another. Thanks a million for your responses. I've actually had this problem for a long time, but feared getting totally negative responses. Hopefully, I'll get some aid by people as helpful as yourself.

Link to comment
Share on other sites

Must have something to do with your nlited installation.

I have never tried nlite, so I could only guess.

Your first error message says "Automation server can't create object".

A better text would be "An Active-X object couldn't be found or initialised" (that's what any visual basic program would say for the same error). So there's something missing on your machine at the time you're trying to execute wpi.

On a clean ínstall, you would never get the "Which program ..." question. Sorry guy, but you have to recheck your install.

the other errors are dependent on the first one. thinking object oriented the situation is the following.

an object can't be created (first error)

this object should execute one of its methods (second error)

the result of this shall be evaluated (third error)

So if you fix the first error's cause, the subsequent errors will be gone.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...