Jump to content

SetScriptWaitTimeout does not work

Recommended Posts



does it correspond to



[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Styles]


if so where is it I want to edit it out I want to use my own regtweak and cleanup

The reason i am asking hasi is bec. it does not work for me.

The only time I was able to get rid of the error and so has many others

is to use the regtweak above.

I used your wpi with SetScriptWaitTimeout that u told me to download to try.

I formatted my drive 20 times DEC 24 and it did not work for me once.

That thread i started, New Error Found. I did everything remove this , add this,

reconfigure, remove sleep, remove autoit, move my install to the %systemdrive%.

Nothing Worked. I always had an error.

Thank god for DVD +RW. I asked a java developer from another forum for help he said

to use the regtweak above.

And Behold and there was light!

your SetScriptWaitTimeout does not work

Link to comment
Share on other sites

Checked it. Problem is, that WPI can't write the value because of an overflow.

Maximum value it writes is 2147483647 which is 7fffffff hex. Must be some sort of javascript or wsh bug. (It works on my machine at home, it doesn't at work).

I'll change the value to 7fffffff in WPI. Should be more than enough.

This could be the reason, why it works, if you apply a registry tweak BEFORE you call WPI. Sorry - can't do more than that. If you need a higher value, then apply a regtweak before you start WPI

Windows Registry Editor Version 5.00


[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Styles]

- you don't have to delete the values - WPI does that for you, when it ends.

Download it again. Value has been changed. Post your results.

Link to comment
Share on other sites

sorry... after so many installs i dont want to do it again. I am sticking to what i know works.

i know that your script removes it after it is done.

if i run my regtweak before wpi, and then your wpi also sends a key

to the registry it overwrites mine. I dont want that to happen.

I need to disable it.

Either that or i will just stick to the version i hv now.

Unlike other people only a few will install Massive Programs like i do.

Pinnacle 9.2 is almost 500 MB

When u hv worked out the bugs i will use yours. Until then i am going

to just use my regtweaks before wpi, and use cleanup.cmd.

It works. i think bonedaddy, and i know for sure several other who

are using my regtweaks are happy now.

Link to comment
Share on other sites

why dont u try installing xp 20 times in one day, right before x-mas. And tell me if u want to do it anytime soon AGAIN ;)

if u dont have the bug well and good for u. It just means that u are not installing anything massive.

why dont u post your wpi so i can take a look at your programs.

I got 50 of my programs to install without any problems w/ my regtweak that i am using. Do u hv Corel Draw 12, Pinnacle Studio Plus 9.2.1, PeachTree Accounting 2005,

Micrsoft Office 2003 Full Suit with Frontpage 2003, Norton Internet Security 2005, Adobe Premier, Adobe Photoshop, etc. I hv several more giant software

that i install. NO problems now. Everything is being installed on DVD no on the hard drive.

I know of at least 20 other people experiencing the same problems.

And if there wasn't a bug why would microsoft release a fix for it???

I suggest that u test it out yourself. and tell me the results. I hv already

contacted Britishbulldog. on how to get rid of the code that doesn't work.

Link to the ERROR and fix



Link to comment
Share on other sites

i'm not suggesting that it's fun to install over and over.

i actually run a real-world install, on my real laptop every 2 weeks or so. i install about 35 programs, but i guess none of them are 'big', although i do install microsoft office...

all my apps install from the dvd i use.

i am not suggesting the bug doesn't exist, all i am saying is that someone who HAS the problem is in a much better position to let others know if hasi's solution works. (i understand your solution works, but i like to apply regtweaks that stay, i dont want to mess with adding a tweak only to remove it later)

Link to comment
Share on other sites

I suggest u read the info on Microsoft's webpage

It can better explain the bug.

Until either bonedaddy or britishbulldog tells me i am sticking to the method

that i know works. I can live with out dependencies, or exclusions.

rather than installing xp i rather make guides and solutions to problems at MSFN. big waste of 2 days trying to figure out what was wrong. And the

solution was so simple.

Link to comment
Share on other sites


my bro bought a new com today. Tested the latest wpi,

guess what half way through Corel Draw 12, I get the error.

I used the version without the setscriptwaitimeout and it worked with my regtweak. I told u so.

I already found out how to safely remove the setscriptwaittimeout from wpi.hta and generate.js and guess what it works GREAT.

with the my regtweak and the cleanup.cmd

hasi i think u should double check why your script does not work.

Link to comment
Share on other sites


i tried the newest version, with the setscriptwaittime script,

ERROR :( during installation of Net FrameWork

i remove all trace of setscriptwaittimeout from the newest version

wpi.hta and generated.js

and installed again on a old workstation at the office and it worked!

that is 2 for 2 that only confirms that it doesn't work

Link to comment
Share on other sites

First I want to say the following: THERE'S NOTHING WRONG WITH MY SCRIPT !!! I've given an answer before. Don't think I write first then think - I triple checked it before. I thought a value of 7fffffff would be enough - note that's 2.147.483.647 decimal.

Maximum integer value of javascript seems to be 7fffffff, therefore i cannot write ffffffff (4.294.967.295 decimal) to the registry. this error also happens in my freeware registry editor called 'RegCool'.

I fixed the problem in another way: first - WPI is started from a command script, that imports a tweak to the registry and starts wpi.hta.

the setscriptwaittimeout is still in there - for those who do not want to start via command script - but there's a difference to former versions. if setscriptwaittimeout finds a preset value in the registry, it won't overwrite it with 7fffffff - it just does nothing in this case. if no value is found it writes 7fffffff to the registry. Exiting wpi still removes the value from the registry - a manual deletion is not necessary.

FYI: this error only happens because i coded WPI to wait for the end of all install processes. It would be easy not to wait, but in this case WPI would close as soon as the first setup began. running a cleanup script after wpi would lead to errors.

Uploaded to the WPI homepage. Version is still 3.2.3

Link to comment
Share on other sites

No no. Everything fine.

It wasn't you to get me angry - it was the fact, that I know how to fix the prob with javascript, but javascript won't let me.

I was so glad when I gor rid of that **** .cmd file - and now there's a .cmd and a .reg file. :(

In fact I'm glad you reported the bug. I wouldn't have found it myself, since I'm not installing so many huge applications. So it's me who depends on your tests - and you're doing very well. So - thank you (for i=1 to infinite) {print("very "} much. ;)

Link to comment
Share on other sites

I was so glad when I gor rid of that **** .cmd file - and now there's a .cmd and a .reg file. :(

I don't know...

Maybe you should just include the cmd and reg files.

I always used a cmd file anyway (to call WPI to run from the CD), so maybe the cmd isnt SO bad after all. If it solves the problem, then I'm fine with it. If there was a better way to solve it without the cmd, sure. But this isn't the worst case - it's better than having the bug!!

So now, let me see if I understand the current method:

CMD is called:

...|-- calls a .REG file: puts ffffffff (which fixes the problem, as per Astalavista)

...|-- calls WPI.hta

...........|-- Looks in registry:

.......................|-- IF value is already there (from above .reg file, for example), NOTHING is done.

.......................|-- IF no value is there (because no reg file was called), WPI adds 7fffffff (not as large as ffffffff ; but largest possible value when working with javascript.)

...........|-- Installs selected programs

...........|-- Deletes value from .reg (no matter if it is the ffffffff put there manually from reg file, or if it is the 7fffffff put there by WPI - in either case, it is deleted)

is this correct?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...