Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
vinpu

Unattended Install of VIA VT8237 SATA RAID Drivers

Recommended Posts

You HAVE to edit the txtsetup.sif file to get MassStorage drivers installed! ;)

Here's a guide

EDIT: fixed wrong URL

[sourceDisksFiles]si3112.sys = 1,,,,,,3_,4,1

[HardwareIdsDatabase]

PCI\VEN_1095&DEV_3112&SUBSYS_31121095 = "Si3112"

PCI\VEN_1095&DEV_3112&SUBSYS_34238086 = "Si3112"

PCI\VEN_1095&DEV_3112&SUBSYS_311215D9 = "Si3112"

PCI\VEN_1095&DEV_3112&SUBSYS_B0021458 = "Si3112"

PCI\VEN_1095&DEV_3112&SUBSYS_01661028 = "Si3112"

PCI\VEN_1095&DEV_3112&SUBSYS_82141033 = "Si3112"

PCI\VEN_1095&DEV_3512&SUBSYS_35121095 = "Si3112"

PCI\VEN_1095&DEV_3512&SUBSYS_01661028 = "Si3112"

[sCSI.load]

si3112 = si3112.sys,4

[sCSI]

si3112 = "Silicon Image SiI 3112 SATALink Controller"

How do you adapt these to the VIA driver?

Thanks!

Share this post


Link to post
Share on other sites

Hmmm... this post may seem old. Does anyone still have the problems?

I'm another one who's been having this problem. I've noticed that the PreOEMInstall tag seems to be a culprit in mine. Everytime I set it to YES, I get the BSOD if I slipstreamed the drivers, or if I use a floppy, at time of copying the files to the HD, it'll just say unable to copy viam.sys.

As far as to why the OEM string would prevent this, I do not know why yet. Can anyone replicate this?

Thanks,

Any response would be appreciated

Share this post


Link to post
Share on other sites
Hmmm... this post may seem old. Does anyone still have the problems?

I'm another one who's been having this problem. I've noticed that the PreOEMInstall tag seems to be a culprit in mine. Everytime I set it to YES, I get the BSOD if I slipstreamed the drivers, or if I use a floppy, at time of copying the files to the HD, it'll just say unable to copy viam.sys.

As far as to why the OEM string would prevent this, I do not know why yet. Can anyone replicate this?

Thanks,

Any response would be appreciated

Could you please post your hwids, using my little tool save_hwids.exe. Please attach your hwids.txt.

Edited by Bâshrat the Sneaky

Share this post


Link to post
Share on other sites

You know... thanks to ur uber driverpacks I tried last night, it seemed to fix the problem.

It might have been just a bad entry on the txtsetup.sif :blushing:

Share this post


Link to post
Share on other sites

ok, I am really frustrated with all the drivers and sif files and $oem$ etc..etc...etc

I've been trying for two days to get XP installed on a samsung 160GB SATA. my board is an old MSI KT6 Delta (has both Promise 20378 and VT8237 V2.31)

I didnt know which one to use, but for now I've been trying to get 8237 working. with promise I cant even get the the drivers to load ..

my problem is that after an unattended setup, at the first boot I get the blue screen with STOP 000............

I downloaded the drivers from MSI's web site ...

winnt.sif

[Unattended]
UnattendMode=FullUnattended
OemSkipEula=Yes
OemPreinstall=Yes
OemPnPDriversPath = "drivers\Viaraid"
TargetPath=\WINDOWS

TXTSETUP.SIF

[SourceDisksFiles]
viamraid.sys=1,,,,,,3_,4,1
[HardwareIdsDatabase]
PCI\VEN_1106&DEV_3349="VCOMBORAID_I386_NT5"
PCI\VEN_1106&DEV_0591="VCOMBORAID_I386_NT5"
PCI\VEN_1106&DEV_3249="VCOMBORAID_I386_NT5"
PCI\VEN_1106&DEV_3149="VCOMBORAID_I386_NT5"
PCI\VEN_1106&DEV_3164="VCOMBORAID_I386_NT5"
[SCSI.load]
VCOMBORAID_I386_NT5=viamraid.sys, 4
[scsi]
VCOMBORAID_I386_NT5="VIA VT8251/8237/8237A/6421/6410 SATA RAID Controller(Windows 2K/XP/SRV2003)"

txtsetup.oem

how do I get rid of the folder paths in [disks]?

Is it supposed to be :

[Disks]

D-I386-NT5-RAID="VIA RAID Combo Driver Diskette",\ ,\NT5

[Disks]
D-I386-NT5-RAID="VIA RAID Combo Driver Diskette",\I386\VIAMRAID, \NT5
D-I386-NT4-RAID="VIA RAID Combo Driver Diskette",\I386\VIAMRAID, \NT4


[Defaults]
scsi = VCOMBORAID_I386_NT5


[SCSI]
VCOMBORAID_I386_NT5="VIA VT8251/8237/8237A/6421/6410 SATA RAID Controller(Windows 2K/XP/SRV2003)"
VCOMBORAID_I386_NT4="VIA VT8251/8237/8237A/6421/6410 SATA RAID Controller(Windows NT4)"

[Files.SCSI.VCOMBORAID_I386_NT5]
driver = D-I386-NT5-RAID, viamraid.sys, CFG_NT5
inf = D-I386-NT5-RAID, viamraid.inf
catalog = D-I386-NT5-RAID, viamraid.cat

[Files.SCSI.VCOMBORAID_I386_NT4]
driver = D-I386-NT4-RAID, viamraid.sys, CFG_NT4
inf = D-I386-NT4-RAID, viamraid.inf



[config.CFG_NT5]
value = parameters\PnpInterface,5,REG_DWORD,1

[config.CFG_NT4]
value = "", Tag, REG_DWORD, 1

[HardwareIds.scsi.VCOMBORAID_I386_NT5]
id = "PCI\VEN_1106&DEV_3349","viamraid"
id = "PCI\VEN_1106&DEV_0591","viamraid"
id = "PCI\VEN_1106&DEV_3249","viamraid"
id = "PCI\VEN_1106&DEV_3149","viamraid"
id = "PCI\VEN_1106&DEV_3164","viamraid"

also viamraid.sys cabbed in i386.... any thoughts ? thanks

post-111860-1159735603_thumb.png

Share this post


Link to post
Share on other sites

I hope to save you ALL a lot of TIME by this:

http://driverpacks.net - there's a driver pack with ALL RAID drivers and a nice GUI that will slipstream them in for you.

For dummies - download the driver pack here: http://driverpacks.net/DriverPacks/download.php?pag=m

download the base (GUI) here: http://driverpacks.net/DriverPacks/download.php?pag=b

Unpack the base, drop the driverpack (UNPACKED) into the /DriverPacks directory, run GUI

Select "disk" if u're gonna burn with nlite or something or bart if u're doing preinstalled bartpe. That's it!

Note: Method 1 (using $OEM$ sometimes fails, try method 2, it works).

i'm sorry if this is old news for some of you or you really wanted to do it yourself, but I've wasted good 16 hours (straight) trying

to do this manually (using everything from nlite to xpcreate, and just using notepad and etc., etc.) and that worked for me, so I

hope to save some frustration for some of you who will find this useful.

NOTE2: THIS IS ONLY FOR 32BIT WIN2K/XP/2K3 INSTALLATIONS ONLY!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...