Jump to content

VDubs - Windows Setup Front-End & more


 Share

Recommended Posts

VDubs (Voltaic's Windows Setup, "W" pronounced "dub") is a windows setup front-end i have been working on. it's finally stable enough that i can release a beta of it! only catch is that it's written in java because that's all i know right now. i'm going to learn c++ when i get a chance (in the next 10 months hopefull) and port it to c++. the good news is that i have included a batch file to decrease the footprint to only about 16MB.

anyway, here are the features:

any number of windows nt based installations

any number of applications can selected/deseleceted and automatically installed.

any number of tweaks can be selected/deselected and installed with Windows.

specify all data to be used by windows installation up-front

multiple application and registry tweak profiles can be selected for easy installation of a subset of your applications.

[ 1.0b (Beta) ]

* Initial Release

[ 1.1b (Beta) – 9/21/04 ]

* Fixed installation issue (install.cmd) which did not “unload” the setupreg.hiv file from the registry after modifying it.

* Added “/syspart:c: /tempdrive:c:” to the winnt32.exe execution string.

* No longer distributing Java Runtime with Vdubs because of storage requirements. (see readme for more info)

[ 1.11b (Beta) – 9/21/04 ]

* Fixed the issue about the reduce size.cmd, umm, just not working. Oops! More specifically, the 7zip program used to re-compress the runtime files was missing a dll resulting in no files actually being extracted.

* Fixed more batch file probs: not correctly mounting the setupreg.hiv file. I'm a java programmer, not a batch file fiend

[ 1.12b (Beta) – 9/22/04 ]

* merged upgrade.cmd into install.cmd and added a menu to allow selection between the two.

* added a section to install.cmd to automatically create a batch file to make your image for you. Note that it requires that you already have cdimage.exe somewhere on your hard drive.

[ 1.13b (Beta) – 9/22/04 ]

* fixed the command line to be executed as shell for Windows PE

[ 1.3b (Beta) - 10/6/04 ]

* added ability to have application and registry setting preset groups

* added ability to "select all" and "select none" on application and registry tweak selection screens

* added force restart feature via peshutdown.exe thanks to the (anonymous) author (http://home.t-online.de/home/520085154509)

* added options to delete installation files upon completion of install

* made windows setup restart and try again if exited with errorlevel > 0

* implemented verbose checkbox

* added more defaults to defaults.ini

* fixed more command lines within code

* added a few cosmetic perks

* fixed the issue where there would sometimes be a blank registry tweak in the list toward the top

[ 1.31b (Beta) – 10/13/04 ]

* fixed minor bug that would cause vdubs to enable a command for deleting installation files even if no applications were selected for installation

* fixed another somewhat less minor bug that involves the syntax checking for tweaks.

* added a feature to the install batch file to use a custom directory for vdubs files.

* fixed a few other very minor bugs.

* put all class and image files in a jar file instead of in a directory

* updated the readme to reflect recent changes, fixed a few inaccuracies, improved readability of directory structure diagram

[ RC1 – 10/21/04 ]

*Fixed the syntax checking for registry tweaks. Everything should be fine now. <knocks on wood>

[bugs Identified in RC1]

*format does not work if drive has pre-existing label

*a few remaining registry tweak checking issues

basically just run the utility, pick what you want to install, put in your user info, and let it copy all the files. after that you can take your cd and walk away!

vdubs131.gif

vdubs132.gif

I plan to maintain this and add some new features in the future. hopefully it gets popular like some of the other tools members have made.

anyway, enjoy. i will be checking the boards for any questions, bug reports, etc.

If for some reason i don't respond withing a few days to a post, just AIM me to get my attention. Screen Name: VoltaicSCA

Download Voltaic's Windows Installer HERE!

-Voltaic

Link to comment
Share on other sites

  • 2 weeks later...

Ive only just noticed this as it appeard on the Msfn front page (this is easiest for me)

This is normaly the way i find new posts

I don't know how others find new info

I have downloaded and will be trying it tonight

will post thoughts later

Link to comment
Share on other sites

Looks interesting. First that I have seen of it.

I believe M$ has a program that can convert java to c#, if you are interested to learning a new language.

I will have a look at this program, once downloaded.

Thanks

:)

Link to comment
Share on other sites

ya, unfortunately the c# runtime is even bigger than the java one. i tried that code conversion utility (not by microsoft, by the way) and it did a pretty crappy job to begin with. like i said, i am going to take a c++ class so i can rewrite the thing, but until then, a 16MB footprint isn't too bad.

enjoy!

Voltaic

[edit]

this response really wasn't designed to be a flame, but as i read over it for the 2nd time, it kinda sounds that way, sorry!

Link to comment
Share on other sites

right now it is only TESTED to run from pe, but really, if you just use some common sense when picking your settings, it should run straight from any version of windows nt/2k/xp

by the way:

as i remember there is a probelm launching winnt32.exe, so if it doesn't work for you, the command line that you should use (from pe) would be:

c:\i386\winnt32.exe /unattend:c:\i386\winnt.sif /syspart:c: /tempdrive:c:

Link to comment
Share on other sites

:} Hmm....I followed the instructions per your readme, but I am unable to get it to work. I wanted to integrate it into my bart's PE, but after installing it to my i386 directory in my "pebldr" directory. It won't build the iso, something about the setupreg.hiv cannot be opened.

I really like your concept on this installer, but I am having a bit of trouble getting it to work. Could you be so kinda as to :whistle: "lemanize" the instructions a bit more.

This is what I have been doing (god help me):

1) Build my Barts PE in the Pebldr directory

2) execute the reduce size.cmd (its does its lil thing)

3) execute the install.cmd and input the above mention directory (C:\pebldr\i386)

4) Try to build the iso using bartpe, get error code 1. cannot open setupreg.hiv (not to mention it says another process is using it and I can't delete it or anything)

If anyone can tell me what I am doing wrong, please educate a brutha!! :thumbup:thumbup

Link to comment
Share on other sites

That was a bug in my installation CMD file. you can either manually unload the hive from your registry using regedit. click on the HKLM\vdubs key and go File>Unload Hive.

you should then be able to create your image just fine.

alternatively (recommended) you can download the newest release (1.1b) which will taunt you with some "yet to be implemented" features that can drive your imagination wild as you fantasize as to their TRUE purpose. oh, and a bug fix or two.

[edit]

additionally, it appears that my instructions may have been lacking in another area. i had intended this to be used on a pre-existing windows pe (or bartpe) folder. you would then run the install.cmd file using the i386 folder as the path when prompted. you would then create the image with something like CDIMAGE.

it wass really designed so that you can have any number of distros of windows xp on it, so the "optomize" feature is really useful for that, but use it as you see fit.

[edit, again]

more batch file problems, stand by...

-Votlaic

Link to comment
Share on other sites

Thanks voltaic,

I will give this new version a run around the block a couple times and let you know what I find:

:thumbup:thumbup:thumbup

{edit}

Finding some error: access denied problems when running the reduce size.cmd, but it should work without the reduced size cmd file, will try and test it from there........ thanks again.... :hello:

Link to comment
Share on other sites

ok, posted an update to the 1.1b version. we'll just call it 1.12b. whatever.

i did more testing on the batch files and fixed hopefully all problems with it, as well as included an upgrade.cmd for people upgrading existing versions.

hope this works.

let me know.

-Voltaic

Link to comment
Share on other sites

:blink: new version!! yay!! I will give this version a go when I get home today.

Just a side note, is there a command or something that I can do to test the installer within my windows install (without messing anything up, don't worry about it if there isn't)? :hello:

Link to comment
Share on other sites

ya, you can just run the following from within the cd's root:

jre\java.exe -cp vdubs Installer

this should work assuming that you used my installer batch file to add it to your cd.

note that i am writing this without access to my files so if it's wrong i'll correct it later.

-Voltaic

Link to comment
Share on other sites

Ok, got MUCH further with this last version.....

but, it got into windows...then tried to execute the java command and gets stuck here...

Edit: Can you by chance tell me where exactly the couple folders that it installs are supposed to be?

-B/c it seems like they are being put outside of the i386 folder and I wanted to be able to double check to make sure they are where they are supposed to before I build the CD.

-and am I supposed to be using the boot.bin from the vdubs folder instead of the bootsect.bin in the pebldr folder?

post-70-1095993366_thumb.jpg

Link to comment
Share on other sites

well...

the command is right.

if you look in the readme.html it will show you what your directory structure should look like relative to the cd root.

but to more accurately answer your question, the folders (vdubs, jre, install, data) should be outside of the i386 dir actually on the root folder of the cd.

as far as the error you are getting it looks like it can't find a class file, howver, by virtue of the fact that it knows what line numbers the error resides on implies that it at least has the Installer.class file. furthermore, there is no reference to another method in another class on any of the line numbers mentioned in the error message you posted.

you should check your directory structure against what is listed in the readme, and make sure that you are using the most recent version. (sorry to say the obvious, but that's the only thing i can think of.)

the most probably cause is that the class files are in a different directory than %systemdrive%\vdubs.

it might also be worth mentioning that if you run that command line from within YOUR windows (like the one you use everyday) you will need to change the paths accordingly.

if you are running from within windows you should run java.exe with no parameters to read up on the -cp switch so it points to the correct directory.

anyway, i'm sure this is more information that you need (or at least i hope it's too much instead of too little :)) but i hope it helps.

-Voltaic

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...