Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
mkill

...but diskpart in bartpe..?!? SP2 bug..?!?

Recommended Posts

hi! ... and really sorry for my very poor english :wacko:

I made a bootable live windows CD from BartPE Version 3.0.32

and source files from a Windows XP Professional (SP1 -->pacth-->) SP2 cd.

but... when from the comand-line I run "diskpart" ...it doesn't go!!!

I have an error sounds like: "impossible to complete the operation for the serivices of management disc"

(for italian users: "impossibile completare l'operazione per i servizi di gestione disco")

my hd is installed on UltraATA133 channel of nForce2 mainboard...

helppp! I really need to run diskpart :}

Share this post


Link to post
Share on other sites

They changed the way RPC works in SP2. Use the following inf in addition to whatever you already have.

; zmmc_sp2.inf
; MMC add-on for Windows XP SP2

[Version]
Signature= "$Windows NT$"

[PEBuilder]
Name="MMC add-on for Windows XP SP2"
Enable=1

[SetupReg.AddReg]
0x1, "ControlSet001\Services\RpcSs","Description","Provides the endpoint mapper and other miscellaneous RPC services."
0x1, "ControlSet001\Services\RpcSs","DisplayName","Remote Procedure Call (RPC)"
0x4, "ControlSet001\Services\RpcSs","ErrorControl", 0x00000001
0x1, "ControlSet001\Services\RpcSs","Group","COM Infrastructure"
0x2, "ControlSet001\Services\RpcSs","ImagePath","%SystemRoot%\system32\svchost -k rpcss"
0x1, "ControlSet001\Services\RpcSs","ObjectName","LocalSystem"
0x4, "ControlSet001\Services\RpcSs","Start", 0x00000002
0x4, "ControlSet001\Services\RpcSs","Type", 0x00000020
0x3, "ControlSet001\Services\RpcSs","FailureActions",\
00,00,00,00,00,00,00,00,00,00,00,00,01,00,00,00,00,00,00,\
00,02,00,00,00,60,EA,00,00
0x7, "ControlSet001\Services\RpcSs","DependOnService","DcomLaunch"
0x2, "ControlSet001\Services\RpcSs\Parameters","ServiceDll","%SystemRoot%\system32\rpcss.dll"
0x3, "ControlSet001\Services\RpcSs\Security","Security",\
01,00,14,80,a8,00,00,00,b4,00,00,00,14,00,00,00,30,00,00,00,02,\
00,1C,00,01,00,00,00,02,80,14,00,FF,01,0F,00,01,01,00,00,00,00,00,01,00,00,\
00,00,02,00,78,00,05,00,00,00,00,00,14,00,8D,00,02,00,01,01,00,00,00,00,00,\
05,0B,00,00,00,00,00,18,00,FF,01,0F,00,01,02,00,00,00,00,00,05,20,00,00,00,\
20,02,00,00,00,00,18,00,8D,00,02,00,01,02,00,00,00,00,00,05,20,00,00,00,23,\
02,00,00,00,00,14,00,9D,00,00,00,01,01,00,00,00,00,00,05,04,00,00,00,00,00,\
18,00,9D,00,00,00,01,02,00,00,00,00,00,05,20,00,00,00,21,02,00,00,01,01,00,\
00,00,00,00,05,12,00,00,00,01,01,00,00,00,00,00,05,12,00,00,00
0x1, "ControlSet001\Services\RpcSs\Enum","0","Root\LEGACY_RPCSS\0000"
0x4, "ControlSet001\Services\RpcSs\Enum","Count", 0x00000001
0x4, "ControlSet001\Services\RpcSs\Enum","NextInstance", 0x00000001

0x1, "ControlSet001\Services\DcomLaunch","Description","Provides launch functionality for DCOM services."
0x1, "ControlSet001\Services\DcomLaunch","DisplayName","DCOM Server Process Launcher"
0x4, "ControlSet001\Services\DcomLaunch","ErrorControl", 0x00000001
0x1, "ControlSet001\Services\DcomLaunch","Group","COM Infrastructure"
0x2, "ControlSet001\Services\DcomLaunch","ImagePath","%SystemRoot%\system32\svchost -k DcomLaunch"
0x1, "ControlSet001\Services\DcomLaunch","ObjectName","LocalSystem"
0x4, "ControlSet001\Services\DcomLaunch","Start", 0x00000002
0x4, "ControlSet001\Services\DcomLaunch","Type", 0x00000020
0x3, "ControlSet001\Services\DcomLaunch","FailureActions",\
00,00,00,00,00,00,00,00,00,00,00,00,01,00,00,00,00,00,00,\
00,02,00,00,00,60,EA,00,00
0x2, "ControlSet001\Services\DcomLaunch\Parameters","ServiceDll","%SystemRoot%\system32\rpcss.dll"
0x3, "ControlSet001\Services\DcomLaunch\Security","Security",\
01,00,14,80,b4,00,00,00,c0,00,00,00,14,00,00,00,34,00,00,00,02,\
00,20,00,01,00,00,00,02,80,18,00,FF,01,0F,00,01,01,00,00,00,00,00,01,00,00,\
00,00,20,02,00,00,02,00,80,00,05,00,00,00,00,03,18,00,8D,00,02,00,01,01,00,\
00,00,00,00,01,00,00,00,00,00,00,00,00,00,03,18,00,FF,01,0F,00,01,02,00,00,\
00,00,00,05,20,00,00,00,20,02,00,00,00,03,18,00,8F,00,02,00,01,02,00,00,00,\
00,00,05,20,00,00,00,23,02,00,00,00,03,18,00,9D,00,00,00,01,01,00,00,00,00,\
00,05,04,00,00,00,23,02,00,00,00,03,18,00,9D,00,00,00,01,02,00,00,00,00,00,\
05,20,00,00,00,21,02,00,00,01,01,00,00,00,00,00,05,12,00,00,00,01,01,00,00,\
00,00,00,05,12,00,00,00
0x1, "ControlSet001\Services\DcomLaunch\Enum","0","Root\LEGACY_DCOMLAUNCH\0000"
0x4, "ControlSet001\Services\DcomLaunch\Enum","Count", 0x00000001
0x4, "ControlSet001\Services\DcomLaunch\Enum","NextInstance", 0x00000001

Cheers

Share this post


Link to post
Share on other sites

ok, that's right. Now diskpart runs very well.

but.... now I have another question:

I have pacthed my Windows Sp1 cd to --> sp2 with AutoStreamer,

and I make a WinPE boot cd with the lastest version of BartPE..

but when I start installation of winxpsp2 from command-line, windows asks me some files (20-30 files) like:

acverfyr.dll

asfsipc.dll

dbmsadsh.dll

dxmrtp.dll

...in my win-sp2 cd I haven't got these files, but they are in my previous version sp1!!!

how can I start a win xp2 installation correctly from winpe-command-line?!? why I alredy haven't got these files!?

thanx a lot!

Share this post


Link to post
Share on other sites

So you are getting the errors when you are try to install windows from inside of WinPE? Where are you trying to install from (ie another CD-ROM, network...)?

Cheers

Share this post


Link to post
Share on other sites

yes, when I try to install windows from inside of WinPE.

But now it runs correctly.

Simply I ran the AutoStreamer patch using only i386 folder of the original cd. ..and i get the error.

Then i patched the entire cd and runs correctlyl

thanks a lot 4the answers!!!

:thumbup:thumbup

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...