Jump to content

Auto Login not working for RunOnceEx


Recommended Posts

Basically when the GUI setup is finished it reboots then is suppose to autologin to run the RunOnceEx stuff, but for some reason it won't autologin. I have to type in the password then hit ok and then RunOnceEx starts. It was working before but I have made some changes in my winnt.sif since then that might have made it not work. Trying to figure out why it isn't autologing in anymore...

winnt.sif

;SetupMgrTag
[Data]
   AutoPartition=0
   MsDosInitiated="0"
   UnattendedInstall="Yes"

[Unattended]
   UnattendMode=FullUnattended
   OemSkipEula=Yes
   OemPreinstall=Yes
   UnattendSwitch="yes"
   TargetPath=\WINDOWS
   FileSystem=*
   WaitForReboot="No"

[GuiUnattended]
   AdminPassword="1234"
   AutoLogon=Yes
   AutoLogonCount=1
   EncryptedAdminPassword=NO
   OEMSkipRegional=1
   TimeZone=20
   OemSkipWelcome=1

[UserData]
   ProductKey=blah
   FullName="Nemesis"
   OrgName=""
   ComputerName=Nemesis2

[Display]
   BitsPerPel=32
   Xresolution=800
   YResolution=600
   Vrefresh=85

[RegionalSettings]
   LanguageGroup=1

[URL]
   Home_Page=http://www.google.com
   Help_Page=http://www.google.com
   Search_Page=http://www.google.com

[Identification]
   JoinWorkgroup=WORKGROUP

[Networking]
   InstallDefaultComponents=Yes

[GuiRunOnce]

[Components]
   msmsgs=off
   msnexplr=off
   TerminalServer = On
   Freecell = off
   Hearts = Off
   minesweeper=off
   pinball=off
   spider=off
   zonegames=off
   
[Shell]
   DefaultStartPanelOff = Yes
   DefaultThemesOff = Yes

Link to comment
Share on other sites


just delete the autologoncount line altogether, then it will logon all the time...

even better, from cmdlines.txt create an autologon admin account... it's better than logging in with Administrator all the time!

cmdlines.txt

[COMMANDS]
"useraccounts.cmd"

useraccounts.cmd

@echo off
net user "UserName" password /add
net localgroup Administrators "UserName" /add
regedit /s autologon.reg
regedit /s user.reg

autologon.reg

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"DefaultUserName"="UserName"
"DefaultPassword"="password"
"AutoAdminLogon"="1"

user.reg

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]
"RegisteredOwner"="Yourname"
"RegisteredOrganization"="Business"

Note: you don't have to include user.reg for this to work

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...