Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

[SOLVED] USB and Windows 2000 on Dell Latitude E6530


 Share

Recommended Posts

Dell Latitude E6530 (2014)

Intel Ivy Bridge (Intel HD 4000)

16GB of Ram

1TB HDD

Intel Core i5

Os's from Windows XP through Windows 10 have been installed on this laptop at one point or another and all are confirmed working.

If you need anything else, please let me know.

Hi! I am trying to install Windows 2000 onto a Dell Latitude E6530, but am having problems. The CD I am using has BlackWingCat's SATA drivers integrated as well as SP4. Due to an ACPI error, I had to press F7 to continue and the DOS-esk setup goes smoothly. Was able to detect the full 400GB that I set aside for the OS (as a dual-boot with XP), able to format it just fine, etc. However, once it gets done with that stage and the laptop restarts into the GUI setup phase (where it sets up devices, your user account, etc), that's where it stops working. The next part of setup loads just fine, however, the laptop's built-in mouse and keyboard do not work at all as is also the case with the lone USB 2.0 port (the rest are 3.0). Despite these things not working, it is at least able to get to the Setup is installing your devices screen, but after that, I cannot proceed. This laptop has no PS/2 ports so I cannot use that nor do I have a PIC-E USB and/or PS/2 card.

So I was wondering if it would be possible to slipstream in working USB 2.0 drivers so I can use the USB mouse to finish the second part of installation. I'm sure @blackwingcat is bound to have something to help get me through this issue. I should note that the built-in mouse/keyboard work in the BIOS and they also work on the OS bootloader (where I get to choose between 2000 and XP), but then stop after I select 2000. I should also note that they also work just fine under XP (which has driver support). Any help on this issue is greatly appreciated, especially blackwingcat's whom I've summoned here in the hopes of drawing his attention.

Edited by Jakob99
Link to comment
Share on other sites


This has been solved! I just needed to press F5 and choose Standard PC. Doing this did not produce the non-ACPI compliant BIOS error and it also allowed the mouse/keyboard to finally work during the second part. Windows 2000 shall be up and running in no time.

Link to comment
Share on other sites

  • Jakob99 changed the title to [SOLVED] USB and Windows 2000 on Dell Latitude E6530

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...