Jump to content

Power management tab won't appear in 10 Home


Recommended Posts

In Windows 10 Home, I'm not able to access the Power Management tab under Device Manager > Network adapters > Realtek 8821CE Wireless LAN 802.11ac PCI-E NIC > Properties. This network card is apparently notorious for disconnecting every few minutes and requiring a reset when the computer isn't plugged into a power outlet.


I've tried the trick where you make DWORD key CsEnabled with value of 0 under Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power in regedit, but this didn't work.

I also tried taking the alternate route, Control Panel > Devices and Printers > (Computer name) > Properties > Hardware > Realtek 8821CE Wireless LAN 802.11ac PCI-E NIC > Properties, which was reported by some to make the Power Management tab to appear, but this didn't work either.

Some people pointed out that certain Dell machines will need to have Wake on USB enabled in their BIOS to make it appear after making the above changes. However, my BIOS doesn't have any such option. I'm using a Dell Inspiron 15 3000 currently.


Is there anything else that can be done to get this thing working without being plugged into a wall outlet? I want to avoid purchasing more parts if possible, since I have no experience making these changes and also want to avoid wasting one of my USB slots on something my computer should've been able to accomplish by itself.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...