Jump to content
MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. ×

Aeroglass hooks dwm, but then crashes

Recommended Posts

I'm on 1909, and installing the latest aeroglass
I've downloaded symbols with pdbdownloader.exe as some other people suggest, and none of them have a .error file,
and to be safe i've downloaded the pdbs for dwmapi, dwmcore, dwmghost, dwminit, dwmredir, dwmscene, applicationframe, and udwm just to be absolutely sure it has the pdbs it needs
In the debug.log file there is no immediate issues, it loads correctly then just says it's crashed many times (see bottom of post for debug.log)

The thing is: when i run the install and it shows the finish screen it doesn't give me the 'dont know how to hook this version of dwm' anymore (i had this issue previously, it appears downloading the pdbs fixed that),
and my screen flashes (three times, specifically) and for about 3 seconds each time i see aeroglass working as intended, with my settings in aeroglassgui and everything, then it just reverts and doesn't give me the hwid popup, and aeroglass doesn't function (no opacity, no coloring, about the only thing that changes is that there will be an accent around the windows, but you can't change it's settings)

thanks for the help guys; i really do appreciate it.

[2020-08-02 17:15:12][0x2A84:0x3074] Machine ID: [MACHINE ID HIDDEN]
[2020-08-02 17:15:12][0x2A84:0x3074] Checking key [KEY HIDDEN]
[2020-08-02 17:15:12][0x2A84:0x3074] Hook (USER32.dll!DrawTextW from udwm.dll) installed
[2020-08-02 17:15:12][0x2A84:0x3074] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed
[2020-08-02 17:15:12][0x2A84:0x3074] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed
[2020-08-02 17:15:12][0x2A84:0x3074] Aero Glass for Win8.1+ x64 correctly loaded (C:\AeroGlass\DWMGlass.dll).
[2020-08-02 17:15:12][0x46C:0x3CA4] C:\AeroGlass\DWMGlass.dll has been injected into dwm.exe. 
[2020-08-02 17:15:13][0x2A84:0x32A0] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols 
[2020-08-02 17:15:13][0x2A84:0x32A0] Loading settings (flags = 0x3) from HKEY 0x0000000000000EF8 for session #1 
[2020-08-02 17:15:13][0x2A84:0x32A0] dwmcore.dll version 10.0.18362.752 
[2020-08-02 17:15:14][0x2A84:0x32A0] udwm.dll version 10.0.18362.752 
[2020-08-02 17:15:15][0x2A84:0x32A0] Symbols loaded from external files: 0x2000 
[2020-08-02 17:15:19][0x46C:0x3CA4] dwm.exe process crashed several times. DLL injection has been stopped.

If you need my dmp files just ask, but opening them in visual studio the exception information reads:

"The thread tried to read from or write to a virtual address for which it does not have the appropriate access."

the exception code is 0xC0000005 and the process name is dwm.exe
other than that idk if you need more info about the dump file, so like i said if you need it just ask :)

Edited by InVaLiD_EDM
made info more accurate
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...