Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


InVaLiD_EDM

Member
  • Content Count

    3
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About InVaLiD_EDM

Profile Information

  • OS
    Windows 10 x86
  • Country

Flags

  • Country Flag
  1. I'm on 1909, and installing the latest aeroglass I've downloaded symbols with pdbdownloader.exe as some other people suggest, and none of them have a .error file, and to be safe i've downloaded the pdbs for dwmapi, dwmcore, dwmghost, dwminit, dwmredir, dwmscene, applicationframe, and udwm just to be absolutely sure it has the pdbs it needs In the debug.log file there is no immediate issues, it loads correctly then just says it's crashed many times (see bottom of post for debug.log) The thing is: when i run the install and it shows the finish screen it doesn't give me the 'dont know how to hook this version of dwm' anymore (i had this issue previously, it appears downloading the pdbs fixed that), and my screen flashes (three times, specifically) and for about 3 seconds each time i see aeroglass working as intended, with my settings in aeroglassgui and everything, then it just reverts and doesn't give me the hwid popup, and aeroglass doesn't function (no opacity, no coloring, about the only thing that changes is that there will be an accent around the windows, but you can't change it's settings) thanks for the help guys; i really do appreciate it. [2020-08-02 17:15:12][0x2A84:0x3074] Machine ID: [MACHINE ID HIDDEN] [2020-08-02 17:15:12][0x2A84:0x3074] Checking key [KEY HIDDEN] [2020-08-02 17:15:12][0x2A84:0x3074] Hook (USER32.dll!DrawTextW from udwm.dll) installed [2020-08-02 17:15:12][0x2A84:0x3074] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed [2020-08-02 17:15:12][0x2A84:0x3074] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed [2020-08-02 17:15:12][0x2A84:0x3074] Aero Glass for Win8.1+ 1.5.13.1621 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll). [2020-08-02 17:15:12][0x46C:0x3CA4] C:\AeroGlass\DWMGlass.dll has been injected into dwm.exe. [2020-08-02 17:15:13][0x2A84:0x32A0] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols [2020-08-02 17:15:13][0x2A84:0x32A0] Loading settings (flags = 0x3) from HKEY 0x0000000000000EF8 for session #1 [2020-08-02 17:15:13][0x2A84:0x32A0] dwmcore.dll version 10.0.18362.752 [2020-08-02 17:15:14][0x2A84:0x32A0] udwm.dll version 10.0.18362.752 [2020-08-02 17:15:15][0x2A84:0x32A0] Symbols loaded from external files: 0x2000 [2020-08-02 17:15:19][0x46C:0x3CA4] dwm.exe process crashed several times. DLL injection has been stopped. If you need my dmp files just ask, but opening them in visual studio the exception information reads: "The thread tried to read from or write to a virtual address for which it does not have the appropriate access." the exception code is 0xC0000005 and the process name is dwm.exe other than that idk if you need more info about the dump file, so like i said if you need it just ask
  2. Well, it's been a little bit and they've released aeroglass for up to 1909, and trying to install that still doesn't work. I've downloaded symbols with pdbdownloader.exe as some other people suggest, and none of them have a .error file, but it still freaks out and to be safe i've downloaded the pdbs for dwmapi, dwmcore, dwmghost, dwminit, dwmredir, dwmscene, and udwm just to be absolutely sure it has the pdbs it needs In the debug.log file there is no immediate issues, it loads correctly then just says it's crashed many times (see bottom of post for debug.log) it repeats that several times as it retries to hook dwm idk what this message means, and therefore i don't know what i can do to fix it. The thing is: when i run the install and it shows the finish screen it doesn't give me the 'dont know how to hook this version of dwm' anymore, and my screen flashes (three times, specifically) and for about 3 seconds each time i see aeroglass working as intended, with my settings in aeroglassgui and everything. thanks for the help guys; i really do appreciate it. Update: Right after posting this a command prompt opened up and downloaded applicationframe.pdb [2020-08-02 17:15:12][0x2A84:0x3074] Machine ID: [MACHINE ID HIDDEN] [2020-08-02 17:15:12][0x2A84:0x3074] Checking key [KEY HIDDEN] [2020-08-02 17:15:12][0x2A84:0x3074] Hook (USER32.dll!DrawTextW from udwm.dll) installed [2020-08-02 17:15:12][0x2A84:0x3074] Hook (GDI32.dll!CreateBitmap from udwm.dll) installed [2020-08-02 17:15:12][0x2A84:0x3074] Hook (GDI32.dll!CreateRoundRectRgn from udwm.dll) installed [2020-08-02 17:15:12][0x2A84:0x3074] Aero Glass for Win8.1+ 1.5.13.1621 x64 correctly loaded (C:\AeroGlass\DWMGlass.dll). [2020-08-02 17:15:12][0x46C:0x3CA4] C:\AeroGlass\DWMGlass.dll has been injected into dwm.exe. [2020-08-02 17:15:13][0x2A84:0x32A0] DBGHELP: Symbol Search Path: .;SRV*C:\AeroGlass\symbols*http://msdl.microsoft.com/download/symbols [2020-08-02 17:15:13][0x2A84:0x32A0] Loading settings (flags = 0x3) from HKEY 0x0000000000000EF8 for session #1 [2020-08-02 17:15:13][0x2A84:0x32A0] dwmcore.dll version 10.0.18362.752 [2020-08-02 17:15:14][0x2A84:0x32A0] udwm.dll version 10.0.18362.752 [2020-08-02 17:15:15][0x2A84:0x32A0] Symbols loaded from external files: 0x2000 [2020-08-02 17:15:19][0x46C:0x3CA4] dwm.exe process crashed several times. DLL injection has been stopped.
  3. Howdy! I've been using aeroglass fine for the last, idk i'd say year or so, and it's wonderful however when windows rolled over to 1903 aeroglass complained about my dwm, and i've done basically everything. my windows build is 18363 (1909) and somehow my dwm differs from the normal? I have the debug.log and I've unmarked my key and machine id, but i assure you that's all correct. and i've tried completely uninstalling it and reinstalling it with no luck. I'll give y'all the debug.log, and if you need the memory dump just ask and i'll happily send it over. Thanks for your time, i appreciate it debug.log
×
×
  • Create New...