Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


docker

Garbled display in Win98SE/QEMU with command.exe!

Recommended Posts

Hi all!  Much thanks to the members for helping me out with my previous question.  I'm very happy with how my Windows 98SE installation works in QEMU!  It's using the VBEMP.INF driver from https://bearwindows.zcm.com.au/vbe9x.htm, and mostly everything is fine.  However, as soon as I open a command prompt (Start > Run > command) the display gets garbled.  Reliably.  Every time.  The same way.  I'm still able to save the day by hitting the windows key the 'u' and 'enter' to safely shut down, but this makes it really hard to run commands.

Does anyone have any ideas?   Unfortunately I don't even know where to begin debugging this issue. 

The attached screenshot shows before / after running command prompt.

Screen Shot 2020-03-19 at 22.31.54.jpg

Screen Shot 2020-03-19 at 22.32.05.jpg

Share this post


Link to post
Share on other sites

After a bit of digging, I have discovered that setting my display settings to 16-color helps – now, the display doesn't jump at all when opening Command Prompt.  When setting the screen to 256 colors, then opening command prompt, the screen gets somewhat distorted (the width and height of the QEMU window are stretched) but it's still usable.  With higher color settings, it's unusable.  Very strange! 🤔

Share this post


Link to post
Share on other sites
Posted (edited)

Why? :unsure:

I mean, VBEMP is known to have issues with Command.com. also on "real" hardware:

 and the general idea of VBEMP is to use it on some video cards for which there is no manufacturer driver (for the given OS).

If you don't use a windowed command prompt but switch to full screen it should work, see the above mentioned thread, try Alt+Enter.

Check also:

https://msfn.org/board/topic/163436-vbemp-9x-with-3d-aceleration/

whether dos prompt works or not depends on the specific video card.

Qemu uses rather standard (emulated) video cards, so you should not *need* VBEMP. :dubbio:

But maybe the same VBEMP driver might work with a different (emulated) video card in QEMU, there are several ones to choose among, depending on QEMU versions and builds.

Which (EXACT) Qemu build are you using?

Under which (EXACT) OS?

Using which (EXACT) parameters to launch QEMU?

jaclaz

Edited by jaclaz

Share this post


Link to post
Share on other sites
19 hours ago, jaclaz said:

I mean, VBEMP is known to have issues with Command.com. also on "real" hardware:

Ah, I didn't know that, thank you very much!  I tried searching the forum, but must've failed.  Your tip about fullscreen worked!  That's good enough for me 👌

19 hours ago, jaclaz said:

Qemu uses rather standard (emulated) video cards, so you should not *need* VBEMP. :dubbio:

If I don't use VBEMP, I cannot select > 16 color, 640x480, so that's a shame.  Perhaps I can find another way, or another driver indeed.

It's using:

$ qemu-system-i386 -version
QEMU emulator version 4.2.0

macOS 10.14.6 (18G3020), and Windows 98 Second Edition 4.10.2222A.  Launched with:

qemu-system-i386 \
    -drive file=win95_disk.img,format=raw \
    -cpu pentium \
    -m 256 \
    -boot c \
    -vga std \
    -nic none

 

Share this post


Link to post
Share on other sites

Good :).

You have several options to try:

https://www.qemu.org/docs/master/system/invocation.html#hxtool-3

The "standard" in the old versions was the "Cirrus" one:

Quote

cirrus

Cirrus Logic GD5446 Video card. All Windows versions starting from Windows 95 should recognize and use this graphic card. For optimal performances, use 16 bit color depth in the guest and the host OS. (This card was the default before QEMU 2.2)

I would try that first thing.

jaclaz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...