Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
Ironman69

YouTube WORKING! With Opera 12.02

Recommended Posts

It's straight forward Windows 2000, SP4 set up within KernelEx. I can attest, it installed and worked very straight forward. Not well, mind, but it works.

Opera98.png

Share this post


Link to post
Share on other sites

On Montag, 5. Februar 2018 at 3:18 PM, Nomen said:

I note that when Ironman69 shows the Opera version in the video, the OS is shown as Windows 98se.  I was under the impression that for Opera 12.02 to be installed on Win-98, you had to set a couple of registry keys to indicate the OS was (at least) Windows 2000 (indeed, that is what Opera shows on my win-98 system).   And I just checked, and no, my Opera 12.02 still can't play youtube videos, although I've messed with a lot of files and I'm probably running the 12.18 Opera.exe with 12.02 Opera.dll so I can't be sure if not being able to play youtube is my fault.   Has anyone else with win-98 and Opera 12.02 been able to duplicate Ironman69's claim?

Edit:  Or it could have been that installing some recent version of Flash, you needed to set the registry to indicate Windows 2000 or higher? But that would have been years ago.

Yesterday I tested to mix 12.18 and 12.02 files.

It's possible to use a 12.18 installation with files of 12.02:

1. 12.18 with "Opera.dll" and "html5_entity_init.dat" from 12.02. In this case you tube doesn't work.

2. 12.18 with "Opera.dll", "html5_entity_init.dat" and the gstreamer (folder) from 12.02. Youtube works.

Starting from 12.02. installation:
At least it certainly has advantages to substitute the styles folder of 12.02, so that 12.02 has the css files of 2016. For example, the website of filehippo can be accessed again.
 

Share this post


Link to post
Share on other sites
Posted (edited)
On 8.3.2018 at 11:21 AM, schwups said:

Yesterday I tested to mix 12.18 and 12.02 files.

It's possible to use a 12.18 installation with files of 12.02:

1. 12.18 with "Opera.dll" and "html5_entity_init.dat" from 12.02. In this case you tube doesn't work.

2. 12.18 with "Opera.dll", "html5_entity_init.dat" and the gstreamer (folder) from 12.02. Youtube works.

Starting from 12.02. installation:
At least it certainly has advantages to substitute the styles folder of 12.02, so that 12.02 has the css files of 2016. For example, the website of filehippo can be accessed again.
 

The Opera.dll was mainly the entire Opera browser back at the time Opera used the Presto-engine.

But if you say you could access a website that didnt work before it probably means atlest some of the other files contain some configuration and or changes that were malfunctioning on the older version of Opera. Someone suggested once replacing a few of the dll files with some of Opera Next when it came to a topic regarding issues with https websites.

I cant say if this still works or was just some workaround, since some pages just wouldnt open on Opera 12.02 and others would open sometimes . But I aswell have this issue at home on my smartphone with various browsers, and when I go online from a wifi access point they do open so it can also be caused by my router at home. 

But to make things short: I think its plausible what you reported regarding the filehippo website working again for you.

Edited by winxpi

Share this post


Link to post
Share on other sites

FileHippo works fine for me with Vanilla Opera 12.02. Nonetheless I tried using the 12.18 css files and it made no difference whatsoever, nothing I could notice anyway. The only difference I have noticed so far is in the look of Opera's internal error pages.

Share this post


Link to post
Share on other sites

In the last weeks I wasn't able to access filehippo and lately e.g. sourceforge anymore. Neither with 12.02 nor 11.64. And I tried different security protocol settings, also TLS 1.2, but without details settings.

Suddenly after substition and activation of TLS 1.2 the sites are accessible again. I don't know why it hasn't worked before. Maybe I had only some bad settings.
 

Share this post


Link to post
Share on other sites

Sourceforge stopped working for me too a little while back and this even with using Burp Suite as proxy which usually lets me use any https site on which Opera fails. Now it works OK again and I didn't change any settings. Happened with a few other sites which went back to OK again too. I guess something (bug/error) to do with upgrading servers to nginx 1.13.9.

Share this post


Link to post
Share on other sites

Something I noticed maybe a few weeks ago is that my work win-98 system can play youtube video's in opera 12.02.  It's sort of a back-burner project to see how it is different than my home win-98 setup...

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×