Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
Win98

Windows 2k install issues stuck on "Setup is starting windows 2000"

Recommended Posts

Well, the title is pretty self explanatory. I'm attempting to install Windows 2000 pro onto my Lenovo ideapad z565, but the problem is not specific to this laptop. The ISO that I'm currently using has SP4 and has been run through hfslip 2000. Setup loads all of the drivers fine, and when it gets to "Setup is starting Windows 2000" it just hangs. I've let it set for an hour and it's still sitting there. I'll let it sit overnight just for the heck of it.

The problem also persists on my Ideapad Y570, as well as on my Toshiba Satellite L505D (Which is much older than the ideapads). I don't have any desktops to try it on right now but I will be attempting it on a older (non sata) laptop here in a bit. 

I thought maybe it could be that the installer doesn't like that I'm attempting to install it on a computer with SATA drives, but it doesn't even get to the point to tell me that it doesn't detect any drives (which I would assume it would do if it couldn't find AHCI drivers). I have used nlite to slipstream the AHCI and raid drivers to the install files, but when I run setup it gives me the error that the AHCI driver is corrupt and the setup fails. I have also tried installing it via USB and CD, and the results are identical. USB just takes a lot less time to let me down. 

4 years or so ago I had 2k installed on a Gateway P-7805u laptop as well as on a HP pavillion (dv6000?) desktop and don't recall having any issue with the installation on those. I had the same problem I'm having now on the z565 and the Toshiba at the same time (4 years ago) but didn't pursue the issue because I got it on those other computers, neither of which are working anymore (One got struck by lighting and the other had major graphics card issues). I think I had attempted to use hfslip then and UURollup but I was like 15 and stupid and couldn't figure it out.

I have also set AHCI to compatibility in the bios on all 3 computers to no avail. Setup completes fine in VMWare. 

Any ideas?

Thanks!

Share this post


Link to post
Share on other sites

I don't like to double post, but I found a thread I forgot I had started in 2012 regarding this same issue. Tomas gave me a lot of good guidance in that thread and also possible fixes which I was too uneducated at the time to understand. I will be going over everything he said and trying the fixes again. Hopefully with better luck this time!

Edited by Win98

Share this post


Link to post
Share on other sites
3 hours ago, Win98 said:

I don't like to double post, but I found a thread I forgot I had started in 2012 regarding this same issue. Tomas gave me a lot of good guidance in that thread and also possible fixes which I was too uneducated at the time to understand. I will be going over everything he said and trying the fixes again. Hopefully with better luck this time!

Try to disable ACPI by pressing F5 or F7 during the installation setup ;)

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks for the suggestion! I didn't see any specific option to disable ACPI, but I did select "Standard PC" which got me past the "Starting windows 2k" screen and to a BSOD saying "Inaccessible_boot_device". I will mess around with some other drivers and see if I can get past that. This is definitely a step in the right direction! Thanks!

Share this post


Link to post
Share on other sites

Voila! I messed around slipstreaming various drivers into the installation media to no avail. I have been using a USB stick to install (or attempt to install) rather than discs because USB is a lot quicker and doesn't cost anything. I decided to go ahead and burn it to a CD and select a different option in the F5 menu (I selected "Standard PC") and this time I didn't get INACCESSIBLE_BOOT_DEVICE. I guess the device that was inaccessible was my USB stick. It's installing now. Hopefully it will finish!

Thanks Junior! 

Share this post


Link to post
Share on other sites

Installing W2k from a Usb stick is known to be non-standard at all. There is a special project here just for that.
Even to install W2ksp4 from a Cd drive on Usb rather than P-Ata or S-Ata, you can have worries. Some MS Usb patches exist just for that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...