Jump to content

Seagate Momentus (ST9750420AS) - Problem (Windows 7 don't boot)


Recommended Posts


Dell l502x XPS 15 (Early, 2011)

HD Seagate momentus (st9750420as) 750gb


What happened?

Yesterday I tried to update the HDD firmware(link ate the end of the post) so I downloaded the recommended version for my pc.

There were two options an .exe file (the one I used) and a usb option that creates a usb boot drive with the firmware.

So I followed all the steps, the pc reboot and got stuck in a black screen like this:

(with "seagate" text flashing...)



After 2 hours waiting I shutdown the pc and after that it no longer boots the windows,

it stucks in a black screen with a flashing underscore.


Here are some pictures of the bios.








First Thing I've tried, Instal the firmware via USB boot drive, its the usb folder in the firmware file (bottom of the post) dind't work.


Second try was to create a windows recovery usb, the result was this:

1º nothing been shown (os, drive size)



2º trying to acess C: from cmd returns something like this:

"The volume does not have a system of known files"

"be shure that all system fille drivers are loaded and the volume is not corrupted."



Ps: "E:" is my pendrive.


3º try, usb seatools




Firmware link:


Edited by icelord
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...