Jump to content

[Solved] Removing Components. Error 3 occured


Recommended Posts

First: Big thx for releasing the tool, and all the work you´ve done in the past... - i am a bit sur"PRICE"d, have hoped you was able to sell it cheaper for personal use... - but that doesnt belong to here... - so first Test, got that Message:


Error: Aborted at Removing Components. Error 3 occured


Used Image is: X15-65741 Home Premium 64 (german localized)


Edited by R4D3
Link to comment
Share on other sites

Hi R4D3, thanks for the report.

Please attach ntlite.log (found in temp folder set in File-Settings) right after that error happens and maybe a preset used but please remove any private info from unattended section (future version Export preset will do that automatically).
Also is that Windows unmodified previously by anything else?

Link to comment
Share on other sites

- Sorry wasn´t able to keep them cause i used a ramdisk as Temp folder... - but i think it was a problem of the folderrights from my temp folder (changed them to everyone) and do a clean install, and now i dont get this error anymore...


Other Things:


1) Sometime NTLite crashes... (even in a Fresh Installed VM)

2) Got my session onetime working (but i forget to clear the other images) - after redone (complete new image extraction) and install - i got 0x7B BSOD after install in VM

3) If you only select a WIM File thats not in the Image Folder - NTLite Crashes when it try to do Automation....

4) DepencedyWalker hat shown some errors (some of them, like ieshimps is missing can be fixed by change the environments path in windows by adding:

    %ProgramFiles%\Internet Explorer;%ProgramFiles(x86)%\Internet Explorer;%SystemRoot%\System32\drivers;


   Some possible errors ??? couldn´t be fixed, cause there is nothing like dism api in windows 7 (see the pic...) - but maybe its not a problem...



Edited by R4D3
Link to comment
Share on other sites

R4D3, great find about the temp folder, I'll try to replicate and fix.
WIM without image folder should not allow automation as it makes no sense, will fix.

Just not sure about what are you aiming at with the depwalker, you mean that could be the cause of the automation processing crash?

Link to comment
Share on other sites

- i use the depencedy walker since years, just to create some keep lists of files, when i use one of your tools... - it shows errors and missing dll´s... - its not really an error when a dll can´t call a special function, cause the depencedy dll isn´t there - but for me, i think its better when every function of a program can be called properly...


- a depencydy that often isn´t there (although at NTLite) is the ieshimps file in the internetexplorer folder

(this is a standard error, and can easy be fixed by adding both Internetexplorerfolder to the Environment Folders (that folders where files can be called from everywhere)


Its (maybe i am wrong cause i am no programer) an error ms have since years (even some gpu files need files in the drivers folder)...

just adding this 3 folders: %ProgramFiles%\Internet Explorer;%ProgramFiles(x86)%\Internet Explorer;%SystemRoot%\System32\drivers;

solve those errors - the good thing is, - if i am wrong at this point, the solution don´t break or slow anything... (maybe it just fixes depencedy walker...)


About that missing wim api file... - its a part of windows 8 and 8.1 and not of windows 7 - if your program don´t need this files and its depencedy´s in windows 7 and just use this kind of dism ? in windows 8 its not a problem... - i really don´t know - you have to ;) ( i have tried to add the files manually - but i wasn´t able to find the file and its 6 ? depencedy dlls as x64 Version


P.S. - when i click create iso - after ntlite is finish, the tool crash (after restart i can create iso)

Edited by R4D3
Link to comment
Share on other sites

R4D3, so last thing that confuses me is that you mention WIM API file, that is news to me. Win7 does have it by default, NTLite was tested under fresh Win7 SP1 without anything installed on it.

So let me summarize:

NTLite currently allows Unatteded/Automation even when you just select WIM image which doesn't have a normal DVD folder structure and it crashes
it is a known issue at this point (you mentioned it first but I got more reports), and will be fixed by creating the XML next to that image - it is a better solution than disabling the page.

But in your original report I did not read any WIM API issue that you now mention, so please repeat it for me like I hear it for the first time please.

Link to comment
Share on other sites

- sorry its probably my bad english...


so aggain:

1) I got some crashes (don´t mean that selection crash, - got crashes on other times two - maybe there are not enoughs "waits" ??? between the steps for a fast cpu ? :D

2) I Checked your program with depencedy walker, who gives that standard error of missing ieshimps.dll (which is easy fixable) and that following missing dll

3) google info: dismapi.dll is a win8/8.1 (Windows Assessment and Deployment Kit) file only (that dont mean that win 7 have no dism, but is has not this specific dll and their depencedys)

4) The reason for my crashed and bsod, don´t have to be a missing dll function, but it could be... (i can´t test what depencedy walker say´s under win 8.1 to NTLite.exe.....) (no space for more images ;)


5) One thing to know: depencedy walker, find things like this, on the most programs, - and they run anyway - don´t panic



After some research,

1) I´ve installed the Windows 8.1 ADK on Windows 7 (if error = you have to remove serebys, or other net 4.5 and take that from adk installer)


2) Update: See next Post

2) After Install the ADK i found the missing DLL and its depencedys, - but there wasnt able to be "called" global, so i add both path (64 and x86) to the path environment
    %ProgramFiles(x86)%\Windows Kits\8.1\Assessment and Deployment Kit\Deployment Tools\amd64\DISM;
    %ProgramFiles(x86)%\Windows Kits\8.1\Assessment and Deployment Kit\Deployment Tools\x86\DISM;


3) Like i did for ieshimps.dll
    %ProgramFiles%\Internet Explorer;
    %ProgramFiles(x86)%\Internet Explorer;

4) And for a call of my ati driver


Info: You need to restart, after change path variables

Now lets look what depencedy walker show now ;) - looks much better... - if i get less errors now i will check next days (not sure if i found time for it today...)






Edited by R4D3
Link to comment
Share on other sites

Ompffff..... - now this dismapi.dll is startet (ntlite try to use it, and than i get an error...)





Update: - ok, seems like NTlite uses the dismapi, and than get an error because, some same dism files that allready exits in windows got a lower version, and Progs always prefer to use the files form System32 and Syswow, if they are not in the directory from the Tool  - to get rid of that (the usage of different versions), - i copy the whole dism amd64 folder from adk into NTLite folder (x86 folder is for 32bit win) - seems like it run fine with dism 6.3.9600.17029 (will check more next days...)


Update 2



Now - NTLite works well (ADK dismapi.dll is used in a right way - see NTLite_dism_log...) - but my session is still corrupted (and i get a bsod after install) (did someone find the error in it ? probably a service...) (- was a service...)








NTLite_dism_log (dismapi is used well, but 1 warning about missing PEProvider.dll - maybe it will needed in full version, to edit the PE Image)


Edited by R4D3
Link to comment
Share on other sites

  • 3 weeks later...
  • 5 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...