Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Win 2k3 - Cant view events, services, device properties

Recommended Posts

Hi people. I need some help here please.

One of our servers, an HP ML310 G5 started rebooting on a loop for no reason after the Windows Server 2003 splash screen. It was the same when I tried booting in safe mode. It rebooted after it loaded acpitabl.dat. We then replaced the motherboard assuming it was the mobo fault as this had happened a few times before.

Now, even after the mobo was replaced, it was rebooting at the exact same place. I then booted the server from a Win 2k3 CD and ran 'chkdsk /r' on C drive from the Recovery Console. This found and fixed 1 error and sorted the boot loop issue and the server now boots back into the OS, to the desktop. This is when the bigger problem started.

1) Not all services are starting though they are set to automatic. Another weird part is 'Extended' part of services wont load. I have to select 'Standard'. I can see which services are started/not started etc, but when I double click on any service, it doesnt not bring up the dialog box where I can disable the service etc.

2) Similar issue when I enter eventvwr. I cant open any of the logs though I can see them. Tried Enter button, double click AND right-click > Properties and it still wont work.

3) Again a similar issue with Device Manager. I can see the devices, but I can see the properties. Nothing comes up again.

4) There are 2 NICs in the server and NIC 2 is disabled. But ncpa.cpl wont show up anything tough Device Manager shows up the NICs.

I honestly dont know where to start the troubleshooting from. Any help would be great.

Share this post

Link to post
Share on other sites

I've seen such a thing when some of the most important system DLLs have been damaged or unregistered.

The first step should be SFC /scannow.

Then maybe re-register some of the DLLs in system32 (this is unlikely to help, but who knows)... I remeber seeing a Microsoft KB article about this, but can't find it now. If you're desperate, maybe try something like this? (Only as a last step).


Share this post

Link to post
Share on other sites

There must be some "basic" issue with MMC.

You can try opening the event files with the nice Nirsoft tool:


see also these:

About re-registering dll's, the trick of re-registering each and every .dll has traditionally saved more than one installs :thumbup

If you can do a "parallel" install of Server 2003, you might be able to do something along the lines of this:


which made use of another nice Nirsoft tool, dllregview:


that would give you more control (as opposed to registering *everything*)


Share this post

Link to post
Share on other sites

Thanks for your help. There were bad blocks in the hard drive and chkdsk had deleted several files. I had to re-install the operating system unfortunately.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...