Jump to content

Two New eSATA Drives

Recommended Posts

I'm a partner in a small business. We have a dozen desktops

all running XP Pro_SP3. This morning I tested my new eSATA

drives on three of the desktops in our offices. Both drives

worked perfectly.

The problem I'm having is running these drives on a desktop

at home. If I try to copy a file that's more than a couple of

megabytes the drives literally vanish completely from Windows.

I've got XP Pro_SP3 at home too.

Here's the error message that appears in the system tray or

notification area:

Windows - Delayed Write Failure

Windows was unable to save all the data for the file . . . . . .

The data has been lost. This error may be caused by a

failure of your computer hardware or network connection.

Please try to save this file elsewhere.

My home desktop has a dual port eSATA controller card.

Naturally, I wanted to blame the card or its drivers. I removed

the card from Device Manager and pulled it from the mobo

expansion slot. I substituted a dual port pass-thru adapter

bracket. It plugs directly into two of the SATAII connectors

on the mobo.

I checked the BIOS setup. It looked good. During bootup

I was waiting to see each drive listed as JBOD or "just a bunch

of drives." They were.

As soon as XP finished loading, I tried copying a 100 MB file

to each of the drives. Nothing had changed. I was hoping

the solution would be to junk the controller card and buy

a replacement. No such luck.

It's obviously not a hardware problem, which leaves the system

itself. Are there any XP configuration changes or registy hacks

that might fix this problem? This desktop is less than a year

old. I'm ready to wack the darn thing with a sledge!

Link to comment
Share on other sites

A quick test might be to take it to a machine that you've verified it works in, and try both the pass-thru card and the add-in card to see if you get the same behavior. Assuming you've got basically the same installation of XP at work and at home, it's possible it could be a configuration issue but it's less likely. At least we know the HDDs themselves are fine, but I'd make sure both the cards you're using work in "known good" hardware first before saying they're not the problem. Unfortunately, you are still left with the possibility that the motherboard or chipset is at fault, but again without further digging it's hard to say.

Link to comment
Share on other sites

Thank you cluberti.

There are two internal drives in a RAID 0 configuration.

They're plugged into SATAII connectors 0 and 1. When

I installed the pass-thru bracket I plugged their cables

into 2 and 3. If the chipset or mobo is bad, why do the

two internal drives function normally? Is each SATAII

connector completely isolated from others? If so, I suppose

it's possible to have a localized failure in one part of

the mobo, while the rest of the board functions normally.

To me, this looks like a classic system freezeup. Remember

the endless crashes and system lockups with 95 and 98?

Before the error message appears, the animated icons

showing your files being copied from one folder to another

freezes solid. Doesn't this seem like a typical Windows

behavior when there is a system conflict?

In the Device Manager I tried disabling write caching for

each drive. You select the policies tab and remove the

tick on the property sheet. Didn't work, of course.

I was thinking, is there any software that can manage these

basic functions like copying, moving, etc., better than Windows?

If so, point my browser to their website.

Link to comment
Share on other sites

HoppaLong it sounds to me like you have eSATA drives that may be under powered or are not fully compatible with SATAII.

If they are under powered that would explain why when you goto copy a large file to the drive it dissapears.

Also that error message you are getting is because the drives are disconnecting during a write operation, you would get the same error if you un-plugged the drives while copying files to them.

Do you know if the desktops at your business have SATAII ports?

Also are the eSATA drives preassembled or did you buy an enclosure then add a hard drive?

Did you try using a different set of cables? If your cables can't handle SATAII and they were connected to SATAI ports at your business, that would explain why they work there and not on your home desktop.

Finally if you did buy and enclosure and added a drive to it, then check the "limit to 1.5gb" jumper and try enabling or disabling this feature.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...