Jump to content

Fix Missing Compatibility Tab in Vista


beast64
 Share

Recommended Posts

I been looking for a way to fix this problem for quite some time now, and the thread I found in this forum is dead, so I thought I'd share what I found.

All these problems occur when 2 system files "wer.dll" and "Faultrep.dll" are missing from "%windir%\System32" folder. Either they have been deleted by mistake or were not installed by Windows because of removing some Windows components from the setup.

I made an SFX that will automatically extract the files where they belong, and hopefuly fix it for you as it did for me, you can get from here:

http://www.mediafire.com/?mz1zwfyyocz

Or you can do it yourself, and in that case here are the missing DLLs:

http://www.mediafire.com/?vugs2rldldr

Either way, choose ONLY ONE, you don't need both.

I hope that helps, enjoy.

~Beast

Edited by beast64
Link to comment
Share on other sites

  • 3 weeks later...

NOT WORKING FOR ME.... I JUST REPLACED WER.DLL AND FAULTREP.DLL IN SYSTEM 32 AND I DONT HAVE COMPATIBILITY TAB :(

DONT WANT TO REINSTALL A CLEAN COPY OF VISTA

I HAVE ASUS G50VT X5 VISTA X64 ULTIMATE

AND DOESNT WORK THIS SOLUTION...

SORRY ABOUT MY ENGLISH I ONLY SPEAK SPANISH...

I JUST TRIED THE REGISTRY THING...

THE POLICY GROUP THING...

SFC /SCANNOW...

AND NOTHING...

I WANT COMPATIBILITY THING....

ANOTHER THING IVE NOTED IS IN SERVICES.MSC IS WERSVC started WITH AN ERROR BUT IS STARTED...ERROR 15100

I HAVE TO STOP THIS???

AND THEN COPY THIS FILES???

I JUST DO IT THAT WAY...WITH NO RESULTS....

HELP

PLEASE HELP

Link to comment
Share on other sites

Turn your caps lock off. It's rude.

sorry about that....

but this thing drive me crazy

update: I just copy the original files from a friends notebok with vista x64

with no result...

i just tried regsvr.exe c:\windows\system32\wer.dll an error DllRegisterServer

i dont know what to do :"(

another thing is that service "wersvc" has an error 15100

the service is in started mode

i have vista x64 ultimate (vlite) <<<---problem

i have read a lot of forums whit not result

ASUS G50VTX-5

please help me !!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.


×
×
  • Create New...