Jump to content

Manifest or Policy file error (The SXS.DLL error)


Recommended Posts

John, thanks for taking time to answer my questions. Maybe I am too slow today, but it just gets more confusing to me.

First, if bad things happen if Nlite is used to modify working directory, and no two SP should be installed in one run, it means no one with SP1 source will be able to upgrade to sp3, right?

Second, NLite FAQ says: "Download the WMP11 installer from Microsoft, install the WMP11 Slipstreamer then simply run nLite and insert the WMP11 installer into the Hotfixes page." This is complete gibberish to me. If I simply insert WMP installer into hotfixes page then what did I install Slipstreamer for? It doesn't say "run it". However if I do run the Slipstreamer, then why should I insert installer into hotfixes? Wouldn't wmp be already slipstreamed into working directory? Weird...

I checked version history and the only thing I see is "fix: Wmp11 x64 hotfixes direct integration" in v1.4.8. This says "hotfixes integration", not wmp itself, doesn't it? Of course I would be ecstatic I NLight could slipstream everything by itself, but I just dont see any reference to it anywhere. Everybody uses WMP11 Slipstreamer or WMP11 Integrator applications for that.

Link to comment
Share on other sites

wwwoholic, I don't think you are slow, at all. Perhaps you are thinking too much and getting yourself wrapped around the axle. When I say integrate only one SP, that means just the latest one you want to use. Today, for most that would be SP3 on XP. It does not matter what your starting point is - no SP, SP1, or SP2 - slipstream only one. MS says to install SP1, SP2 then SP3, but that is for a RUNNING system, not integration into an install. As I stated before, when nLite discovers the WMP11 file in Hot Fixes, IT calls WMP11 Slipstreamer. When it was first implemented, the user was asked to install it. I have since noticed that WMP11Slipstreamer.exe is in the nLite folder in the Program Files folder. Take a look and see if it is in yours. I have not tried it, but I assume I could remove WMP11 Slipstreamer from my system and it would still work because nLite would use the one in its folder. I simply place WMP11 and its updates (in that order) in my Hot Fix section and shortly after I start the process, I see a WMP11 Slipstreamer window open and can watch it run. I would urge you to give things a try. It is very cheap to try these things and does no harm. I think 'just trying' is a great to learn. Enjoy, John.

Link to comment
Share on other sites

Perhaps you are thinking too much
LOL, John, you are right. I should have just went ahead and tried it first. Unfortunately I don't have VM installed, so each attempt for me means burning CD. Anyway, I'll give it a try tonight.

Also, I wanted to mention this regarding OP - just go ahead and google "SXS.DLL Syntax error". You will get thousands of hits and not a single plausible solution. Apparently this thing plagues XP installations, including x64 versions and pristine hologram CDs from MS. It's amazing how diverse the solutions are for different people. Some just try second time, some clean CDs with alcohol, some move memory sticks around... My opinion - XP is haunted and some holy water on HD will help :)

In any case, my point is: this error probably has nothing to do with NLite.

Link to comment
Share on other sites

wwwoholic, great, please let us know how things go. I do think marfig's problem was to do with integrating an SP on top of an already integrated one. It is funny I have not heard of this error before. I also think a virtual system is well worth the effort! Enjoy, John.

Link to comment
Share on other sites

  • 2 months later...

Hi all who was involved with this post.

I am reselling various main stream used computers. These computers are off lease units and come with the COA and the HD is a blank canvass waiting for me to re-install the OS.

Today I wanted to make a new OEM DELL Optimplex xp home disk. I took an original MS OEM xp SP1 home edition CD and copied all files to a local folder. I then stripped out the unecessary folders and added the following: winnt.inf and svcpack.inf together with a folder SVCPACK in which I placed a number of further KB123456.exe updates.

So far so good.

I added $OEM$ and inside added folders for the drivers specific to the Dell.

I then used "Autostreamer" to (1) slipstream sp3 and (2) create my ISO.

I used Roxio 8 to create the new CD from the ISO.

I then proceeded to install xphome on my victim machine; the Dell Optiplex GX260.

A little way into the installation, I got the dreaded message that there was a problem with the SXS.DLL; Syntax error in manifest or policy file.

After some digging on the net I read various opinions but no real answer.

I looked at my install and couldn't see anything wrong with the files or the method. I had previously burned an XP pro disk in the same way, which worked great.

I did however notice that the volume name on the CD was slightly different to that of the original MS OEM disk. The original was XRMHOEM_EN and I had XROEM_EN.

I decided to make a new cd from scratch going through the exact steps above, however I made sure the volume name was the same.

The new CD installed the OS without a glitch.

My experience may have been a one off but I thought I would share it with someone. :)

Link to comment
Share on other sites

  • 11 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...