Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Recommended Posts

hi thanks for a great forum,

ive searched every where trying to make my unattended vista

read hundres of posts

it works but not quite right.

I have a vista sp1 with added updates using vlite alsoe made simple auto unattended xml in vlite

I followed FireGeier great guide but adding apps or reg tweaks

the

 <?xml version="1.0" encoding="utf-8" ?> 
- <unattend xmlns="urn:schemas-microsoft-com:unattend">
- <settings pass="windowsPE">
- <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <SetupUILanguage>
<UILanguage>en-us</UILanguage>
</SetupUILanguage>
<InputLocale>0x00000809</InputLocale>
<SystemLocale>en-us</SystemLocale>
<UILanguage>en-us</UILanguage>
<UserLocale>en-us</UserLocale>
</component>
- <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <UserData>
- <ProductKey>
<Key>*******************</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
</UserData>
- <Display>
<ColorDepth>32</ColorDepth>
<HorizontalResolution>1024</HorizontalResolution>
<VerticalResolution>768</VerticalResolution>
</Display>
- <ImageInstall>
- <OSImage>
<InstallToAvailablePartition>false</InstallToAvailablePartition>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
</component>
</settings>
- <settings pass="specialize">
- <component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SkipAutoActivation>true</SkipAutoActivation>
</component>
- <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <RunSynchronous>
- <RunSynchronousCommand wcm:action="add">
<Description>Detection CDROM</Description>
<Order>1</Order>
<Path>cmd /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\AppsRoot.txt SETX AppsRoot %i:\ -m"</Path>
</RunSynchronousCommand>
</RunSynchronous>
</component>
</settings>
- <settings pass="oobeSystem">
- <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <AutoLogon>
<Enabled>true</Enabled>
<LogonCount>2</LogonCount>
<Username>Administrator</Username>
</AutoLogon>
- <Display>
<ColorDepth>32</ColorDepth>
<HorizontalResolution>1024</HorizontalResolution>
<VerticalResolution>768</VerticalResolution>
</Display>
- <OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Home</NetworkLocation>
<ProtectYourPC>1</ProtectYourPC>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
- <FirstLogonCommands>
- <SynchronousCommand wcm:action="add">
<CommandLine>%AppsRoot%install\run.cmd</CommandLine>
<Description>install programs</Description>
<Order>1</Order>
</SynchronousCommand>
</FirstLogonCommands>
<RegisteredOrganization>Owner</RegisteredOrganization>
<RegisteredOwner>Owner</RegisteredOwner>
</component>
- <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<InputLocale>0x00000809</InputLocale>
<SystemLocale>en-us</SystemLocale>
<UILanguage>en-us</UILanguage>
<UserLocale>en-s</UserLocale>
</component>
</settings>
<cpi:offlineImage cpi:source="wim://useruse-h70gcu9/dvistawork/dvd/sources/install.wim#Windows Vista ULTIMATE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

Run cmd

Echo.....Installing things to make your computer better
start /wait regedit /s \\%AppsRoot%install\REGTWEAKS.REG
Echo..........Install Winrar
start /wait %AppsRoot%install\Winrar\WINRAR.EXE /s
Echo..........Install Foxit Pdf Reader
start /wait %AppsRoot%install\Foxit\FOXITREADER30_ENU.MSI /quiet
Echo..........Install Image Burn
start /wait %AppsRoot%install\Imgburn\SetupImgBurn_2.4.2.0.exe /S
Echo..........Install Image Burn Desktop Shortcut
start /wait %AppsRoot%install\Imgburn\ImgBurn.exe
Echo..........Install Internet Firefox Browser
start /wait %AppsRoot%install\Firefox\Firefox3.0.exe -ms -ira
Echo..........InstallFlash Plugin For Firefox
start /wait %AppsRoot%install\Flashplugin\install_flash_player.exe /s
Echo..........Install Avg Virus Software
start /wait %AppsRoot%install\Avg\avg.exe /hide /no_welcome /REMOVE_FEATURE fea_AVG_SafeSurf /REMOVE_FEATURE fea_AVG_SafeSearch /NOAVGTOOLBAR
Echo..........InstallOffice 2007
start /wait %AppsRoot%install\office2007\setup.exe /config custom-uA.XML
Echo..........Install Codec Pack
start /wait %AppsRoot%install\Codec\Codec.exe
Echo..........Install Quicktime Alternative
start /wait %AppsRoot%install\quicktime\quicktimealt195lite.exe /VERYSILENT
Echo..........Finished just needs to load windows then reboot
shutdown -r -c "Rebooting To Finish Setup."

thanks for looking

Share this post


Link to post
Share on other sites

Just a quick Q for you..does your reg tweaks work as expected by simply merging the file live in windows? If not what tweaks work/don't work for you?

Share this post


Link to post
Share on other sites

thanks for the reply

yes they work in windows

the ones that dont work are


; Automatic Updates download but let user install

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]
"AUOptions"=dword:00000003
"IncludeRecommendedUpdates"=dword:00000000
"BalloonTime"="2009-01-07 18:35:04"
"BalloonType"=dword:00000002

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\UAS]
"UpdateCount"=dword:00000000

; Add "Device Manager" to the right click menu of "Computer"
;
;[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Devices]
;@=hex(2):44,00,65,00,76,00,69,00,63,00,65,00,20,00,4d,00,61,00,6e,00,61,00,67,\
;00,65,00,72,00,00,00
;"SuppressionPolicy"=dword:4000003c
;
;[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Devices\command]
;@=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,73,00,79,00,73,\
;00,74,00,65,00,6d,00,33,00,32,00,5c,00,6d,00,6d,00,63,00,2e,00,65,00,78,00,\
;65,00,20,00,2f,00,73,00,20,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\
;00,6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,\
;32,00,5c,00,64,00,65,00,76,00,6d,00,67,00,6d,00,74,00,2e,00,6d,00,73,00,63,\
;00,20,00,2f,00,73,00,00,00

; Remove warning about showing hidden system folders

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden]
"WarningIfNotDefault"=-

; Remove new BMP file

[-HKEY_CLASSES_ROOT\.bmp\ShellNew]

;Put my computer, User Folder on the desktop

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
"{20D04FE0-3AEA-1069-A2D8-08002B30309D}"=dword:00000000
"{59031a47-3f72-44a7-89c5-5595fe6b30ee}"=dword:00000000

;Deactivate security center notifications
[-HKEY_CLASSES_ROOT\CLSID\{FD6905CE-952F-41F1-9A6F-135D9C6622CC}]

here is the full regtweaks


Windows Registry Editor Version 5.00

;Disable the User Account Control (UAC)
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"EnableLUA"=dword:00000000

;Disable Windows Welcome Center - StartUp
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
"WindowsWelcomeCenter"=-

;Open with notepad
[HKEY_CLASSES_ROOT\*\shell\Open with Notepad]
@=""
[HKEY_CLASSES_ROOT\*\shell\Open with Notepad\command]
@="notepad.exe %1"


;Deactivate security center notifications
[-HKEY_CLASSES_ROOT\CLSID\{FD6905CE-952F-41F1-9A6F-135D9C6622CC}]


;Change the Default Action of the Start Menu Power Button to Shutdown (0 = Sleep, 1 = Hibernate, 2 = Shutdown)
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Power\PowerSettings\A7066653-8D6C-40A8-910E-A1F54B84C7E5]
"ACSettingIndex"=dword:00000002
"DCSettingIndex"=dword:00000002


; this is the changed value to get rid of word 'Shortcut'
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
"link"=hex:00,00,00,00

;Remove the 'Shortcut to...' (00 00 00 00 = No Shortcut Text)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
"link"=hex:00,00,00,00

;Put my computer, User Folder on the desktop

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
"{20D04FE0-3AEA-1069-A2D8-08002B30309D}"=dword:00000000
"{59031a47-3f72-44a7-89c5-5595fe6b30ee}"=dword:00000000

;Don't Group Similar Taskbar Buttons, use personalized menu (disable), lock task bar
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"TaskbarGlomming"=dword:00000000
"IntelliMenus"=dword:00000000
"TaskbarSizeMove"=dword:00000000

; add command prompt to right click context menu
[HKEY_CLASSES_ROOT\Folder\shell\Open Command Prompt Here]

[HKEY_CLASSES_ROOT\Folder\shell\Open Command Prompt Here\command]
@="cmd.exe /k pushd %L"


; Windows will tell you exactly what it is doing when it is shutting down or is booting

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system]
"verbosestatus"=dword:00000001

; IE7 - Set Google.com as homepage

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Start Page"="http://www.google.com/"


;ControlPanel Classic
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel]

thanks

Share this post


Link to post
Share on other sites

all the reg tweaks works for me..that u said doesnt work......

i integrate it during audit user mode......

but m facing a different prob which i m tryin 2 solve.....

thanx

angel

Share this post


Link to post
Share on other sites
thanks for the reply

yes they work in windows

the ones that dont work are


; Automatic Updates download but let user install

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update]
"AUOptions"=dword:00000003
"IncludeRecommendedUpdates"=dword:00000000
"BalloonTime"="2009-01-07 18:35:04"
"BalloonType"=dword:00000002

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\UAS]
"UpdateCount"=dword:00000000

; Add "Device Manager" to the right click menu of "Computer"
;
;[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Devices]
;@=hex(2):44,00,65,00,76,00,69,00,63,00,65,00,20,00,4d,00,61,00,6e,00,61,00,67,\
;00,65,00,72,00,00,00
;"SuppressionPolicy"=dword:4000003c
;
;[HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Devices\command]
;@=hex(2):25,00,77,00,69,00,6e,00,64,00,69,00,72,00,25,00,5c,00,73,00,79,00,73,\
;00,74,00,65,00,6d,00,33,00,32,00,5c,00,6d,00,6d,00,63,00,2e,00,65,00,78,00,\
;65,00,20,00,2f,00,73,00,20,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\
;00,6f,00,6f,00,74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,\
;32,00,5c,00,64,00,65,00,76,00,6d,00,67,00,6d,00,74,00,2e,00,6d,00,73,00,63,\
;00,20,00,2f,00,73,00,00,00

; Remove warning about showing hidden system folders

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\SuperHidden]
"WarningIfNotDefault"=-

; Remove new BMP file

[-HKEY_CLASSES_ROOT\.bmp\ShellNew]

;Put my computer, User Folder on the desktop

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
"{20D04FE0-3AEA-1069-A2D8-08002B30309D}"=dword:00000000
"{59031a47-3f72-44a7-89c5-5595fe6b30ee}"=dword:00000000

;Deactivate security center notifications
[-HKEY_CLASSES_ROOT\CLSID\{FD6905CE-952F-41F1-9A6F-135D9C6622CC}]

here is the full regtweaks


Windows Registry Editor Version 5.00

;Disable the User Account Control (UAC)
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
"EnableLUA"=dword:00000000

;Disable Windows Welcome Center - StartUp
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
"WindowsWelcomeCenter"=-

;Open with notepad
[HKEY_CLASSES_ROOT\*\shell\Open with Notepad]
@=""
[HKEY_CLASSES_ROOT\*\shell\Open with Notepad\command]
@="notepad.exe %1"


;Deactivate security center notifications
[-HKEY_CLASSES_ROOT\CLSID\{FD6905CE-952F-41F1-9A6F-135D9C6622CC}]


;Change the Default Action of the Start Menu Power Button to Shutdown (0 = Sleep, 1 = Hibernate, 2 = Shutdown)
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Power\PowerSettings\A7066653-8D6C-40A8-910E-A1F54B84C7E5]
"ACSettingIndex"=dword:00000002
"DCSettingIndex"=dword:00000002


; this is the changed value to get rid of word 'Shortcut'
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
"link"=hex:00,00,00,00

;Remove the 'Shortcut to...' (00 00 00 00 = No Shortcut Text)
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
"link"=hex:00,00,00,00

;Put my computer, User Folder on the desktop

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
"{20D04FE0-3AEA-1069-A2D8-08002B30309D}"=dword:00000000
"{59031a47-3f72-44a7-89c5-5595fe6b30ee}"=dword:00000000

;Don't Group Similar Taskbar Buttons, use personalized menu (disable), lock task bar
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"TaskbarGlomming"=dword:00000000
"IntelliMenus"=dword:00000000
"TaskbarSizeMove"=dword:00000000

; add command prompt to right click context menu
[HKEY_CLASSES_ROOT\Folder\shell\Open Command Prompt Here]

[HKEY_CLASSES_ROOT\Folder\shell\Open Command Prompt Here\command]
@="cmd.exe /k pushd %L"


; Windows will tell you exactly what it is doing when it is shutting down or is booting

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system]
"verbosestatus"=dword:00000001

; IE7 - Set Google.com as homepage

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"Start Page"="http://www.google.com/"


;ControlPanel Classic
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ControlPanel]

thanks

I use most of those tweaks also & work UA no problem. Maybe instead installing through your seperate batch file "Run.cmd" maybe install it directly by the "FirstLogonCommands"

eg:

<FirstLogonCommands>

<SynchronousCommand wcm:action="add">

<CommandLine>%AppsRoot%Install\reg.exe</CommandLine>

<Description>Apply Registry Settings</Description>

<Order>60</Order>

I just sfx my reg file to silently install & no problems.

Edited by MAVERICKS CHOICE

Share this post


Link to post
Share on other sites

hi thanks for you replys

The Day Walker!

i tryed that but it kept shuting down i think its somthing to do with sysprep ?

could you post your xml not including any sensative suff key etc

what problem are you having

Thanks

MAVERICKS CHOICE

ill try FirstLogonCommands

and let you know how it goes thanks

cheers bob

works like a dream cheers added

- <FirstLogonCommands>
- <SynchronousCommand wcm:action="add">
<CommandLine>%AppsRoot%install\run.cmd</CommandLine>
<Description>install programs</Description>
<Order>10</Order>
</SynchronousCommand>
- <SynchronousCommand wcm:action="add">
<Order>1</Order>
<CommandLine>cmd /c REGEDIT /S %AppsRoot%\Install\Regtweaks.reg</CommandLine>

Edited by bobthenob

Share this post


Link to post
Share on other sites

bro....

my prob is things get installed perfectly in audit user mode,,,but then when the system gets restarted,,,

2 login into the oobe system ,,,,,, as soon as the system login, it gets restarted,,, hence.....

no settings is retained by the admin........

only the local machine setting remains,,,,,,,rest the curent user settings gets deleted......

and also, .msi file doesnt gets installed in the audit user mode..or may b it gets installed but gets deleted or something cause i can c the rest of the softwares gets installed,,,,as it is,,but couldnt find the msi soft installed....

---------------------------------

cause of the above probs,,,, after i saw ur post.......

i changed my xml and created a firstlogon.bat bile so that those things get installed during first logon....

but the prob now is,,,,,

my softs that i have not deleted in audit user mode gets installed......

and rest of my stuff...(the msi, rteg tweaks, and cleanup.bat) that i included in bat file.....

doesnt get installed ........

same prob as previous,,,,,,

as soon as i login into oobe system phase.....

the system gets restarted,,and cause of that, after re login,,,,, the first login.bat doesnt run....

so help needed regarding that....

my xml file...

<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<servicing>

<package action="configure">

<assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="6.0.6000.16386" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="" />

<selection name="TabletPCOC" state="false" />

<selection name="Windows-Ultimate-Extras" state="false" />

<selection name="SimpleTCP" state="true" />

<selection name="SpiderSolitaire" state="false" />

<selection name="AxInstallService" state="false" />

<selection name="FaxServicesUltimate" state="false" />

</package>

</servicing>

<settings pass="windowsPE">

<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<SetupUILanguage>

<UILanguage>en-US</UILanguage>

</SetupUILanguage>

<InputLocale>0409:00000409</InputLocale>

<SystemLocale>en-US</SystemLocale>

<UILanguage>en-US</UILanguage>

<UserLocale>en-US</UserLocale>

</component>

<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<Display>

<ColorDepth>32</ColorDepth>

<HorizontalResolution>1024</HorizontalResolution>

<VerticalResolution>768</VerticalResolution>

</Display>

<UserData>

<ProductKey>

<WillShowUI>OnError</WillShowUI>

<Key></Key>

</ProductKey>

<AcceptEula>true</AcceptEula>

<FullName>The Day Walker!</FullName>

<Organization>Angel Corporation</Organization>

</UserData>

<ImageInstall>

<OSImage>

<InstallFrom>

<MetaData wcm:action="add">

<Key>/IMAGE/NAME</Key>

<Value>Windows Vista ULTIMATE</Value>

</MetaData>

</InstallFrom>

<InstallToAvailablePartition>false</InstallToAvailablePartition>

</OSImage>

</ImageInstall>

<UseConfigurationSet>true</UseConfigurationSet>

</component>

</settings>

<settings pass="specialize">

<component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<SkipAutoActivation>true</SkipAutoActivation>

</component>

<component name="Microsoft-Windows-ErrorReportingCore" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<DisableWER>1</DisableWER>

</component>

<component name="Microsoft-Windows-SystemRestore-Main" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<DisableSR>1</DisableSR>

</component>

<component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<BlockPopups>yes</BlockPopups>

<ShowInformationBar>true</ShowInformationBar>

<Home_Page>about:blank</Home_Page>

<PlaySound>true</PlaySound>

</component>

<component name="Microsoft-Windows-RemoteAssistance-Exe" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<fAllowToGetHelp>false</fAllowToGetHelp>

<fAllowFullControl>false</fAllowFullControl>

</component>

<component name="Microsoft-Windows-SQMApi" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<CEIPEnabled>0</CEIPEnabled>

</component>

<component name="Microsoft-Windows-TerminalServices-LocalSessionManager" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<fDenyTSConnections>true</fDenyTSConnections>

</component>

<component name="Security-Malware-Windows-Defender" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<DisableAntiSpyware>true</DisableAntiSpyware>

</component>

<component name="Networking-MPSSVC-Svc" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<PublicProfile_EnableFirewall>false</PublicProfile_EnableFirewall>

<PrivateProfile_EnableFirewall>false</PrivateProfile_EnableFirewall>

<DomainProfile_EnableFirewall>false</DomainProfile_EnableFirewall>

<DomainProfile_DisableNotifications>true</DomainProfile_DisableNotifications>

<PrivateProfile_DisableNotifications>true</PrivateProfile_DisableNotifications>

<PublicProfile_DisableNotifications>true</PublicProfile_DisableNotifications>

</component>

<component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<RunSynchronous>

<RunSynchronousCommand wcm:action="add">

<Order>1</Order>

<Path>cmd /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\AppsRoot.txt SETX AppsRoot %i: -m"</Path>

</RunSynchronousCommand>

<RunSynchronousCommand wcm:action="add">

<Order>2</Order>

<Path>%WINDIR%\system32\sysprep\sysprep.exe /quiet /audit</Path>

</RunSynchronousCommand>

</RunSynchronous>

</component>

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<ComputerName>Matrix</ComputerName>

<CopyProfile>true</CopyProfile>

</component>

</settings>

<settings pass="oobeSystem">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<AutoLogon>

<Enabled>true</Enabled>

<LogonCount>1</LogonCount>

<Username>Administrator</Username>

</AutoLogon>

<OOBE>

<SkipUserOOBE>true</SkipUserOOBE>

<SkipMachineOOBE>true</SkipMachineOOBE>

<ProtectYourPC>3</ProtectYourPC>

<NetworkLocation>Other</NetworkLocation>

<HideEULAPage>true</HideEULAPage>

</OOBE>

<Display>

<ColorDepth>32</ColorDepth>

<HorizontalResolution>1024</HorizontalResolution>

<VerticalResolution>768</VerticalResolution>

<DPI>96</DPI>

</Display>

<RegisteredOwner>The Day Walker!</RegisteredOwner>

<ShowWindowsLive>false</ShowWindowsLive>

<TimeZone>India Standard Time</TimeZone>

<VisualEffects>

<FontSmoothing>ClearType</FontSmoothing>

</VisualEffects>

<WindowsFeatures>

<ShowWindowsMail>true</ShowWindowsMail>

<ShowMediaCenter>false</ShowMediaCenter>

<ShowInternetExplorer>true</ShowInternetExplorer>

<ShowWindowsMediaPlayer>true</ShowWindowsMediaPlayer>

</WindowsFeatures>

<RegisteredOrganization>Angel Corporation</RegisteredOrganization>

<OEMInformation>

<Manufacturer>Intel</Manufacturer>

<Model>Customized By The Day Walker!</Model>

<Logo>C:\Windows\system32\oobe\INTEL_BADGE.BMP</Logo>

</OEMInformation>

<FirstLogonCommands>

<SynchronousCommand wcm:action="add">

<CommandLine>%SystemDrive%\Tempo\FirstLogon.bat</CommandLine>

<Description>Final Installation...</Description>

<Order>1</Order>

</SynchronousCommand>

</FirstLogonCommands>

</component>

<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<InputLocale>0409:00000409</InputLocale>

<SystemLocale>en-US</SystemLocale>

<UILanguage>en-US</UILanguage>

<UserLocale>en-US</UserLocale>

</component>

<component name="Microsoft-Windows-Sidebar" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<SidebarOnByDefault>true</SidebarOnByDefault>

<SidebarVisible>true</SidebarVisible>

<Gadget1>%PROGRAMFILES%\windows sidebar\gadgets\Clock.Gadget,true</Gadget1>

<Gadget3>%PROGRAMFILES%\windows sidebar\gadgets\Calendar.Gadget,true</Gadget3>

<Gadget2>%PROGRAMFILES%\windows sidebar\gadgets\AllCPUMeter.Gadget,true</Gadget2>

<Gadget4>%PROGRAMFILES%\windows sidebar\gadgets\Notes.Gadget,true</Gadget4>

</component>

<component name="Microsoft-Windows-ehome-reg-inf" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<WorkOffline>false</WorkOffline>

<PreventAutoConnect>true</PreventAutoConnect>

</component>

</settings>

<settings pass="generalize">

<component name="Microsoft-Windows-SharedAccess" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<EnableICS>false</EnableICS>

</component>

</settings>

<settings pass="auditSystem">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<AutoLogon>

<Enabled>true</Enabled>

<LogonCount>1</LogonCount>

<Username>Administrator</Username>

</AutoLogon>

<TimeZone>India Standard Time</TimeZone>

<ShowWindowsLive>false</ShowWindowsLive>

</component>

</settings>

<settings pass="auditUser">

<component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<RunSynchronous>

<RunSynchronousCommand wcm:action="add">

<Description>.NET Framework 1.1 - 3.5 SP1</Description>

<Order>5</Order>

<Path>cmd /c %AppsRoot%\Install\DNF_all.exe</Path>

</RunSynchronousCommand>

<RunSynchronousCommand wcm:action="add">

<Description>Sun Java Runtime 6</Description>

<Order>10</Order>

<Path>cmd /c %AppsRoot%\Install\jre6u11.exe /qn /norestart</Path>

</RunSynchronousCommand>

<RunSynchronousCommand wcm:action="add">

<Description>Adobe Reader 9</Description>

<Order>15</Order>

<Path>cmd /c %AppsRoot%\Install\AR9_Lite.exe /qn</Path>

</RunSynchronousCommand>

<RunSynchronousCommand wcm:action="add">

<Description>Flash Player</Description>

<Order>25</Order>

<Path>cmd /c %AppsRoot%\Install\F1001236.exe /s</Path>

</RunSynchronousCommand>

<RunSynchronousCommand wcm:action="add">

<Description>Hashtab Shell Extension v2.1.1</Description>

<Order>30</Order>

<Path>cmd /c %AppsRoot%\Install\HashTab2.1.1.exe /S</Path>

</RunSynchronousCommand>

<RunSynchronousCommand wcm:action="add">

<Description>Silverlight 2.0</Description>

<Order>35</Order>

<Path>cmd /c %AppsRoot%\Install\Silverlight2.0.exe /q</Path>

</RunSynchronousCommand>

<RunSynchronousCommand wcm:action="add">

<Description>Restarting...</Description>

<Order>55</Order>

<Path>%WINDIR%\system32\sysprep\sysprep.exe /quiet /oobe /reboot</Path>

</RunSynchronousCommand>

</RunSynchronous>

</component>

</settings>

<cpi:offlineImage cpi:source="wim:d:/downloads/temp/vista/vista%20answer/install.wim#Windows Vista ULTIMATE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

</unattend>

my FirstLogon.bat file

cmdow @ /HID

@Echo Off

start /wait %AppsRoot%\Install\SWFull.msi /qn /norestart

start /wait regedit /s %AppsRoot%\Install\Tweaks.reg

start /wait regedit /s %AppsRoot%\Install\IESet.reg

start /wait %AppsRoot%\Install\Clean.bat

shutdown -r -c "Final Rebooting..."

EXIT

wots the prob,,help needed

thanx

angel

Share this post


Link to post
Share on other sites

hi Angel

my softs that i have not deleted in audit user mode gets installed......

and rest of my stuff...(the msi, rteg tweaks, and cleanup.bat) that i included in bat file.....

doesnt get installed ........

cant you load xml in windows system image manger and delete the software in audit mode

the problem i had was the sysprep line shut my computer down


<?xml version="1.0" encoding="utf-8" ?>
- <unattend xmlns="urn:schemas-microsoft-com:unattend">
- <settings pass="windowsPE">
- <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <SetupUILanguage>
<UILanguage>en-us</UILanguage>
</SetupUILanguage>
<InputLocale>0x00000809</InputLocale>
<SystemLocale>en-us</SystemLocale>
<UILanguage>en-us</UILanguage>
<UserLocale>en-us</UserLocale>
</component>
- <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <UserData>
- <ProductKey>
<Key>###################</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
</UserData>
- <Display>
<ColorDepth>32</ColorDepth>
<HorizontalResolution>1024</HorizontalResolution>
<VerticalResolution>768</VerticalResolution>
</Display>
- <ImageInstall>
- <OSImage>
<InstallToAvailablePartition>false</InstallToAvailablePartition>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
</component>
</settings>
- <settings pass="specialize">
- <component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SkipAutoActivation>true</SkipAutoActivation>
</component>
- <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <RunSynchronous>
- <RunSynchronousCommand wcm:action="add">
<Description>Detection CDROM</Description>
<Order>1</Order>
<Path>cmd /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\AppsRoot.txt SETX AppsRoot %i:\ -m"</Path>
</RunSynchronousCommand>
</RunSynchronous>
</component>
</settings>
- <settings pass="oobeSystem">
- <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <AutoLogon>
<Enabled>true</Enabled>
<LogonCount>2</LogonCount>
<Username>Administrator</Username>
</AutoLogon>
- <Display>
<ColorDepth>32</ColorDepth>
<HorizontalResolution>1024</HorizontalResolution>
<VerticalResolution>768</VerticalResolution>
</Display>
- <OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Home</NetworkLocation>
<ProtectYourPC>1</ProtectYourPC>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
- <FirstLogonCommands>
- <SynchronousCommand wcm:action="add">
<CommandLine>%AppsRoot%install\run.cmd</CommandLine>
<Description>install programs</Description>
<Order>10</Order>
</SynchronousCommand>
- <SynchronousCommand wcm:action="add">
<Order>1</Order>
<CommandLine>cmd /c REGEDIT /S %AppsRoot%\Install\Regtweaks.reg</CommandLine>
</SynchronousCommand>
</FirstLogonCommands>
<RegisteredOrganization>Owner</RegisteredOrganization>
<RegisteredOwner>Owner</RegisteredOwner>
</component>
- <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<InputLocale>0x00000809</InputLocale>
<SystemLocale>en-us</SystemLocale>
<UILanguage>en-us</UILanguage>
<UserLocale>en-s</UserLocale>
</component>
</settings>
<cpi:offlineImage cpi:source="wim://useruse-h70gcu9/dvistawork/dvd/sources/install.wim#Windows Vista ULTIMATE" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

and heres my cmd file


Echo.....Installing things to make your computer better
Echo..........Install Winrar
start /wait %AppsRoot%install\Winrar\WINRAR.EXE /s
Echo..........Install Foxit Pdf Reader
start /wait %AppsRoot%install\Foxit\FOXITREADER30_ENU.MSI /quiet
Echo..........Install Image Burn
start /wait %AppsRoot%install\Imgburn\SetupImgBurn_2.4.2.0.exe /S
Echo..........Install Image Burn Desktop Shortcut
start /wait %AppsRoot%install\Imgburn\ImgBurn.exe
Echo..........Install Internet Firefox Browser
start /wait %AppsRoot%install\Firefox\Firefox3.0.exe -ms -ira
Echo..........InstallFlash Plugin For Firefox
start /wait %AppsRoot%install\Flashplugin\install_flash_player.exe /s
Echo..........Install Avg Virus Software
start /wait %AppsRoot%install\Avg\avg.exe /hide /no_welcome /REMOVE_FEATURE fea_AVG_SafeSurf /REMOVE_FEATURE fea_AVG_SafeSearch /NOAVGTOOLBAR
Echo..........InstallOffice 2007
start /wait %AppsRoot%install\office2007\setup.exe /config custom-uA.XML
Echo..........Install Codec Pack
start /wait %AppsRoot%install\Codec\Codec.exe
Echo..........Install Quicktime Alternative
start /wait %AppsRoot%install\quicktime\quicktimealt195lite.exe /VERYSILENT
Echo..........Finished just needs to load windows then reboot

shutdown -r -c "Rebooting For the final time."

Share this post


Link to post
Share on other sites

hey bro...

can i remove both the sysprep commands and still install the softs int he audit user mode or i have 2 remove everything.....from audit user mode and include everything in first logon??

thanx

angel

Share this post


Link to post
Share on other sites

i think if you remove sysysprep

you need to install everything in first logon

it works fine for me

hope this helps

Share this post


Link to post
Share on other sites

k buddy ill change everythign 2 first logon 2day and test it....

just having the prob with tinker and hold'em now....

thou integrated,,still cant find them anywhere....

thanx

angel

Share this post


Link to post
Share on other sites

ya sure will post the results....

1ce done...

hey bro..do u know how 2 use pkgmgr 2 install tinker....

needed help...i could expand the cab,,but m not able 2 install..it

thanx

angel

Share this post


Link to post
Share on other sites

hi

is holdem an update can it be added with vlite ?

i tryed to find the download for it but i cant

what is tinker?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...