Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Application Error:

Recommended Posts

Hi all,

I have used an nLite build for the last 1.5yrs and had this problem, and now have tried two new builds that are also experiencing the error. What happens is, when I close a program or an Explorer.exe window I get an "Application Popup:". This does not happen every time, maybe 50% of the time. The errors I get are these:

x.exe (substitute any program for 'x'):

"Application Popup: x.exe - Application Error: The application failed to initialize properly (0xc000012d). Click OK to terminate application."


"Application Popup: Proxy Desktop: Explorer.exe - Application Error: The exception unknown software exception (0x0eedfade) occurred in the application at location 0x7c812aeb.

Searching the web has not helped.

Very few addons integrated, different for each of the three builds (the first, that I used for 1.5yrs or more, had no integrated addons). I do not have Anti virus installed (no connection to that computer, currently), Internet Explorer is pulled out (though the "core" is still there). The only driver common to each build is NVIDIA graphics driver, but I believe it is a different release than I used a few years ago. I can post the configuration INI later, if it would help, but I am on a different computer at a WIFI spot, atm.

This seems to be something that I removed, or maybe a service I disabled, but I have not done anything particularly drastic; most of the core components are still there. I am not using any Tweaks that I have not used on non-nLite OS's.

I am wondering if anyone else has experienced this issue and if they resolved it. If I've managed to have this on three different builds, it must be somewhat common, no?

Any help is appreciated. As I said I do not have internet at home yet, so any replies will be slightly delayed (till I get out to a coffee shop tomorrow :)).

Share this post

Link to post
Share on other sites

Wow, great responses ya'll. *sigh* Well, at least I didn't generate any bad responses, like "did u try reboting?"

Well, anyway, I figured out the problem and will answer my own question, in the off chance that a google search will lead someone else here, and maybe this will help.

I used Sysinternals Process Explorer to watch what was happening to processes as they closed, and quickly noticed that a DLL from the Audio Shell Addon was hooking into programs when an 'open file' dialog was opened (apparently looking for media files) and not releasing when the 'open file' dialog closed. It stayed hooked to the program until said program closed, then caused the error message. This also explains why all non-explorer programs were generating the same error message: it wasn't the program, it was the hooked DLL.

Share this post

Link to post
Share on other sites

As to the first error:

# for hex 0xc000012d / decimal -1073741523
# {Out of Virtual Memory}
# Your system is low on virtual memory. To ensure that
# Windows runs properly, increase the size of your virtual
# memory paging file. For more information, see Help.
# as an HRESULT: Severity: FAILURE (1), FACILITY_NULL (0x0), Code 0x12d
# for hex 0x12d / decimal 301
# An invalid oplock acknowledgment was received by the
# system.
# 2 matches found for "0xc000012d"

So, you're either getting a virtual memory commit error when running an app, or, you've got a driver messing with the oplock code. You could disable oplocks in the registry to see if it's the former rather than the latter, of course.

As to the second error, the hex code "0x0eedfade" is a COM error, thrown in a kernel32!RaiseException, usually when a loaded .dll file causes an exception in a container process (like explorer.exe, or iexplore.exe).

Since you already know it was likely the Audio Shell Add-on, great - otherwise I would have suggested a process crash dump of explorer.exe to catch the RaiseException thread and determine the module. Also, your first post was on a Sunday, and weekend posts always take longer to get responses (most users don't log in over the weekend) - don't be surprised it takes awhile for a response.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.