Jump to content

problems with Remote Desktop from XP to Vista


Recommended Posts


I'm trying to connect to My computer (with windows vista home ultimate SP1) remotelly (from XP SP2) using Remote Desktop Client. I've allowed remote connections (screenshot 1) and added a user (screenshot 2). But I can't connect to My PC (screenshot 3). Also svchost.exe, which hosts Terminal Services not listens on 3389 port (as XP does)...

So can I fix this problem somehow?

Best regards...




Link to comment
Share on other sites

First of all i would check the firewall settings within vista to ensure that you are on a private network as it locks down the machine if it is connected to a public network.

Second make sure you are on the same network (ip in the same range and subnet the same)

Link to comment
Share on other sites

I'm accessing it by hostname. I've installed port forwarding utility (PJS PassPort) so it gives the same "from" address as My machine has. When I'm trying to connect from My work PC I'm having the same results ("error 1" when I'm connecting directly and "error 2" when I'm connecting through forwarder).

Link to comment
Share on other sites

Ive got my vista machine setup with the standard RDP port as a public port on my router and it connects fine from my office although as long as you set the RDP port correctly you can in theory set any external port as the incomming connection wich routes through to your machine

So say for example my home machine is set to the port for RDP to work is 3389 this is open by default on my machine try looking at any firewall on your machine which could be blocking this port

I have my external ip setup to (only an example) with port 380 set to forward to which allows me a connection ok from my XP laptop as from the error messages you are getting i sugest trying using only your machines ip for now and from work take the public ip from your router and try using port forwarding

Link to comment
Share on other sites

you could try chaging the port that RDP is connecting by disabling the remote desktop option in the proprties window then using regedit and editing


once done if you run


that should have changed the listening port number

Link to comment
Share on other sites

Another problem appeared (now I'm connecting from My work PC).

During connection RD Client (I've installed latest (6.1) version) says that it can't identify remote computer (screenshot 1).

But if I pressing "Yes" to proceed -- it tryes to connect and shows error that there was some problems with encryption (screenshot 2)...



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...