Jump to content

Running WPI with usb boot


Recommended Posts

Forgive me if I am posting in the wrong forum (I know there is one called "Booting xp from usb").

I made a successful unattended install for XP using nlite and wpi for my apps. So I wanted to go a step further and use a usb flash drive to make the installs faster. I used the "USBMultiBoot10" and the instructions provided by the maker and xp installs great! Right up to the part of the WPI execution. It generates a error saying:

"cannot find D:\wpi\wpi.hta"

Before I ran the install, I noticed that the USBMultiBoot10 did not copy over the WPI folder to the USB flash drive any where. So I copied it myself to where they placed my i386 folder and $OEM$ folder.

I use the runwpi.exe in the $oem$ folder and executes from the cmdlines.txt

I tried to copy the entire WPI folder over to the %systemdrive% and that did not work either.

Maybe my drive letters are all screwed up?

Maybe I should just run WPI from the flash drive?

Maybe I am completely doing this the wrong way for a USB install?

I can run WPI after the xp install finishes and windows logs on. However I would like this to execute immediatly after windows xp is done installing.

I am Noob at this. :blushing: Any help from somebody that uses USBMULTIBOOT10 and WPI would be really great.

UPDATE: I think I solved my own problem. Testing it out. Hopefully it works. If it does, what a dumb mistake.

Edited by wkkerns
Link to comment
Share on other sites

Ok, so tried to put the wpi folder to the root of the usb drive. That generated different errors.

"Could not save


"Could not save


Wpi program then starts after I click ok.

However the apps fail to install and wpi just sits idle.

Link to comment
Share on other sites

  • 3 years later...

Is it possible if I want to run WPI application without Windows installer from USB?

It means that, I don't want to use or don't have any $OEM$ folder root in my USB.

When I directly paste WPI folder into USB and I tried to run the application, the GUI gone blank.

It hasn't happened when I accessed it on my HDD. I really want to use it in the USB without Windows installer in it.

Is the solution that I have to make my USB bootable first? Or there's another way to solve it? Any suggestion?

Thank you in advance.

Link to comment
Share on other sites

For some reason it seems like your usb disk is read only...

Try these things:

Right click wpi folder and make sure that read only is NOT checked.

Re format usb drive with defualt settings.

I only use wpi from usb and don't have any issues so I can tell you that it does work fine.

Link to comment
Share on other sites

  • 1 year later...

I have the same problem I have copied all the (WPI_v8.6.3) file to the root of my usb flash (formatted with FAT32) when double click wpi.exe a window opens with no option to configure or anything else BLANK

Link to comment
Share on other sites

Why is a un-configured wpi just thrown onto a usb drive and then expected to be use-able?

There are so many things that could be wrong with this.....

Also did you read the MANUAL and LOOK for the CONFIG button????

Edited by Kelsenellenelvian
Link to comment
Share on other sites

I did extract it to a folder on the on desktop computer without doing anything and the buttons shows up so i can configure it but not on usb i will refer to the manual and see

Link to comment
Share on other sites

You can copy your customized useroptions.js inside the usb key and change the value: true to false:

On line 55 (open with notepad)

// Features tab


Maybe it's needed to change this default value inside useroptions.js ?

Tested and works!

*Edit: I see it's done inside the new attached global.js and works fine!

The line is missing inside useroptions.js created after launching WPI.exe from the usb key, the first time and will be writed when the user select:

inside Features: DoNotShowIfUSB:true

Thanks Kels.

*Edit2: It seems a line is missing inside:

optionswizard.js to do this work on: // Features tab (line 1959)


Edited by myselfidem
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...