Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


Sign in to follow this  
geezery

Problems booting HP DC7800 SFF with bootable WinPE2 USB-stick

Recommended Posts

Has anyone else had problems booting in to WinPE v.2 environment with a HP DC7800 desktop computer?

I have to retry the booting almost five times until it boots in to the system. After that there is no problems. I also had problems with the nic drivers, but I updated the newest INTEL 1000 PRO Vista drivers to BOOT.WIM and after that they where functional.

Edited by geezery

Share this post


Link to post
Share on other sites

Yup!

You can fix it by disabling "Data Execution Prevention" in the bios.

Lovely! Had the same problem. Tnx SKiNNiEH.

Share this post


Link to post
Share on other sites

Another solution is to disable DEP in the BCD-store of your USB-device.

This can be done by following theses few steps :

Boot a system into PE from your USB-stick (disable DEP in the bios if needed)

from the PE command prompt type :

- "bcdedit /store [your USB-stick driveletter]\boot\bcd"

- this will give you the contents of the BCD-store on your USB-device

- locate the entry "Window Boot Loader", there you'll find the value "identifier", wich - in my case - has the value {default}. (this could also be {Current} in your case.)

- type "bcdedit.exe /store [your USB-stick driveletter]\boot\bcd /set {default} nx AlwaysOff" (replace {default} with {current} if needed.)

- reboot your system and restore the BIOS-setting to it's original value.

This disables the Windows PE DEP-functionality completely without messing around in the BIOS.

This sollution will not only work on the HP DC7800, but also in other systems.

greets,

Peter

Share this post


Link to post
Share on other sites

The fix posted by rc00451 worked for me. Thank you for that post. I have spent two days troubleshooting all sorts of things and would never have looked at that (or known to look at it.)

What is strange is that the default winpe.wim (and BCD) must have that setting configured to ignore the DEP setting in the BIOS because my initial test build worked on everything I booted without a problem. I made a new .wim adding in the WMI, HTA and scripting packages and almost everything would boot except for the DC7800 SFF and the DC7800 UltraSlim. So, of course I spent all of my time troubleshooting the package build process and wondering if I had missed a critical formatting procedure for the USB.

Thanks again.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...