Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 


sa4720k

hivesft.inf is Corrupt

Recommended Posts

Hi,

I've spent hours trying to get my XP slipstreamed, but I keep getting an error when I try to install it on a machine. The error i get says that there is an erro on some line and that hivesft.inf is corrupt.

I've narrowed down the cause to either the "Component", "Unattended", "Options", and "Tweaks" sections. As soon as I modify even a single part of these this error comes up. I have no idea why this is happening or how to fix it. All I'm trying to do is to update an XP to SP2 with hotfixes and drivers with the Key and network information integrated. Has anyone had the same issues? If so, were you able to fix the problem? How? Any help is appreciated.

Thanks.

Share this post


Link to post
Share on other sites

I save it as the result as an ISO then I burn a cd from it. I don't touch the hivesft.inf file myself everything is done by nLite automatically and I believe it's just an unformatted text file.

Share this post


Link to post
Share on other sites

I've been having the same problem.

I don't know what 'ricktendo64' is talking about, since nLite is doing all the file saving, its completely irrelavant to the problem

I opened up hivesft.inf to take a look, and the error is cuz its parsing the line incorrectly

An entry that spans more then one line should end like XX,/ (there should be a comma in it) and the next line (the line windows installer is telling you is corrupt should be XX, WITHOUT a comma)

The way nlite is parsing it though is its carrying the comma to the second line, that it, the first line ends XX/ and the next line is , XX (Replace XX with 00 or whatever it is)

I'm 100% certain this is the cause of the error, as every other line in the entire file follows the same conventions, its just that line that

After correcting the problem though (and it happens 3-4 times in the file), the windows installer no longer complains about those lines being corrupted, but it just stops and says there was an 'internal setup error'. I'm not sure whats causing this, but if nLite incorrectly formattd the line, theres no way to know if there should be more characters in the second line (aka has nlite truncated the line? it already screwed up the syntax). I tried comparing it to the hivesft.inf from my vanilla windows disc, but the syntax that nlite uses to rewrite hivesft.inf is TOTALLY different .. so even if there was no 'internal error', I still wouldn't trust the install.

I know this post doesn't solve your problem lol, I ran into it trying to find a solution for myself, and figured i'd let you know what i've fouond out. I have tried making an image with nlite under a dozen different conditions so far (the order in which I integrate SP3, dotnet, hotfixes, tweaks, and WMP11 slipstreaming), and the exact same problem happens, at a differnt line in hivesft.inf .. but still the same problem.

If anyone has any advice I would be very grateful.

O, and, to simplify things, (you may already be doing this, I dunno), you might want to try installing VMWare (or similar), and just mounting your images, and loading a virtual machine from the mounted image ... saves burning time, coasters, and constant rebooting.

Hope someone can help, my view of nLite is quickly changing from 'a great piece of software' to 'a piece of trash that will ultimately hinder the stability of any custom windows installation I make with it"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×